From bc77fd1bc827a74237de9c0184fb3617041bc303 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Mon, 17 Jan 2011 21:08:52 -0800
Subject: system-templates:Resolves keyboard and mouse inoperability when X
 starts.

---
 abs/core/system-templates/PKGBUILD                        |  3 ++-
 abs/core/system-templates/templates/xorg/xorg.conf.ati    | 10 +++++-----
 abs/core/system-templates/templates/xorg/xorg.conf.intel  | 10 +++++-----
 abs/core/system-templates/templates/xorg/xorg.conf.vesa   | 10 +++++-----
 abs/core/system-templates/templates/xorg/xorg.conf.via    | 10 +++++-----
 abs/core/system-templates/templates/xorg/xorg.conf.vmware | 10 +++++-----
 6 files changed, 27 insertions(+), 26 deletions(-)

diff --git a/abs/core/system-templates/PKGBUILD b/abs/core/system-templates/PKGBUILD
index 94650c9..7383068 100755
--- a/abs/core/system-templates/PKGBUILD
+++ b/abs/core/system-templates/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=system-templates
 pkgver=2.0
-pkgrel=1
+pkgrel=2
 conflicts=( )
 pkgdesc="Templates used for system configuration"
 depends=()
@@ -14,3 +14,4 @@ build() {
     rsync -r --exclude=.svn ../templates $MVDIR/
 }
 
+md5sums=()
diff --git a/abs/core/system-templates/templates/xorg/xorg.conf.ati b/abs/core/system-templates/templates/xorg/xorg.conf.ati
index 529e186..ce2c25f 100644
--- a/abs/core/system-templates/templates/xorg/xorg.conf.ati
+++ b/abs/core/system-templates/templates/xorg/xorg.conf.ati
@@ -1,12 +1,12 @@
-Section "ServerFlags"
-	Option "AutoAddDevices" "False"
-EndSection
+#Section "ServerFlags"
+#	Option "AutoAddDevices" "False"
+#EndSection
 
 Section "ServerLayout"
 	Identifier     "X.org Configured"
 	Screen      0  "aticonfig-Screen[0]" 0 0
-	InputDevice    "Mouse0" "CorePointer"
-	InputDevice    "Keyboard0" "CoreKeyboard"
+#	InputDevice    "Mouse0" "CorePointer"
+#	InputDevice    "Keyboard0" "CoreKeyboard"
 EndSection
 
 Section "Files"
diff --git a/abs/core/system-templates/templates/xorg/xorg.conf.intel b/abs/core/system-templates/templates/xorg/xorg.conf.intel
index 5bc73f8..6f695d3 100644
--- a/abs/core/system-templates/templates/xorg/xorg.conf.intel
+++ b/abs/core/system-templates/templates/xorg/xorg.conf.intel
@@ -1,12 +1,12 @@
-Section "ServerFlags"
-        Option "AutoAddDevices" "False"
-EndSection
+#Section "ServerFlags"
+#        Option "AutoAddDevices" "False"
+#EndSection
 
 Section "ServerLayout"
 	Identifier     "Xorg Configured"
 	Screen      0  "Screen0" 0 0
-	InputDevice    "Keyboard0" "CoreKeyboard"
-	InputDevice    "PS/2 Mouse" "CorePointer"
+#	InputDevice    "Keyboard0" "CoreKeyboard"
+#	InputDevice    "PS/2 Mouse" "CorePointer"
 # Serial Mouse not detected
 # USB Mouse not detected
 EndSection
diff --git a/abs/core/system-templates/templates/xorg/xorg.conf.vesa b/abs/core/system-templates/templates/xorg/xorg.conf.vesa
index dbc607d..5ea0ef8 100755
--- a/abs/core/system-templates/templates/xorg/xorg.conf.vesa
+++ b/abs/core/system-templates/templates/xorg/xorg.conf.vesa
@@ -1,14 +1,14 @@
 # nvidia-xconfig: X configuration file generated by nvidia-xconfig
 # nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Tue Aug  1 21:11:12 PDT 2006
-Section "ServerFlags"
-        Option "AutoAddDevices" "False"
-EndSection
+#Section "ServerFlags"
+#        Option "AutoAddDevices" "False"
+#EndSection
 
 Section "ServerLayout"
     Identifier     "Layout0"
     Screen      0  "Screen0"
-    InputDevice    "Keyboard0" "CoreKeyboard"
-    InputDevice    "Mouse0" "CorePointer"
+#    InputDevice    "Keyboard0" "CoreKeyboard"
+#    InputDevice    "Mouse0" "CorePointer"
 EndSection
 
 Section "Files"
diff --git a/abs/core/system-templates/templates/xorg/xorg.conf.via b/abs/core/system-templates/templates/xorg/xorg.conf.via
index c18eb6f..85919c6 100644
--- a/abs/core/system-templates/templates/xorg/xorg.conf.via
+++ b/abs/core/system-templates/templates/xorg/xorg.conf.via
@@ -1,14 +1,14 @@
 # nvidia-xconfig: X configuration file generated by nvidia-xconfig
 # nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Tue Aug  1 21:11:12 PDT 2006
-Section "ServerFlags"
-        Option "AutoAddDevices" "False"
-EndSection
+#Section "ServerFlags"
+#        Option "AutoAddDevices" "False"
+#EndSection
 
 Section "ServerLayout"
     Identifier     "Layout0"
     Screen      0  "Screen0"
-    InputDevice    "Keyboard0" "CoreKeyboard"
-    InputDevice    "Mouse0" "CorePointer"
+#    InputDevice    "Keyboard0" "CoreKeyboard"
+#    InputDevice    "Mouse0" "CorePointer"
 EndSection
 
 Section "Files"
diff --git a/abs/core/system-templates/templates/xorg/xorg.conf.vmware b/abs/core/system-templates/templates/xorg/xorg.conf.vmware
index 1c038ef..ae8f34d 100755
--- a/abs/core/system-templates/templates/xorg/xorg.conf.vmware
+++ b/abs/core/system-templates/templates/xorg/xorg.conf.vmware
@@ -1,14 +1,14 @@
 # nvidia-xconfig: X configuration file generated by nvidia-xconfig
 # nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Tue Aug  1 21:11:12 PDT 2006
-Section "ServerFlags"
-        Option "AutoAddDevices" "False"
-EndSection
+#Section "ServerFlags"
+#        Option "AutoAddDevices" "False"
+#EndSection
 
 Section "ServerLayout"
     Identifier     "Layout0"
     Screen      0  "Screen0"
-    InputDevice    "Keyboard0" "CoreKeyboard"
-    InputDevice    "Mouse0" "CorePointer"
+#    InputDevice    "Keyboard0" "CoreKeyboard"
+#    InputDevice    "Mouse0" "CorePointer"
 EndSection
 
 Section "Files"
-- 
cgit v0.12