From 118c5f50c9ab1d98e9314413d64bc1ca3f8cc6c2 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 13 May 2014 19:10:13 +0000
Subject: python-mako: initial inclusion. dep of gobject-introspection

---
 abs/core/python_modules/python-mako/PKGBUILD    | 54 +++++++++++++++++++++++++
 abs/core/python_modules/python-mako/__changelog |  1 +
 2 files changed, 55 insertions(+)
 create mode 100644 abs/core/python_modules/python-mako/PKGBUILD
 create mode 100644 abs/core/python_modules/python-mako/__changelog

diff --git a/abs/core/python_modules/python-mako/PKGBUILD b/abs/core/python_modules/python-mako/PKGBUILD
new file mode 100644
index 0000000..71440e4
--- /dev/null
+++ b/abs/core/python_modules/python-mako/PKGBUILD
@@ -0,0 +1,54 @@
+# $Id$
+# Maintainer : 
+
+pkgname=('python2-mako')
+pkgver=0.9.1
+pkgrel=2
+pkgdesc="Hyperfast and lightweight templating for the Python2 platform"
+arch=('any')
+url="http://www.makotemplates.org/"
+license=('MIT')
+makedepends=('python2-setuptools')
+checkdepends=('python2-nose')
+source=(https://pypi.python.org/packages/source/M/Mako/Mako-$pkgver.tar.gz{,.asc})
+sha1sums=('aa01bafca5a835eb92a9048be92414fa83da102b'
+          'SKIP')
+
+prepare() {
+    cp -r Mako-$pkgver python2-Mako-$pkgver
+    mv Mako-$pkgver/scripts/mako-render Mako-$pkgver/scripts/python3-mako-render
+#    2to3 -nw Mako-$pkgver/scripts/python3-mako-render
+    sed -i 's/mako-render/python3-mako-render/' Mako-$pkgver/setup.py
+}
+
+build() {
+    cd Mako-$pkgver
+#    python3 setup.py build
+
+    cd ../python2-Mako-$pkgver
+    python2 setup.py build
+}
+
+check() {
+    cd Mako-$pkgver
+#    python3 setup.py test
+
+    cd ../python2-Mako-$pkgver
+    python2 setup.py test
+}
+
+#package_python-mako() {
+#    depends=('python-markupsafe' 'python-beaker')
+
+#    cd Mako-$pkgver
+#    python3 setup.py install --root="$pkgdir" --optimize=1
+#    install -D LICENSE "$pkgdir/usr/share/licenses/python-mako/COPYING"
+#}
+
+package_python2-mako() {
+    depends=('python2-markupsafe' 'python2-beaker')
+
+    cd python2-Mako-$pkgver
+    python2 setup.py install --root="$pkgdir" --optimize=1
+    install -D LICENSE "$pkgdir/usr/share/licenses/python2-mako/COPYING"
+}
diff --git a/abs/core/python_modules/python-mako/__changelog b/abs/core/python_modules/python-mako/__changelog
new file mode 100644
index 0000000..9715c21
--- /dev/null
+++ b/abs/core/python_modules/python-mako/__changelog
@@ -0,0 +1 @@
+PKGBUILD - comment out all python 3 stuff and only build for py 2
-- 
cgit v0.12