From d7fd6a71150dca90db5962f56132499b77b6a686 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Wed, 22 Aug 2012 17:25:41 -0500
Subject: LinHES-system:  add ability to run files  from /etc/X11/autostart
 when the frontend is started. minor fix with determining the window manager

---
 abs/core/LinHES-system/LinHES-session | 19 +++++++++++++++----
 abs/core/LinHES-system/PKGBUILD       | 11 +++++------
 2 files changed, 20 insertions(+), 10 deletions(-)

diff --git a/abs/core/LinHES-system/LinHES-session b/abs/core/LinHES-system/LinHES-session
index 8e5d72b..0436898 100755
--- a/abs/core/LinHES-system/LinHES-session
+++ b/abs/core/LinHES-system/LinHES-session
@@ -180,7 +180,6 @@ function show_help_tip(){
 }
 
 function notify_scan(){
-    delay_osd
     if [ -e /tmp/scan_report ]
     then
         msg "\nNew storage found. \nRun add_storage.py for details"
@@ -188,6 +187,17 @@ function notify_scan(){
 
    }
 
+function auto_start(){
+    asdir="/etc/X11/autostart"
+    for i in `ls $asdir/*`
+    do
+        if [ -x $i ]
+        then
+            echo "Starting $i"
+            $i &
+        fi
+    done
+    }
 
 function update_apple_trailers(){
     #update apple trailers
@@ -335,10 +345,10 @@ function set_background()
 {
     echo "Setting the background"
 
-    }
+}
 
 
-if [ x$WM = "x" ]
+if [ x"$WM" = "x" ]
 then
 #	fluxbox > /var/log/fluxbox.log 2>&1
     WM=fluxbox
@@ -350,12 +360,13 @@ $WM &
 pid=$!
 mouse_move
 keylaunch
-set_background
+#set_background
 unclutter
 load_nvidia_settings
 run_tilda
 start_screensaver
 notify_scan &
+auto_start &
 update_apple_trailers
 first_configure
 show_help_tip
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 2cfe372..f101864 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,12 +1,12 @@
 pkgname=LinHES-system
 pkgver=2
-pkgrel=55
+pkgrel=56
 arch=('i686' 'x86_64')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
 #install=LinHES.install
 pkgdesc="scripts and things related to having an  automated system"
-depends=(linhes-sounds xdotool tilda keylaunch python_aosd 'linhes-scripts>=7-24' 'udisks' 'LinHES-config>=2.3-59' 'sudo' 'python2-dbus')
+depends=(linhes-sounds xdotool tilda keylaunch python_aosd 'linhes-scripts>=7-24' 'udisks' 'LinHES-config>=2.3-59' 'sudo' 'python2-dbus' 'unclutter')
 backup=(etc/modprobe.d/alsa-base)
 binfiles="LinHES-start optimize_mythdb.py
  myth_mtc.py myth_mtc.sh LinHES-run
@@ -56,7 +56,7 @@ build() {
         mkdir $startdir/pkg/etc/logrotate.d
         cp $startdir/myth_mtc.lr $startdir/pkg/etc/logrotate.d
 }
-md5sums=('c5bbcfbc2b426158d90e79103a524b7c'
+md5sums=('0593b6f954ba983d8834da353d5ff0e5'
          '5881bdb43d578ec3a79d1f77ea58a3db'
          'a875ee97f86e46f34a741c2bc455f894'
          '76b2637cac0452b3acdbeeb4e8a5474b'
@@ -77,9 +77,9 @@ md5sums=('c5bbcfbc2b426158d90e79103a524b7c'
          '859a80ddb4c234506379c605114c1343'
          '47e093e8cfe4b5b96602358e1f540832'
          '6faeba0aeb38e772121f751cabda8683'
-         '8fb300778c0d9f03edb92fdd3d9f9158'
+         'b11fee9a8749602ebc2d59b48aec13ae'
          '6519d209e151cdc39ae7e1091d189c3e'
-         'd318ea06dacdfe7a474121eac1f75be0'
+         'a98d41e6d9286d01cc99a32db3cbc397'
          '4a3cd8f9b33b2b86fdba47a8f1fa2859'
          '717b80d5069188ccef52001de0df0c21'
          'a182af47a7d373b2a63a27e1bb7485b2'
@@ -88,6 +88,5 @@ md5sums=('c5bbcfbc2b426158d90e79103a524b7c'
          'eb879fee9603a05d5420d4ce8ed9e450'
          'f1870a9522c79e6b248fcbf81dec3280'
          '84492954db16740f949d795b74383189'
-         'abe887472a170bd1a8e6da6a7b7e93e4'
          '02c810c2f47b7c4495fdacaf54189473'
          '93a2af3e723f36c063623f705330d337')
-- 
cgit v0.12