From a6bb890dc7c9f5679377077d7dce76da9db7d4dc Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 24 Apr 2012 14:07:00 -0500
Subject: mythweb: modified to use git_src_checkout

---
 abs/core/mythtv/stable-0.25/mythweb/PKGBUILD | 33 +++++++++++++++++++++-------
 1 file changed, 25 insertions(+), 8 deletions(-)

diff --git a/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD b/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD
index cab8fbd..f78c224 100644
--- a/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD
+++ b/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD
@@ -1,24 +1,41 @@
 pkgname=mythweb
-pkgver=0.24
-pkgrel=16
-pkgdesc="Web interface for MythTV's backend"
+pkgver=0.25
+pkgrel=1
+
+commit_hash=`cat ../git_src/git_hash_web`
+
+pkgdesc="Web interface for MythTV's backend, $commit_hash"
 url="http://www.mythtv.org"
 license="GPL"
 arch=('i686' 'x86_64')
 
-depends=('mythtv>=0.24' 'lighttpd' 'php' 'local-website')
+depends=('mythtv>=0.25' 'lighttpd' 'php' 'local-website')
 groups=('mythtv-extras')
 
 patches=()
-source=('ftp://ftp.knoppmyth.net/R6/sources/mythweb-0.24-fixes.tar.bz2' `echo ${patches[@]:0}`)
+source=(`echo ${patches[@]:0}`)
 
 DOCROOT=/data/srv/httpd/htdocs/mythweb
-_gitroot="https://github.com/mythtv/mythweb.git"
-_gitname="${pkgname}"
 build() {
 
+   if [ -e ${srcdir}/mythweb ]
+      then
+          rm -rf ${srcdir}/mythweb
+      fi
+  
+      cd ${startdir}
+      msg "copy in myth web src"
+      cp -rp ../git_src/mythweb $srcdir
+      cd ${srcdir}/${pkgbase}
+  
+  
+  
+    msg "The local files are updated."
+
+
 	cd $startdir/src/mythweb
-	git pull
+
+
 
 	echo "--------------------------applying patches----------------------------------------------------"
 	for i in `echo ${patches[@]:0} `
-- 
cgit v0.12