From 1d451012eab8135bc14fe0c50aa179c9b8a1bf79 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Mon, 27 Dec 2010 19:48:07 -0800
Subject: libssh:initial inclusion.  Dep of XBMC.

---
 abs/extra/libssh/PKGBUILD    | 31 +++++++++++++++++++++++++++++++
 abs/extra/libssh/__changelog |  1 +
 2 files changed, 32 insertions(+)
 create mode 100644 abs/extra/libssh/PKGBUILD
 create mode 100644 abs/extra/libssh/__changelog

diff --git a/abs/extra/libssh/PKGBUILD b/abs/extra/libssh/PKGBUILD
new file mode 100644
index 0000000..f70c291
--- /dev/null
+++ b/abs/extra/libssh/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id$
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: ice-man <icemanf@gmail.com>
+# Contributor: sergeantspoon <sergeantspoon@archlinux.us>
+
+pkgname=libssh
+pkgver=0.4.6
+pkgrel=2
+pkgdesc="Library for accessing ssh client services through C libraries"
+url="http://www.libssh.org/"
+license=('LGPL')
+arch=('i686' 'x86_64')
+depends=('openssl')
+makedepends=('cmake' 'doxygen')
+source=("http://www.libssh.org/files/0.4/${pkgname}-${pkgver}.tar.gz")
+md5sums=('9efdc8911fdb150fb16500c2fbe4ef2e')
+
+build() {
+  cd ${srcdir}
+  mkdir build
+  cd build
+  cmake ../${pkgname}-${pkgver} \
+    -DCMAKE_INSTALL_PREFIX=/usr \
+    -DCMAKE_BUILD_TYPE=Release
+  make
+}
+
+package(){
+  cd ${srcdir}/build
+  make DESTDIR=${pkgdir} install
+}
diff --git a/abs/extra/libssh/__changelog b/abs/extra/libssh/__changelog
new file mode 100644
index 0000000..9e60b2f
--- /dev/null
+++ b/abs/extra/libssh/__changelog
@@ -0,0 +1 @@
+12/27/10 - chw - fixed URL for source
-- 
cgit v0.12