From 27f7a8d911d79a795090322892f0b831a5de714a Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 2 Jan 2015 22:16:24 +0000
Subject: Revert "plymouth: update to 0.9.0"

This reverts commit d5cb134735305134af8410f00768adf4b5254c91.
---
 abs/core/plymouth/PKGBUILD                         | 120 +++++++++---------
 abs/core/plymouth/gdm-plymouth.service             |  14 +--
 abs/core/plymouth/kdm-plymouth.service             |   8 +-
 abs/core/plymouth/lightdm-plymouth.service         |  15 +--
 abs/core/plymouth/lxdm-plymouth.service            |  11 +-
 abs/core/plymouth/plymouth-quit.service.in.patch   |  14 ---
 .../plymouth/plymouth-set-default-theme.in.patch   |   5 +-
 abs/core/plymouth/plymouth-start.service           |  16 ---
 abs/core/plymouth/plymouth-update-initrd.patch     |  11 +-
 abs/core/plymouth/plymouth.encrypt_hook            | 134 ---------------------
 abs/core/plymouth/plymouth.encrypt_install         |  49 --------
 abs/core/plymouth/plymouth.initcpio_hook           |  29 ++---
 abs/core/plymouth/plymouth.initcpio_install        |  10 +-
 abs/core/plymouth/slim-plymouth.service            |   6 +-
 abs/core/plymouth/system-release                   |   1 +
 15 files changed, 116 insertions(+), 327 deletions(-)
 delete mode 100644 abs/core/plymouth/plymouth-quit.service.in.patch
 delete mode 100644 abs/core/plymouth/plymouth-start.service
 delete mode 100644 abs/core/plymouth/plymouth.encrypt_hook
 delete mode 100644 abs/core/plymouth/plymouth.encrypt_install
 create mode 100644 abs/core/plymouth/system-release

diff --git a/abs/core/plymouth/PKGBUILD b/abs/core/plymouth/PKGBUILD
index 2563333..6126d4f 100644
--- a/abs/core/plymouth/PKGBUILD
+++ b/abs/core/plymouth/PKGBUILD
@@ -1,84 +1,74 @@
-#
-# Maintainer: Damian01w <damian01w@gmail.com>
-# Maintainer: Padfoot <padfoot@exemail.com.au>
-#
-
 pkgname=plymouth
-pkgver=0.9.0
-pkgrel=5
-pkgdesc="A graphical boot splash screen with kernel mode-setting support"
-url="http://www.freedesktop.org/wiki/Software/Plymouth/"
-
+pkgver=0.8.8.52.g37d2e40
+pkgrel=4
+pkgdesc="A graphical boot splash screen with kernel mode-setting support (Git version)"
+url="http://cgit.freedesktop.org/cgit/plymouth/"
 arch=('i686' 'x86_64')
 license=('GPL')
-
 depends=('libdrm' 'pango' 'v86d')
-makedepends=('docbook-xsl')
+makedepends=('git' 'docbook-xsl')
 optdepends=('ttf-dejavu')
-
 options=('!libtool' '!emptydirs')
-
+install=$pkgname.install
+groups=('base')
 provides=('plymouth')
-conflicts=('plymouth-git')
+conflicts=('plymouth')
 backup=('etc/plymouth/plymouthd.conf')
 
-source=("http://www.freedesktop.org/software/${pkgname}/releases/${pkgname}-${pkgver}.tar.bz2" 
+source=('git://anongit.freedesktop.org/plymouth'
         'arch-logo.png'
-        'plymouth.encrypt_hook'
-        'plymouth.encrypt_install'
+        'encrypt_hook'
+        'encrypt_install'
         'gdm-plymouth.service'
         'kdm-plymouth.service'
+        'kdm-unpatched-plymouth.service'
         'lxdm-plymouth.service'
         'lightdm-plymouth.service'
         'slim-plymouth.service'
+        'plymouth.functions'
+        "$pkgname.install"
         'plymouth.initcpio_hook'
         'plymouth.initcpio_install'
-        'plymouth-start.service'
-        'plymouth-quit.service.in.patch'
+        'plymouth-quit.service'
         'plymouth-set-default-theme.in.patch'
-        'plymouth-update-initrd.patch')
+        'plymouth-update-initrd.patch'
+        'plymouthd.conf'
+        'system-release')
         
-md5sums=('147150705417f025d036304e97e33c9c'
-         '65fa2763d5c9bb9f80973ea5e6e3db3e'
-         'fbdd5d04e3089a214b9056357434df86'
-         '65eb269910f1b81e3f0970af456394ca'
-         'e336aa51a5b781026ce541c046ee9131'
-         'dcacff05835053242f52b9e375248ec3'
-         '22130f7e6b20d2a43dbed924de75180b'
-         '870ea3e63c6989e2badf79d1fbafa914'
-         'fb2eb948e2198cfb54cc2b710a05ee61'
-         '32f04fdbd1eb94ade30d1e63fdcdd9b5'
-         'a6dca3d57fd38b875d0520ec033dbf66'
-         '78340207f7391c682601b1b36baed14d'
-         '165a39dbedcc6e123c8ca05d5b4b2e25'
-         'f79edbbb30c71b0dbcd102c7dd31660b'
-         '0357775c16b5f90f1af485e6a4c80a9e')
+pkgver() {
+	cd "$srcdir"/${pkgname%%-*}
+	git describe --always | sed 's/-/./g'
+}
 
 prepare() {
-	cd "$srcdir"/${pkgname}-${pkgver}
+	cd "$srcdir"/${pkgname%%-*}
+	
+	patch -Np0 -i ../plymouth-set-default-theme.in.patch
+	patch -Np0 -i ../plymouth-update-initrd.patch
 	
-	patch -p1 -i $srcdir/plymouth-set-default-theme.in.patch
-	patch -p1 -i $srcdir/plymouth-update-initrd.patch
-	patch -p1 -i $srcdir/plymouth-quit.service.in.patch
+	sed -e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:g' \
+	-i src/libply-splash-graphics/ply-image.c
+	
+	test -f Makefile && make distclean
+	
+	return 0
 }
 
 build() {
-	cd "$srcdir"/${pkgname}-${pkgver}
-	
-	LDFLAGS="$LDFLAGS -ludev" ./configure --prefix=/usr \
+	cd "$srcdir"/${pkgname%%-*}
+
+	./autogen.sh --prefix=/usr \
 		--exec-prefix=/usr \
 		--sysconfdir=/etc \
 		--localstatedir=/var \
 		--libdir=/usr/lib \
 		--libexecdir=/usr/lib \
 		--sbindir=/usr/bin \
-		--enable-drm \
+		--enable-drm-renderer \
 		--enable-tracing \
 		--enable-pango \
-		--enable-gtk=no \
-		--with-release-file=/etc/os-release \
+		--with-gdm-autostart-file=yes \
 		--with-logo=/usr/share/plymouth/arch-logo.png \
-		--with-background-color=0x000000 \
 		--with-background-start-color-stop=0x000000 \
 		--with-background-end-color-stop=0x4D4D4D \
 		--without-rhgb-compat-link \
@@ -88,21 +78,41 @@ build() {
 }
 
 package() {
-  cd "$srcdir"/${pkgname}-${pkgver}
+  cd "$srcdir"/${pkgname%%-*}
 
   make DESTDIR="$pkgdir" install
 
   install -Dm644 "$srcdir/arch-logo.png"             "$pkgdir/usr/share/plymouth/arch-logo.png"
-  install -Dm644 "$srcdir/plymouth.encrypt_hook"     "$pkgdir/usr/lib/initcpio/hooks/plymouth-encrypt"
-  install -Dm644 "$srcdir/plymouth.encrypt_install"  "$pkgdir/usr/lib/initcpio/install/plymouth-encrypt"
+  install -Dm644 "$srcdir/encrypt_hook"              "$pkgdir/usr/lib/initcpio/hooks/plymouth-encrypt"
+  install -Dm644 "$srcdir/encrypt_install"           "$pkgdir/usr/lib/initcpio/install/plymouth-encrypt"
+  install -Dm644 "$srcdir/plymouth.functions"        "$pkgdir/etc/rc.d/functions.d/plymouth.functions"
   install -Dm644 "$srcdir/plymouth.initcpio_hook"    "$pkgdir/usr/lib/initcpio/hooks/plymouth"
   install -Dm644 "$srcdir/plymouth.initcpio_install" "$pkgdir/usr/lib/initcpio/install/plymouth"
+  install -Dm644 "$srcdir/plymouthd.conf"            "$pkgdir/etc/plymouth/plymouthd.conf"
+  install -Dm644 "$srcdir/system-release"            "$pkgdir/etc/system-release"
 
-  for i in {gdm,kdm,lxdm,slim,lightdm}-plymouth.service; do
+  # Plymouth<->systemd integration, including units for DMs
+  for i in {{gdm,kdm{,-unpatched},lxdm,slim,lightdm}-plymouth,plymouth-quit}.service; do
     install -Dm644 "$srcdir/$i" "$pkgdir/usr/lib/systemd/system/$i"
   done
-
-  install -Dm644 "$srcdir/plymouth-start.service" "$pkgdir/usr/lib/systemd/system/plymouth-start.service"
-  cp "$pkgdir/usr/share/plymouth/plymouthd.defaults" "$pkgdir/etc/plymouth/plymouthd.conf"
+  
 }
-
+md5sums=('SKIP'
+         '65fa2763d5c9bb9f80973ea5e6e3db3e'
+         '79613b70a0a0be4c33978ef37c30f00a'
+         '65eb269910f1b81e3f0970af456394ca'
+         '34d0ed7bbcb3d0ea498de24bc17b2ee9'
+         '75ec0ac73eb9a1e3f6104df64520d431'
+         'ceec65ce58accdb270f3eaa23d794b4a'
+         '62c3b4e894330a2ca4c2b8fbcaba083c'
+         'e6d573b1913f3aa020cbde3863ee80f0'
+         '225b953976e1c824f62ba406a63c18c7'
+         'f0110fba1e77cd22c32d1727399d0b8a'
+         '95e987cfbc2d30a2cea215394eb9ac20'
+         '4f3be343eea9956bbc94d615d5f41def'
+         '7f21ba9a85733ff945c23012cff55a89'
+         '3bb0b8008edfad9e23703674341766a0'
+         '42fddd683720dbacbe6e30b4b7892f3c'
+         '412a1a89ca960370071746b0af8c0ac5'
+         '37479b134827dc307b3c55bfb2711e99'
+         'ab8a557d10f74bec5c94ed6cae34729c')
diff --git a/abs/core/plymouth/gdm-plymouth.service b/abs/core/plymouth/gdm-plymouth.service
index d44d9f3..d58c0e9 100644
--- a/abs/core/plymouth/gdm-plymouth.service
+++ b/abs/core/plymouth/gdm-plymouth.service
@@ -1,15 +1,13 @@
 [Unit]
 Description=GNOME Display Manager
-Conflicts=getty@tty1.service
-After=systemd-user-sessions.service getty@tty1.service
+After=systemd-user-sessions.service
+
+Conflicts=plymouth-quit.service
+After=plymouth-quit.service
 
 [Service]
-ExecStart=/usr/bin/gdm
-Restart=always
-IgnoreSIGPIPE=no
-BusName=org.gnome.DisplayManager
+ExecStart=/usr/sbin/gdm -nodaemon
 StandardOutput=syslog
-StandardError=inherit
 
 [Install]
-Alias=display-manager.service
\ No newline at end of file
+Alias=display-manager.service
diff --git a/abs/core/plymouth/kdm-plymouth.service b/abs/core/plymouth/kdm-plymouth.service
index 5292ba6..a9e9142 100644
--- a/abs/core/plymouth/kdm-plymouth.service
+++ b/abs/core/plymouth/kdm-plymouth.service
@@ -1,12 +1,12 @@
 [Unit]
 Description=K Display Manager
-Conflicts=getty@tty1.service plymouth-quit.service
-After=systemd-user-sessions.service getty@tty1.service plymouth-quit.service
+After=systemd-user-sessions.service
+
+Conflicts=plymouth-quit.service
+After=plymouth-quit.service
 
 [Service]
 ExecStart=/usr/bin/kdm -nodaemon
-Restart=always
-IgnoreSIGPIPE=no
 StandardOutput=syslog
 
 [Install]
diff --git a/abs/core/plymouth/lightdm-plymouth.service b/abs/core/plymouth/lightdm-plymouth.service
index a845498..47ec47e 100644
--- a/abs/core/plymouth/lightdm-plymouth.service
+++ b/abs/core/plymouth/lightdm-plymouth.service
@@ -1,13 +1,14 @@
 [Unit]
-Description=Light Display Manager
-Conflicts=getty@tty1.service plymouth-quit.service
-After=systemd-user-sessions.service getty@tty1.service plymouth-quit.service
+Description=LightDM Display Manager
+After=systemd-user-sessions.service
+
+Conflicts=plymouth-quit.service
+After=plymouth-quit.service
 
 [Service]
-ExecStart=/usr/bin/lightdm
-Restart=always
-IgnoreSIGPIPE=no
-BusName=org.freedesktop.DisplayManager
+ExecStart=/usr/sbin/lightdm
+StandardOutput=syslog
 
 [Install]
+WantedBy=graphical.target
 Alias=display-manager.service
diff --git a/abs/core/plymouth/lxdm-plymouth.service b/abs/core/plymouth/lxdm-plymouth.service
index bf4a0a8..dc6b000 100644
--- a/abs/core/plymouth/lxdm-plymouth.service
+++ b/abs/core/plymouth/lxdm-plymouth.service
@@ -1,12 +1,13 @@
 [Unit]
 Description=LXDE Display Manager
-Conflicts=getty@tty1.service plymouth-quit.service
-After=systemd-user-sessions.service getty@tty1.service plymouth-quit.service
+After=systemd-user-sessions.service
+
+Conflicts=plymouth-quit.service
+After=plymouth-quit.service
 
 [Service]
-ExecStart=/usr/sbin/lxdm
-Restart=always
-IgnoreSIGPIPE=no
+ExecStart=/usr/sbin/lxdm >/dev/null 2>&1 </dev/null
+StandardOutput=syslog
 
 [Install]
 Alias=display-manager.service
diff --git a/abs/core/plymouth/plymouth-quit.service.in.patch b/abs/core/plymouth/plymouth-quit.service.in.patch
deleted file mode 100644
index ec3435c..0000000
--- a/abs/core/plymouth/plymouth-quit.service.in.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -aur plymouth-0.8.8.src/systemd-units/plymouth-quit.service.in plymouth-0.8.8.patch/systemd-units/plymouth-quit.service.in
---- plymouth-0.8.8.src/systemd-units/plymouth-quit.service.in	2012-09-27 02:50:53.000000000 +1000
-+++ plymouth-0.8.8.patch/systemd-units/plymouth-quit.service.in	2014-02-11 16:36:58.813194805 +1100
-@@ -1,8 +1,9 @@
- [Unit]
- Description=Terminate Plymouth Boot Screen
- After=rc-local.service plymouth-start.service systemd-user-sessions.service
-+Before=getty@tty1.service
- 
- [Service]
--ExecStart=-@PLYMOUTH_CLIENT_DIR@/plymouth quit
-+ExecStart=-@PLYMOUTH_CLIENT_DIR@/plymouth quit --retain-splash
- Type=oneshot
- TimeoutSec=20
diff --git a/abs/core/plymouth/plymouth-set-default-theme.in.patch b/abs/core/plymouth/plymouth-set-default-theme.in.patch
index 808a644..21f975d 100644
--- a/abs/core/plymouth/plymouth-set-default-theme.in.patch
+++ b/abs/core/plymouth/plymouth-set-default-theme.in.patch
@@ -1,6 +1,5 @@
-diff -aur plymouth-0.8.8.src/scripts/plymouth-set-default-theme.in plymouth-0.8.8.patch/scripts/plymouth-set-default-theme.in
---- plymouth-0.8.8.src/scripts/plymouth-set-default-theme.in	2012-10-27 02:01:45.000000000 +1100
-+++ plymouth-0.8.8.patch/scripts/plymouth-set-default-theme.in	2014-01-26 09:55:34.337189615 +1100
+--- scripts/plymouth-set-default-theme.ina	2012-07-15 12:16:53.083156390 +0300
++++ scripts/plymouth-set-default-theme.in	2012-07-15 12:17:32.715893173 +0300
 @@ -173,7 +173,10 @@
          exit $?
  fi
diff --git a/abs/core/plymouth/plymouth-start.service b/abs/core/plymouth/plymouth-start.service
deleted file mode 100644
index b0f442f0..0000000
--- a/abs/core/plymouth/plymouth-start.service
+++ /dev/null
@@ -1,16 +0,0 @@
-[Unit]
-Description=Show Plymouth Boot Screen
-DefaultDependencies=no
-Wants=systemd-ask-password-plymouth.path systemd-vconsole-setup.service
-After=systemd-vconsole-setup.service systemd-udev-trigger.service systemd-udevd.service
-Before=systemd-ask-password-plymouth.service
-ConditionKernelCommandLine=!plymouth.enable=0
-
-[Service]
-ExecStart=/usr/bin/plymouthd --mode=boot --pid-file=/run/plymouth/pid --attach-to-session
-ExecStartPost=-/usr/bin/plymouth show-splash
-Type=forking
-KillMode=none
-SendSIGKILL=no
-[Install]
-WantedBy=sysinit.target
diff --git a/abs/core/plymouth/plymouth-update-initrd.patch b/abs/core/plymouth/plymouth-update-initrd.patch
index 47d88a6..c307199 100644
--- a/abs/core/plymouth/plymouth-update-initrd.patch
+++ b/abs/core/plymouth/plymouth-update-initrd.patch
@@ -1,9 +1,8 @@
-diff -aur plymouth-0.9.0.src/scripts/plymouth-update-initrd plymouth-0.9.0.patch/scripts/plymouth-update-initrd
---- plymouth-0.9.0.src/scripts/plymouth-update-initrd	2014-01-16 08:14:47.000000000 +1100
-+++ plymouth-0.9.0.patch/scripts/plymouth-update-initrd	2014-05-21 19:04:16.802594001 +1000
+--- scripts/plymouth-update-initrd.old 2013-10-27 17:02:15.200368142 +0900
++++ scripts/plymouth-update-initrd 2013-10-27 17:02:57.686768138 +0900
 @@ -1,2 +1,4 @@
- #!/bin/bash
--dracut -f
+#!/bin/bash
+-dracut -f /boot/initramfs-$(uname -r).img $(uname -r)
 +find /etc/mkinitcpio.d/ -name \*.preset -a \! -name example.preset | while read p; do
-+  mkinitcpio -p $p
++ mkinitcpio -p $p
 +done
diff --git a/abs/core/plymouth/plymouth.encrypt_hook b/abs/core/plymouth/plymouth.encrypt_hook
deleted file mode 100644
index 963cc06..0000000
--- a/abs/core/plymouth/plymouth.encrypt_hook
+++ /dev/null
@@ -1,134 +0,0 @@
-#!/bin/bash
-
-run_hook() {
-    modprobe -a -q dm-crypt >/dev/null 2>&1
-    [ "${quiet}" = "y" ] && CSQUIET=">/dev/null"
-
-    # Get keyfile if specified
-    ckeyfile="/crypto_keyfile.bin"
-    if [ -n "$cryptkey" ]; then
-        IFS=: read ckdev ckarg1 ckarg2 <<EOF
-$cryptkey
-EOF
-
-        if [ "$ckdev" = "rootfs" ]; then
-            ckeyfile=$ckarg1
-        elif resolved=$(resolve_device "${ckdev}" ${rootdelay}); then
-            case ${ckarg1} in
-                *[!0-9]*)
-                    # Use a file on the device
-                    # ckarg1 is not numeric: ckarg1=filesystem, ckarg2=path
-                    mkdir /ckey
-                    mount -r -t "$ckarg1" "$resolved" /ckey
-                    dd if="/ckey/$ckarg2" of="$ckeyfile" >/dev/null 2>&1
-                    umount /ckey
-                    ;;
-                *)
-                    # Read raw data from the block device
-                    # ckarg1 is numeric: ckarg1=offset, ckarg2=length
-                    dd if="$resolved" of="$ckeyfile" bs=1 skip="$ckarg1" count="$ckarg2" >/dev/null 2>&1
-                    ;;
-            esac
-        fi
-        [ ! -f ${ckeyfile} ] && echo "Keyfile could not be opened. Reverting to passphrase."
-    fi
-
-    if [ -n "${cryptdevice}" ]; then
-        DEPRECATED_CRYPT=0
-        IFS=: read cryptdev cryptname cryptoptions <<EOF
-$cryptdevice
-EOF
-    else
-        DEPRECATED_CRYPT=1
-        cryptdev="${root}"
-        cryptname="root"
-    fi
-
-    warn_deprecated() {
-        echo "The syntax 'root=${root}' where '${root}' is an encrypted volume is deprecated"
-        echo "Use 'cryptdevice=${root}:root root=/dev/mapper/root' instead."
-    }
-
-    for cryptopt in ${cryptoptions//,/ }; do
-        case ${cryptopt} in
-            allow-discards)
-                cryptargs="${cryptargs} --allow-discards"
-                ;;
-            *)
-                echo "Encryption option '${cryptopt}' not known, ignoring." >&2
-                ;;
-        esac
-    done
-
-    if resolved=$(resolve_device "${cryptdev}" ${rootdelay}); then
-        if cryptsetup isLuks ${resolved} >/dev/null 2>&1; then
-            [ ${DEPRECATED_CRYPT} -eq 1 ] && warn_deprecated
-            dopassphrase=1
-            # If keyfile exists, try to use that
-            if [ -f ${ckeyfile} ]; then
-                if eval cryptsetup --key-file ${ckeyfile} luksOpen ${resolved} ${cryptname} ${cryptargs} ${CSQUIET}; then
-                    dopassphrase=0
-                else
-                    echo "Invalid keyfile. Reverting to passphrase."
-                fi
-            fi
-            # Ask for a passphrase
-            if [ ${dopassphrase} -gt 0 ]; then
-                echo
-                echo "A password is required to access the ${cryptname} volume:"
-                plymouth ask-for-password --prompt="Password for ${cryptname} volume" --dont-pause-progress --number-of-tries=5 --command="/sbin/cryptsetup luksOpen --key-file=- ${cryptdev} ${cryptname} ${cryptargs} ${CSQUIET}"
-                sleep 2
-            fi
-            if [ -e "/dev/mapper/${cryptname}" ]; then
-                if [ ${DEPRECATED_CRYPT} -eq 1 ]; then
-                    export root="/dev/mapper/root"
-                fi
-            else
-                err "Password succeeded, but ${cryptname} creation failed, aborting..."
-                exit 1
-            fi
-        elif [ -n "${crypto}" ]; then
-            [ ${DEPRECATED_CRYPT} -eq 1 ] && warn_deprecated
-            msg "Non-LUKS encrypted device found..."
-            if echo "$crypto" | awk -F: '{ exit(NF == 5) }'; then
-                err "Verify parameter format: crypto=hash:cipher:keysize:offset:skip"
-                err "Non-LUKS decryption not attempted..."
-                return 1
-            fi
-            exe="cryptsetup create $cryptname $resolved $cryptargs"
-            IFS=: read c_hash c_cipher c_keysize c_offset c_skip <<EOF
-$crypto
-EOF
-            [ -n "$c_hash" ]    && exe="$exe --hash '$c_hash'"
-            [ -n "$c_cipher" ]  && exe="$exe --cipher '$c_cipher'"
-            [ -n "$c_keysize" ] && exe="$exe --key-size '$c_keysize'"
-            [ -n "$c_offset" ]  && exe="$exe --offset '$c_offset'"
-            [ -n "$c_skip" ]    && exe="$exe --skip '$c_skip'"
-            if [ -f "$ckeyfile" ]; then
-                exe="$exe --key-file $ckeyfile"
-            else
-                exe="$exe --verify-passphrase"
-                echo ""
-                echo "A password is required to access the ${cryptname} volume:"
-            fi
-            eval "$exe $CSQUIET"
-
-            if [ $? -ne 0 ]; then
-                err "Non-LUKS device decryption failed. verify format: "
-                err "      crypto=hash:cipher:keysize:offset:skip"
-                exit 1
-            fi
-            if [ -e "/dev/mapper/${cryptname}" ]; then
-                if [ ${DEPRECATED_CRYPT} -eq 1 ]; then
-                    export root="/dev/mapper/root"
-                fi
-            else
-                err "Password succeeded, but ${cryptname} creation failed, aborting..."
-                exit 1
-            fi
-        else
-            err "Failed to open encryption mapping: The device ${cryptdev} is not a LUKS volume and the crypto= paramater was not specified."
-        fi
-    fi
-    rm -f ${ckeyfile}
-}
diff --git a/abs/core/plymouth/plymouth.encrypt_install b/abs/core/plymouth/plymouth.encrypt_install
deleted file mode 100644
index 5258a0b..0000000
--- a/abs/core/plymouth/plymouth.encrypt_install
+++ /dev/null
@@ -1,49 +0,0 @@
-#!/bin/bash
-
-build() {
-    local mod
-
-    add_module dm-crypt
-    if [[ $CRYPTO_MODULES ]]; then
-        for mod in $CRYPTO_MODULES; do
-            add_module "$mod"
-        done
-    else
-        add_all_modules '/crypto/'
-    fi
-
-    add_binary "cryptsetup"
-    add_binary "dmsetup"
-    add_file "/usr/lib/udev/rules.d/10-dm.rules"
-    add_file "/usr/lib/udev/rules.d/13-dm-disk.rules"
-    add_file "/usr/lib/udev/rules.d/95-dm-notify.rules"
-    add_file "/usr/lib/initcpio/udev/11-dm-initramfs.rules" "/usr/lib/udev/rules.d/11-dm-initramfs.rules"
-    add_binary "/usr/lib/plymouth/label.so"
-    add_binary "/usr/lib/plymouth/text.so"
-    add_file "/usr/share/fonts/TTF/DejaVuSans.ttf"
-    add_file "/etc/fonts/fonts.conf"
-    add_file "/etc/fonts/conf.d/60-latin.conf"
-
-    add_runscript
-}
-
-help() {
-    cat <<HELPEOF
-This hook allows for an encrypted root device. Users should specify the device
-to be unlocked using 'cryptdevice=device:dmname' on the kernel command line,
-where 'device' is the path to the raw device, and 'dmname' is the name given to
-the device after unlocking, and will be available as /dev/mapper/dmname.
-
-For unlocking via keyfile, 'cryptkey=device:fstype:path' should be specified on
-the kernel cmdline, where 'device' represents the raw block device where the key
-exists, 'fstype' is the filesystem type of 'device' (or auto), and 'path' is
-the absolute path of the keyfile within the device.
-
-Without specifying a keyfile, you will be prompted for the password at runtime.
-This means you must have a keyboard available to input it, and you may need
-the keymap hook as well to ensure that the keyboard is using the layout you
-expect.
-HELPEOF
-}
-
-# vim: set ft=sh ts=4 sw=4 et:
diff --git a/abs/core/plymouth/plymouth.initcpio_hook b/abs/core/plymouth/plymouth.initcpio_hook
index 3d7ec1d..d527f24 100644
--- a/abs/core/plymouth/plymouth.initcpio_hook
+++ b/abs/core/plymouth/plymouth.initcpio_hook
@@ -1,23 +1,16 @@
-run_earlyhook(){
-        # first trigger graphics subsystem
-        udevadm trigger --action=add --attr-match=class=0x030000 >/dev/null 2>&1
-        # first trigger graphics and tty subsystem
-        udevadm trigger --action=add --subsystem-match=graphics --subsystem-match=drm --subsystem-match=tty >/dev/null 2>&1
- 
-        udevadm settle --timeout=30 2>&1
-       
-	/usr/bin/mknod /dev/fb c 29 &>/dev/null
-        /usr/bin/mkdir -p /dev/pts
-        /usr/bin/mount -t devpts -o noexec,nosuid,gid=5,mode=0620 devpts /dev/pts || true
-        /usr/bin/plymouthd --mode=boot --pid-file=/run/plymouth/pid --attach-to-session
-}
- 
 run_hook() {
+        msg -n ":: Loading plymouth..."
+
+        /bin/mknod /dev/fb c 29 0 &>/dev/null
+        #/bin/mount devpts /dev/pts -t devpts
+
+        # plymouth deamon
+        #/bin/mkdir -p /run/plymouth
+        /usr/sbin/plymouthd --mode=boot --pid-file=/run/plymouth.pid
+
+        # plymouth frontend
         /usr/bin/plymouth --show-splash
-}
- 
-run_latehook(){
-        /usr/bin/plymouth update-root-fs --new-root-dir=/new_root      
+        msg "done."
 }
 
 # vim: set ft=sh:
diff --git a/abs/core/plymouth/plymouth.initcpio_install b/abs/core/plymouth/plymouth.initcpio_install
index 40838ac..22cc298 100644
--- a/abs/core/plymouth/plymouth.initcpio_install
+++ b/abs/core/plymouth/plymouth.initcpio_install
@@ -1,7 +1,6 @@
 build() {
 	add_dir /dev/pts
 	add_dir /usr/share/plymouth/themes
-	add_dir /var/run/plymouth
 
 	DATADIR="/usr/share"
 	PLYMOUTH_LOGO_FILE="${DATADIR}/plymouth/arch-logo.png"
@@ -17,10 +16,11 @@ build() {
 	add_file ${DATADIR}/plymouth/themes/details/details.plymouth
 	add_binary ${PLYMOUTH_PLUGIN_PATH}/details.so
 
+
 	add_file "${PLYMOUTH_LOGO_FILE}"
-	add_file /etc/os-release
+	add_file /etc/system-release /etc/system-release
 	add_file /etc/plymouth/plymouthd.conf
-    add_file ${DATADIR}/plymouth/plymouthd.defaults
+        add_file ${DATADIR}/plymouth/plymouthd.defaults
 
 	if [ ! -f ${PLYMOUTH_PLUGIN_PATH}/${PLYMOUTH_MODULE_NAME}.so ]; then
 	    echo "The default plymouth plugin (${PLYMOUTH_MODULE_NAME}) doesn't exist" > /dev/stderr
@@ -30,6 +30,7 @@ build() {
 	add_binary ${PLYMOUTH_PLUGIN_PATH}/${PLYMOUTH_MODULE_NAME}.so
 
 	add_binary ${PLYMOUTH_PLUGIN_PATH}/renderers/drm.so
+	#add_binary ${PLYMOUTH_PLUGIN_PATH}/renderers/x11.so
 	add_binary ${PLYMOUTH_PLUGIN_PATH}/renderers/frame-buffer.so
 
 	if [ -d ${DATADIR}/plymouth/themes/${PLYMOUTH_THEME_NAME} ]; then
@@ -38,9 +39,6 @@ build() {
 		add_file $x
 	    done
 	fi
-	
-	add_file /usr/lib/udev/rules.d/70-uaccess.rules
-	add_file /usr/lib/udev/rules.d/71-seat.rules
 
 	# suppress a warning in glib (which the label control uses)
 	# about uid 0 by building a dummy NSS stack (LP #649917)
diff --git a/abs/core/plymouth/slim-plymouth.service b/abs/core/plymouth/slim-plymouth.service
index df3a107..8806c7d 100644
--- a/abs/core/plymouth/slim-plymouth.service
+++ b/abs/core/plymouth/slim-plymouth.service
@@ -1,7 +1,9 @@
 [Unit]
 Description=SLiM Simple Login Manager
-Conflicts=getty@tty1.service plymouth-quit.service
-After=systemd-user-sessions.service getty@tty1.service plymouth-quit.service
+After=systemd-user-sessions.service
+
+Conflicts=plymouth-quit.service
+After=plymouth-quit.service
 
 [Service]
 ExecStart=/usr/bin/slim -nodaemon
diff --git a/abs/core/plymouth/system-release b/abs/core/plymouth/system-release
new file mode 100644
index 0000000..850183e
--- /dev/null
+++ b/abs/core/plymouth/system-release
@@ -0,0 +1 @@
+Arch Linux
-- 
cgit v0.12