From 2cf59595f15d6fff4f4c038679ebec4a6411f44e Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 20 Jan 2016 19:42:50 +0000
Subject: qtchooser: initial inclusion: dep of qt5-base

---
 abs/extra/qtchooser/4.conf   |  2 ++
 abs/extra/qtchooser/5.conf   |  2 ++
 abs/extra/qtchooser/PKGBUILD | 41 +++++++++++++++++++++++++++++++++++++++++
 3 files changed, 45 insertions(+)
 create mode 100644 abs/extra/qtchooser/4.conf
 create mode 100644 abs/extra/qtchooser/5.conf
 create mode 100644 abs/extra/qtchooser/PKGBUILD

diff --git a/abs/extra/qtchooser/4.conf b/abs/extra/qtchooser/4.conf
new file mode 100644
index 0000000..96e344e
--- /dev/null
+++ b/abs/extra/qtchooser/4.conf
@@ -0,0 +1,2 @@
+/usr/lib/qt4/bin
+/usr/lib
diff --git a/abs/extra/qtchooser/5.conf b/abs/extra/qtchooser/5.conf
new file mode 100644
index 0000000..bcd76de
--- /dev/null
+++ b/abs/extra/qtchooser/5.conf
@@ -0,0 +1,2 @@
+/usr/lib/qt/bin
+/usr/lib
diff --git a/abs/extra/qtchooser/PKGBUILD b/abs/extra/qtchooser/PKGBUILD
new file mode 100644
index 0000000..a5339f0
--- /dev/null
+++ b/abs/extra/qtchooser/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=qtchooser
+pkgver=53
+pkgrel=2
+pkgdesc='Wrap the other Qt tools by searching for different instances of Qt on the system'
+arch=('i686' 'x86_64')
+url='http://code.qt.io/cgit/qt/qtchooser.git/'
+license=('GPL')
+backup=('etc/xdg/qtchooser/default.conf')
+depends=('gcc-libs')
+makedepends=('git')
+source=("git://code.qt.io/qt/${pkgname}.git#commit=d20fdc63"
+        {4,5}.conf)
+md5sums=('SKIP'
+         'aa4d49b269e1b806f5eea170801f0aa6'
+         'cf83f09a9a5a44d898b93f624d74dd11')
+
+pkgver() {
+  cd $pkgname
+  echo $(git rev-list --count HEAD)
+}
+
+build() {
+  cd $pkgname
+  make
+}
+
+package() {
+  cd $pkgname
+  make INSTALL_ROOT="$pkgdir" install
+
+  install -d "$pkgdir"/etc/xdg/qtchooser
+  install -m644 "$srcdir"/{4,5}.conf \
+    "$pkgdir"/etc/xdg/qtchooser/
+
+  # Set the default Qt
+  ln -s /etc/xdg/qtchooser/5.conf \
+    "$pkgdir"/etc/xdg/qtchooser/default.conf
+}
-- 
cgit v0.12