From e0e80fb41248e5691afdcda5f34ec8364d3c2c5f Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 16 Sep 2013 13:55:19 -0500
Subject: LinHES-system: move stop_xss.sh from linhes-scripts.

remove stop_xss.sh from linhes-scripts. Remove linhes-scripts as a dep of web-on-linhes and xbmc.
---
 abs/core/LinHES-system/PKGBUILD     |  5 +++--
 abs/core/LinHES-system/stop_xss.sh  | 12 ++++++++++++
 abs/core/linhes-scripts/PKGBUILD    |  4 +---
 abs/core/linhes-scripts/stop_xss.sh | 12 ------------
 abs/extra/web-on-linhes/PKGBUILD    |  6 +++---
 abs/extra/xbmc/PKGBUILD             |  4 ++--
 6 files changed, 21 insertions(+), 22 deletions(-)
 create mode 100755 abs/core/LinHES-system/stop_xss.sh
 delete mode 100644 abs/core/linhes-scripts/stop_xss.sh

diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 9abf04a..82cc14b 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=8.0
-pkgrel=11
+pkgrel=12
 arch=('i686' 'x86_64')
 install=system.install
 pkgdesc="Everything that makes LinHES an automated system"
@@ -21,7 +21,7 @@ binfiles="LinHES-start optimize_mythdb.py myth_mtc.py myth_mtc.sh
  gen_is_xml.py gen_lib_xml.py gen_light_include.py gen_game_xml.py
  misc_recent_recordings.pl misc_status_config.py misc_status_info.sh
  misc_upcoming_recordings.pl misc_which_recorder.pl
- change_channel.sh change_channel_wrapper.sh
+ change_channel.sh change_channel_wrapper.sh stop_xss.sh
  be_check.py checkXFSfrag.sh find_orphans.py idle.sh xwin_find.sh
  linhes_update.sh linhes_update2.sh
  mythwelcome-config.py mythwelcome-set-alarm.sh mythwelcome-test-wakeup.sh"
@@ -110,6 +110,7 @@ md5sums=('8fc4b7c1ddf8f3c4d2266ce55086b4d4'
          '116b0f62ed4e8dd6e437930deeb6e49e'
          '17f678d37187be0f12d67f64e40429c6'
          'bacc813b48bafcc6fe906e5969930501'
+         '54a478660d0f8150fe10112a9ecf2740'
          '8b0298f70f97cc1dc2a58b9a73c64bd3'
          '911b0fbc8d9178dac1a193346c9decaf'
          '34fc1f58ad1eabf4eff4979d420760c0'
diff --git a/abs/core/LinHES-system/stop_xss.sh b/abs/core/LinHES-system/stop_xss.sh
new file mode 100755
index 0000000..4bb9d1a
--- /dev/null
+++ b/abs/core/LinHES-system/stop_xss.sh
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+while [ 1=1 ];
+do
+
+    if [ "$(pidof chromium)" -o "$(pidof huludesktop)" -o "$(pidof xbmc.bin)" ]
+    then
+    xscreensaver-command -deactivate
+    fi
+    sleep 60
+
+done
diff --git a/abs/core/linhes-scripts/PKGBUILD b/abs/core/linhes-scripts/PKGBUILD
index 0c81167..050c4e2 100644
--- a/abs/core/linhes-scripts/PKGBUILD
+++ b/abs/core/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=linhes-scripts
 pkgver=7
-pkgrel=55
+pkgrel=56
 pkgdesc="Various scripts that help to make LinHES, LinHES."
 arch=('i686' 'x86_64')
 license=('GPL2')
@@ -39,7 +39,6 @@ qip7100-cc.sh
 dtheme.sh
 upgrade_screen_rc
 upgrade_linhes_script.sh
-stop_xss.sh
 myth2mkv
 LinHES-osd
 ripD_eject.sh
@@ -88,7 +87,6 @@ md5sums=('47a66238d95259d75c9c5cbcbb6da19f'
          '35693f50939d5827aeabfce8c5dce589'
          '974c137d3fcb85942ba8945a1bc815fe'
          'f454faeabfa153b10389a9a3bfd51c4a'
-         '54a478660d0f8150fe10112a9ecf2740'
          '503df99218373dfc75e7e7f5e449a44e'
          'b608044c9e7530a400d8f5b88fdfe6e6'
          'e2e24dd59d5d576cc33feafb329fa302'
diff --git a/abs/core/linhes-scripts/stop_xss.sh b/abs/core/linhes-scripts/stop_xss.sh
deleted file mode 100644
index 4bb9d1a..0000000
--- a/abs/core/linhes-scripts/stop_xss.sh
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/sh
-
-while [ 1=1 ];
-do
-
-    if [ "$(pidof chromium)" -o "$(pidof huludesktop)" -o "$(pidof xbmc.bin)" ]
-    then
-    xscreensaver-command -deactivate
-    fi
-    sleep 60
-
-done
diff --git a/abs/extra/web-on-linhes/PKGBUILD b/abs/extra/web-on-linhes/PKGBUILD
index 61abc93..64afe1e 100644
--- a/abs/extra/web-on-linhes/PKGBUILD
+++ b/abs/extra/web-on-linhes/PKGBUILD
@@ -3,16 +3,16 @@
 
 pkgname=web-on-linhes
 pkgver=1.00.0
-pkgrel=6
+pkgrel=7
 pkgdesc="Added multiple websites with 10' UIs to Play Online Streams."
 arch=('i686' 'x86_64')
 license=('GPL2')
 url="http://www.linhes.org/"
-depends=('google-chrome' 'linhes-scripts>=7-29' )
+depends=('google-chrome')
 install=web-on-linhes.install
 source=('web-on-linhes.sh' 'web-on-linhes_is.conf')
 
-build() {
+package() {
 	cd ${srcdir}
 	install -d ${pkgdir}/usr/LH/bin
 	install -D -m755 *.sh ${pkgdir}/usr/LH/bin
diff --git a/abs/extra/xbmc/PKGBUILD b/abs/extra/xbmc/PKGBUILD
index 33fbb70..e496886 100644
--- a/abs/extra/xbmc/PKGBUILD
+++ b/abs/extra/xbmc/PKGBUILD
@@ -9,7 +9,7 @@ _prefix=/usr
 
 pkgname=xbmc
 pkgver=12.2
-pkgrel=5
+pkgrel=6
 pkgdesc="A software media player and entertainment hub for digital media"
 arch=('i686' 'x86_64')
 url="http://xbmc.org"
@@ -19,7 +19,7 @@ depends=('hicolor-icon-theme' 'fribidi' 'lzo2' 'smbclient' 'libtiff' 'libva'
 	 'glew' 'libssh' 'libmicrohttpd' 'libxrandr' 'sdl_mixer' 'sdl_image' 'python2'
 	 'libass' 'libmpeg2' 'libmad' 'libmodplug' 'jasper' 'rtmpdump' 'unzip' 'mesa-demos'
 	 'xorg-xdpyinfo' 'libbluray' 'libnfs' 'afpfs-ng' 'libshairport' 'avahi' 'bluez-libs' 'glu'
-	 'tinyxml' 'taglib' 'linhes-scripts>=7-31')
+	 'tinyxml' 'taglib')
 makedepends=('boost' 'cmake' 'gperf' 'nasm' 'libxinerama' 'zip' 'libvdpau' 'libcec'
 	     'udisks' 'upower' 'mesa' 'doxygen' 'swig' 'java-environment')
 optdepends=('libcec: support for Pulse-Eight USB-CEC adapter'
-- 
cgit v0.12