From 505e4c0734274b850798f43ebb7278df04a7f47b Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 14 Mar 2014 19:11:42 +0000
Subject: mythinstall: add XBMC to Programs Menu. refs #962

---
 .../MythVantage-app/mythinstall/installsettings.cpp           | 11 +++++++++++
 .../mythinstall/MythVantage-app/mythinstall/installsettings.h |  1 +
 abs/core/mythinstall/PKGBUILD                                 |  2 +-
 3 files changed, 13 insertions(+), 1 deletion(-)

diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
index fb5f841..3171c67 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
@@ -1205,6 +1205,14 @@ static HostCheckBox *HostHuluDesktop()
     return gc;
 };
 
+static HostCheckBox *HostXBMC()
+{
+    HostCheckBox *gc = new HostCheckBox("HostXBMC");
+    gc->setLabel(QObject::tr("XBMC"));
+    gc->setValue(false);
+    gc->setHelpText(QObject::tr("A software media player and entertainment hub for digital media."));
+    return gc;
+};
 
 static HostComboBox *Hostfoldingusername()
 {
@@ -4049,6 +4057,7 @@ void writesettings ()
 //    hostparm.ThisHostfuppes = gCoreContext->GetSetting("Hostfuppes");
     hostparm.ThisHostHuluDesktop = gCoreContext->GetSetting("HostHuluDesktop");
     hostparm.ThisHostwebonlinhes = gCoreContext->GetSetting("HostWebonlinhes");
+    hostparm.ThisHostXBMC = gCoreContext->GetSetting("HostXBMC");
 
 //    hostparm.ThisHostfuppes = gCoreContext->GetSetting("Hostfuppes");
 
@@ -4386,6 +4395,7 @@ void writesettings ()
     myfile << "miro=\"" + hostparm.ThisHostMiro + "\"\n";
     myfile << "webonlinhes=\"" + hostparm.ThisHostwebonlinhes + "\"\n";
     myfile << "huludesktop=\"" + hostparm.ThisHostHuluDesktop + "\"\n";
+    myfile << "xbmc=\"" + hostparm.ThisHostXBMC + "\"\n";
     //myfile << "fuppes=\"" + hostparm.ThisHostfuppes  + "\"\n";
     myfile << "foldingathome=\"" + hostparm.ThisHostfoldingathome  + "\"\n";
     myfile << "foldingusername=\"" + hostparm.ThisHostfoldingusername  + "\"\n";
@@ -4831,6 +4841,7 @@ MythInstallSettings::MythInstallSettings()
                 //GridShowPlugin4->addChild(Hostfuppes());
                 GridShowPlugin4->addChild(HostHuluDesktop());
                 GridShowPlugin4->addChild(Hostwebonlinhes());
+                GridShowPlugin4->addChild(HostXBMC());
 
 
                 ConfigurationGroup *GridShowPlugin5 = new GridConfigurationGroup(2);
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
index 23c00f0..719eea5 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
@@ -532,6 +532,7 @@ struct HostParms
 
     QString ThisHostMiro;
     QString ThisHostwebonlinhes;
+    QString ThisHostXBMC;
     QString ThisHostHuluDesktop;
 
     QString ThisHostpluginmythgameMame;
diff --git a/abs/core/mythinstall/PKGBUILD b/abs/core/mythinstall/PKGBUILD
index ec5d403..50e4bca 100644
--- a/abs/core/mythinstall/PKGBUILD
+++ b/abs/core/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Jams
 pkgname=mythinstall
 pkgver=8.1
-pkgrel=11
+pkgrel=12
 pkgdesc="LinHES installer/systemconfig GUI."
 arch=('i686' 'x86_64')
 depends=('mythtv>=0.27')
-- 
cgit v0.12