From 858c21001f6e7c725e65937c7b94fa086585774b Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 28 Jan 2016 15:35:20 +0000
Subject: ffmpeg: update to 2.8.5

---
 abs/core/ffmpeg/PKGBUILD | 58 ++++++++++++++++++++++++++----------------------
 1 file changed, 31 insertions(+), 27 deletions(-)

diff --git a/abs/core/ffmpeg/PKGBUILD b/abs/core/ffmpeg/PKGBUILD
index 38458a6..8f3e9d7 100644
--- a/abs/core/ffmpeg/PKGBUILD
+++ b/abs/core/ffmpeg/PKGBUILD
@@ -1,41 +1,39 @@
 # $Id$
-# Maintainer:  Ionut Biru <ibiru@archlinux.org>
-# Maintainer:  Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
-# Maintainer:  Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
 # Contributor: Tom Newsom <Jeepster@gmx.co.uk>
 # Contributor: Paul Mattal <paul@archlinux.org>
 
 pkgname=ffmpeg
-pkgver=2.7.2
+pkgver=2.8.5
 pkgrel=2
 epoch=1
 pkgdesc='Complete solution to record, convert and stream audio and video'
 arch=('i686' 'x86_64')
 url='http://ffmpeg.org/'
 license=('GPL3')
-depends=(
-      'alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame' 'libass'
-      'libbluray' 'libmodplug' 'libsoxr' 'libssh' 'libtheora'
-      'libva' 'libvdpau' 'libwebp' 'opencore-amr' 'openjpeg' 'opus'
-      'schroedinger' 'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
-      'libvorbis.so' 'libvorbisenc.so' 'libvpx.so' 'libx264.so' 'libx265.so'
-)
-makedepends=('hardening-wrapper' 'libvdpau' 'yasm')
-provides=(
-      'libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
-      'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
-      'libswscale.so'
-)
-source=(http://ffmpeg.org/releases/$pkgname-$pkgver.tar.bz2{,.asc})
-validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8') # ffmpeg-devel
-md5sums=('7eb2140bab9f0a8669b65b50c8e4cfb5'
-         'SKIP')
+depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame'
+         'libass' 'libbluray' 'libmodplug' 'libsoxr' 'libssh'
+         'libtheora' 'libva' 'libvdpau' 'libwebp' 'opencore-amr' 'openjpeg'
+         'opus' 'schroedinger' 'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
+         'libdcadec.so' 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so'
+         'libvpx.so' 'libx264.so' 'libx265.so')
+makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm')
+optdepends=('ladspa: LADSPA filters')
+provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
+          'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
+          'libswscale.so')
+source=(http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.bz2{,.asc})
+validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
+sha256sums=('3b6d9951533323ee64a21d0aa7667a780b3470bfe4e0fb7c1b33307ce290615a'
+            'SKIP')
 
 build() {
-  cd $pkgname-$pkgver
+  cd ffmpeg-${pkgver}
 
   ./configure \
-    --prefix=/usr \
+    --prefix='/usr' \
     --disable-debug \
     --disable-static \
     --disable-stripping \
@@ -44,8 +42,10 @@ build() {
     --enable-fontconfig \
     --enable-gnutls \
     --enable-gpl \
+    --enable-ladspa \
     --enable-libass \
     --enable-libbluray \
+    --enable-libdcadec \
     --enable-libfreetype \
     --enable-libfribidi \
     --enable-libgsm \
@@ -62,6 +62,7 @@ build() {
     --enable-libssh \
     --enable-libtheora \
     --enable-libv4l2 \
+    --enable-libvidstab \
     --enable-libvorbis \
     --enable-libvpx \
     --enable-libwebp \
@@ -70,7 +71,7 @@ build() {
     --enable-libxvid \
     --enable-shared \
     --enable-version3 \
-    --enable-x11grab \
+    --enable-x11grab
 
   make
   make tools/qt-faststart
@@ -78,7 +79,10 @@ build() {
 }
 
 package() {
-  cd $pkgname-$pkgver
-  make DESTDIR="$pkgdir" install install-man
-  install -Dm755 tools/qt-faststart "$pkgdir"/usr/bin/qt-faststart
+  cd ffmpeg-${pkgver}
+
+  make DESTDIR="${pkgdir}" install install-man
+  install -Dm 755 tools/qt-faststart "${pkgdir}"/usr/bin/
 }
+
+# vim: ts=2 sw=2 et:
-- 
cgit v0.12