From a8c427b35b9b33fcd176141522732541634ebfd0 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 21 Aug 2012 18:23:23 -0500
Subject: Merge remote-tracking branch 'origin/testing' into testing

# By Cecil (2) and Michael Hanson (1)
# Via Michael Hanson
* origin/testing:
  linhes-scripts: minor changes to myth2mkv
  mythtv:Bumped to latest fixes. Added ./configure items to close #842.
  LinHES-config:7.4 rdt 9th anniversary release.

Conflicts:
	abs/core/LinHES-config/LinHES-release
	abs/core/LinHES-config/PKGBUILD
	abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
---
 abs/core/LinHES-config/PKGBUILD             | 2 +-
 abs/core/linhes-scripts/PKGBUILD            | 4 ++--
 abs/core/linhes-scripts/myth2mkv            | 7 +++++--
 abs/core/mythtv/stable-0.25/mythtv/PKGBUILD | 5 ++++-
 4 files changed, 12 insertions(+), 6 deletions(-)

diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 8c7a010..ec6feb1 100644
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.3
-pkgrel=79
+pkgrel=80
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
 pkgdesc="Install and configure your system"
 depends=('bc' 'libstatgrab'  'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
diff --git a/abs/core/linhes-scripts/PKGBUILD b/abs/core/linhes-scripts/PKGBUILD
index 22e112d..4d851d8 100644
--- a/abs/core/linhes-scripts/PKGBUILD
+++ b/abs/core/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=linhes-scripts
 pkgver=7
-pkgrel=45
+pkgrel=46
 pkgdesc="Various scripts that help to make LinHES, LinHES."
 arch=('i686' 'x86_64')
 license=('GPL2')
@@ -106,6 +106,6 @@ md5sums=('f56985b2d602e11dc1e10d3e7848b2a5'
          '34fc1f58ad1eabf4eff4979d420760c0'
          'cc9cdabcdfc969c2829b58c0e513488c'
          '54a478660d0f8150fe10112a9ecf2740'
-         '8fa34662c686b210c9943324b7df2feb'
+         'bb8eae5de8a0d22f1722b3e7b2e32468'
          'b608044c9e7530a400d8f5b88fdfe6e6'
          'e2e24dd59d5d576cc33feafb329fa302')
diff --git a/abs/core/linhes-scripts/myth2mkv b/abs/core/linhes-scripts/myth2mkv
index f180b31..447e3c4 100644
--- a/abs/core/linhes-scripts/myth2mkv
+++ b/abs/core/linhes-scripts/myth2mkv
@@ -2,7 +2,7 @@
 #
 # Convert video to AVC-1 / h264
 #
-# version 0.25-002
+# version 0.25-003
 #
 # Prerequisites:
 #   - mythtv >= 0.25
@@ -204,10 +204,13 @@ if [[ ${QUALITY} = HQ ]] ; then
   if [[ -n ${CROP} ]] ; then
     CROP="--crop ${CROP}"
   else
-    CROP="--crop 0:0:0:0"
+    CROP="--crop 0:0:0:0 --strict-anamorphic"
   fi
   HB_OPTS="-o ${TMPFILE} -f mkv -m -e x264 ${TUNING} -x b-adapt=2:rc-lookahead=50 -b 5000 -2 -T ${WIDTH} ${HEIGHT} -r ${FPS} --cfr ${CROP} ${DEINT} -a 1 -E copy -s 1"
 else
+  if [[ ${CROP} = "--crop 0:0:0:0" ]] ; then
+    CROP="${CROP} --strict-anamorphic"
+  fi
   if [[ ${QUALITY} = LQ ]] ; then
     HB_OPTS="-o ${TMPFILE} -f mkv -m -e x264 ${TUNING} -b 1250 ${WIDTH} ${HEIGHT} -r ${FPS} --pfr ${CROP} ${DEINT} -a 1 -E lame -B 128 -Q 8 -6 stereo -s 1"
   else
diff --git a/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
index e8ad430..f50bd5c 100644
--- a/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
@@ -47,7 +47,8 @@ depends=('mysql-clients'
          'libxml2'
          'lsdvd'
          'libass'
-         'dvdbackup')
+         'dvdbackup'
+         'x264')
 
 #glew for gpu commerical flagging
 #openssl for roap
@@ -104,6 +105,8 @@ build() {
               --enable-vdpau \
               --enable-crystalhd \
               --dvb-path=/usr/include \
+	           --enable-libmp3lame \
+	           --enable-libx264 \
               --with-bindings=perl,python --python=python2 || return 1
 
   make all || return 1
-- 
cgit v0.12