From e6390521d31973140a9fc8f0aaea6dac27e7096a Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 27 Sep 2016 12:32:22 +0000
Subject: tidy, tidyhtml: remove tidyhtml, replace with tidy

---
 abs/extra/tidy/PKGBUILD     | 42 ++++++++++++++++++++++++++++++++++++++++++
 abs/extra/tidyhtml/PKGBUILD | 42 ------------------------------------------
 2 files changed, 42 insertions(+), 42 deletions(-)
 create mode 100644 abs/extra/tidy/PKGBUILD
 delete mode 100644 abs/extra/tidyhtml/PKGBUILD

diff --git a/abs/extra/tidy/PKGBUILD b/abs/extra/tidy/PKGBUILD
new file mode 100644
index 0000000..352e56f
--- /dev/null
+++ b/abs/extra/tidy/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 230776 2015-02-04 23:00:34Z bluewind $
+# Maintainer:
+# Contributor: eric <eric@archlinux.org>
+# Contributor: Markus Meissner <markus@meissna.de>
+
+pkgname=tidy
+pkgver=5.2.0
+pkgrel=1
+pkgdesc="A tool to tidy down your HTML code to a clean style"
+arch=(i686 x86_64)
+url="http://www.html-tidy.org/"
+license=(custom)
+depends=(glibc)
+makedepends=(cmake libxslt)
+conflicts=(tidyhtml)
+provides=(tidyhtml)
+replaces=(tidyhtml)
+source=("https://github.com/htacg/tidy-html5/archive/$pkgver.tar.gz")
+md5sums=('ffbe6e8471eff90877b4d74bb714e22f')
+
+prepare() {
+  mkdir -p build
+}
+
+build() {
+  cd build
+  cmake ../tidy-html5-$pkgver \
+    -DCMAKE_INSTALL_PREFIX=/usr \
+    -DCMAKE_BUILD_TYPE=Release
+  make
+}
+
+package() {
+  cd build
+  make DESTDIR="$pkgdir" install
+
+# Compatibility symlinks until everything is ported
+  ln -s tidybuffio.h "$pkgdir"/usr/include/buffio.h
+  ln -s tidyplatform.h "$pkgdir"/usr/include/platform.h
+
+  install -Dm644 "$srcdir"/$pkgname-html5-$pkgver/README/LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/abs/extra/tidyhtml/PKGBUILD b/abs/extra/tidyhtml/PKGBUILD
deleted file mode 100644
index aaca300..0000000
--- a/abs/extra/tidyhtml/PKGBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# $Id: PKGBUILD 146404 2012-01-10 21:14:26Z andrea $
-# Maintainer:
-# Contributor: eric <eric@archlinux.org>
-# Contributor: Markus Meissner <markus@meissna.de>
-
-pkgname=tidyhtml
-# obtain pkgver from http://tidy.cvs.sourceforge.net/tidy/tidy/src/version.h?view=markup
-pkgver=1.46
-pkgrel=2
-pkgdesc="A tool to tidy down your HTML code to a clean style"
-arch=('i686' 'x86_64')
-url="http://tidy.sourceforge.net/"
-license=('custom')
-depends=('glibc')
-options=('!libtool')
-source=("ftp://ftp.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
-md5sums=('3d970d54be83c5ec985687e9976a2832')
-
-mksource() {
-  mkdir ${pkgname}-${pkgver}
-  cd ${pkgname}-${pkgver}
-  cvs -d:pserver:anonymous@tidy.cvs.sourceforge.net:/cvsroot/tidy login   #hit enter for password
-  cvs -z3 -d:pserver:anonymous@tidy.cvs.sourceforge.net:/cvsroot/tidy co -P tidy
-  cd ..
-  tar -cvjf ${pkgname}-${pkgver}.tar.bz2 ${pkgname}-${pkgver}/*
-}
-
-build(){
-  cd $srcdir/${pkgname}-${pkgver}/tidy
-  source build/gnuauto/setup.sh
-  
-  ./configure --prefix=/usr
-  make
-}
-
-package() {
-  cd $srcdir/${pkgname}-${pkgver}/tidy
-  make DESTDIR=$pkgdir install
-  
-  install -Dm644 htmldoc/license.html \
-    ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
-}
-- 
cgit v0.12