From 162e9d1b44e3d7a7f76053653100de66f024b9f1 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 7 Aug 2012 14:41:00 -0500
Subject: boost 1.50

---
 abs/extra/boost/PKGBUILD         | 20 +++++++++-----------
 abs/extra/boost/__changelog      |  3 ---
 abs/extra/boost/exceptions.patch | 25 -------------------------
 3 files changed, 9 insertions(+), 39 deletions(-)
 delete mode 100644 abs/extra/boost/__changelog
 delete mode 100644 abs/extra/boost/exceptions.patch

diff --git a/abs/extra/boost/PKGBUILD b/abs/extra/boost/PKGBUILD
index f9502a9..7629843 100644
--- a/abs/extra/boost/PKGBUILD
+++ b/abs/extra/boost/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id$
+# $Id: PKGBUILD 163703 2012-07-18 01:05:09Z ibiru $
 # Maintainer: kevin <kevin@archlinux.org>
 # Contributor: Giovanni Scafora <giovanni@archlinux.org>
 # Contributor: Kritoke <kritoke@gamebox.net>
@@ -6,28 +6,26 @@
 
 pkgbase=boost
 pkgname=('boost-libs' 'boost')
-pkgver=1.49.0
+pkgver=1.50.0
 _boostver=${pkgver//./_}
 pkgrel=1
 arch=('i686' 'x86_64')
 url="http://www.boost.org/"
-makedepends=('icu' 'python2' 'bzip2' 'zlib' 'openmpi')
-source=(http://downloads.sourceforge.net/sourceforge/${pkgbase}/${pkgbase}_${_boostver}.tar.gz
-        exceptions.patch)
+makedepends=('icu'  'python2' 'bzip2' 'zlib' 'openmpi')
+source=(http://downloads.sourceforge.net/${pkgbase}/${pkgbase}_${_boostver}.tar.gz)
 license=('custom')
+md5sums=('dbc07ab0254df3dda6300fd737b3f264')
 
 _stagedir="${srcdir}/stagedir"
 
 build() {
   # set python path for bjam
   cd "${srcdir}/${pkgbase}_${_boostver}/tools"
-  echo "using python : 2.6 : /usr/bin/python2 ;" >> build/v2/user-config.jam
+  echo "using python : 2.7 : /usr/bin/python2 ;" >> build/v2/user-config.jam
   #echo "using python : 3.2 : /usr/bin/python : /usr/include/python3.2mu : /usr/lib ;" >> build/v2/user-config.jam
   echo "using mpi ;" >> build/v2/user-config.jam
 
   cd "${srcdir}"/${pkgbase}_${_boostver}
-  # https://svn.boost.org/trac/boost/ticket/5731
-  patch -p0 -i "${srcdir}/exceptions.patch"
 
   # build bjam
   cd "${srcdir}/${pkgbase}_${_boostver}/tools/build/v2/engine"
@@ -78,7 +76,9 @@ build() {
 package_boost() {
     pkgdesc="Free peer-reviewed portable C++ source libraries - Development"
     depends=("boost-libs=${pkgver}")
-    optdepends=('python2: for python2 bindings')
+    optdepends=(#'python: for python bindings'
+                'python2: for python2 bindings'
+		'boost-build: to use boost jam for building your project.')
 
     install -d "${pkgdir}"/usr/{include,lib,share}
     # headers/source files
@@ -111,5 +111,3 @@ package_boost-libs() {
     install -D -m644 "${srcdir}/${pkgbase}_${_boostver}/LICENSE_1_0.txt" \
         "${pkgdir}"/usr/share/licenses/boost-libs/LICENSE_1_0.txt
 }
-md5sums=('e0defc8c818e4f1c5bbb29d0292b76ca'
-         'bedd276510b6ad1ff2b4d143de21373e')
diff --git a/abs/extra/boost/__changelog b/abs/extra/boost/__changelog
deleted file mode 100644
index f0c532d..0000000
--- a/abs/extra/boost/__changelog
+++ /dev/null
@@ -1,3 +0,0 @@
-* remove 'python' dep (aka python3)
-* change python 2.7 refrence to 2.6
-* remove python optdep for the libs package
diff --git a/abs/extra/boost/exceptions.patch b/abs/extra/boost/exceptions.patch
deleted file mode 100644
index 0322db6..0000000
--- a/abs/extra/boost/exceptions.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -up boost/numeric/conversion/converter_policies.hpp\~ boost/numeric/conversion/converter_policies.hpp
---- boost/numeric/conversion/converter_policies.hpp~	2008-10-13 11:00:03.000000000 +0200
-+++ boost/numeric/conversion/converter_policies.hpp	2011-07-22 11:46:40.961876274 +0200
-@@ -20,6 +20,7 @@
-
- #include "boost/mpl/if.hpp"
- #include "boost/mpl/integral_c.hpp"
-+#include "boost/throw_exception.hpp"
-
- namespace boost { namespace numeric
- {
-@@ -159,9 +160,9 @@ struct def_overflow_handler
-   void operator() ( range_check_result r ) // throw(negative_overflow,positive_overflow)
-   {
-     if ( r == cNegOverflow )
--      throw negative_overflow() ;
-+      boost::throw_exception( negative_overflow() ) ;
-     else if ( r == cPosOverflow )
--           throw positive_overflow() ;
-+      boost::throw_exception( positive_overflow() ) ;
-   }
- } ;
-
-
-Diff finished.  Fri Jul 22 11:46:49 2011
-- 
cgit v0.12