From 4add9e1eee8d0f82289600efb4357d2565e5dd09 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 26 Sep 2016 20:04:26 +0000
Subject: openssh: update to 7.3p1

---
 abs/core/openssh/PKGBUILD            | 12 +++---
 abs/core/openssh/dispatch.patch      | 81 ------------------------------------
 abs/core/openssh/error.patch         | 25 -----------
 abs/core/openssh/install             | 10 -----
 abs/core/openssh/sshdgenkeys.service |  6 +--
 5 files changed, 7 insertions(+), 127 deletions(-)
 delete mode 100644 abs/core/openssh/dispatch.patch
 delete mode 100644 abs/core/openssh/error.patch
 delete mode 100644 abs/core/openssh/install

diff --git a/abs/core/openssh/PKGBUILD b/abs/core/openssh/PKGBUILD
index 1948de4..2fe40b3 100644
--- a/abs/core/openssh/PKGBUILD
+++ b/abs/core/openssh/PKGBUILD
@@ -4,8 +4,8 @@
 # Contributor: judd <jvinet@zeroflux.org>
 
 pkgname=openssh
-pkgver=7.1p2
-pkgrel=2
+pkgver=7.3p1
+pkgrel=1
 pkgdesc='Free version of the SSH connectivity tools'
 url='http://www.openssh.org/portable.html'
 license=('custom:BSD')
@@ -15,15 +15,15 @@ depends=('krb5' 'openssl' 'libedit' 'ldns')
 optdepends=('xorg-xauth: X11 forwarding'
             'x11-ssh-askpass: input passphrase in X')
 validpgpkeys=('59C2118ED206D927E667EBE3D3E5F56B6D920D30')
-source=("ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/${pkgname}-${pkgver}.tar.gz"{,.asc}
+source=("http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/${pkgname}-${pkgver}.tar.gz"{,.asc}
         'sshdgenkeys.service'
         'sshd@.service'
         'sshd.service'
         'sshd.socket'
         'sshd.conf'
         'sshd.pam')
-sha1sums=('9202f5a2a50c8a55ecfb830609df1e1fde97f758' 'SKIP'
-          'cc1ceec606c98c7407e7ac21ade23aed81e31405'
+sha1sums=('bfade84283fcba885e2084343ab19a08c7d123a5' 'SKIP'
+          'caaa801da59a5d14c0c29c43e9de5fef281ea03e'
           '6a0ff3305692cf83aca96e10f3bb51e1c26fccda'
           'ec49c6beba923e201505f5669cea48cad29014db'
           'e12fa910b26a5634e5a6ac39ce1399a132cf6796'
@@ -32,8 +32,6 @@ sha1sums=('9202f5a2a50c8a55ecfb830609df1e1fde97f758' 'SKIP'
 
 backup=('etc/ssh/ssh_config' 'etc/ssh/sshd_config' 'etc/pam.d/sshd')
 
-install=install
-
 build() {
 	cd "${srcdir}/${pkgname}-${pkgver}"
 
diff --git a/abs/core/openssh/dispatch.patch b/abs/core/openssh/dispatch.patch
deleted file mode 100644
index 9350d8f..0000000
--- a/abs/core/openssh/dispatch.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From 639d6bc57b1942393ed12fb48f00bc05d4e093e4 Mon Sep 17 00:00:00 2001
-From: djm@openbsd.org <djm@openbsd.org>
-Date: Fri, 01 May 2015 07:10:01 +0000
-Subject: upstream commit
-
-refactor ssh_dispatch_run_fatal() to use sshpkt_fatal()
- to better report error conditions. Teach sshpkt_fatal() about ECONNRESET.
-
-Improves error messages on TCP connection resets. bz#2257
-
-ok dtucker@
----
-diff --git a/dispatch.c b/dispatch.c
-index afe6182..aac933e 100644
---- a/dispatch.c
-+++ b/dispatch.c
-@@ -1,4 +1,4 @@
--/* $OpenBSD: dispatch.c,v 1.26 2015/02/12 20:34:19 dtucker Exp $ */
-+/* $OpenBSD: dispatch.c,v 1.27 2015/05/01 07:10:01 djm Exp $ */
- /*
-  * Copyright (c) 2000 Markus Friedl.  All rights reserved.
-  *
-@@ -137,22 +137,6 @@ ssh_dispatch_run_fatal(struct ssh *ssh, int mode, volatile sig_atomic_t *done,
- {
- 	int r;
- 
--	if ((r = ssh_dispatch_run(ssh, mode, done, ctxt)) != 0) {
--		switch (r) {
--		case SSH_ERR_CONN_CLOSED:
--			logit("Connection closed by %.200s",
--			    ssh_remote_ipaddr(ssh));
--			cleanup_exit(255);
--		case SSH_ERR_CONN_TIMEOUT:
--			logit("Connection to %.200s timed out while "
--			    "waiting to read", ssh_remote_ipaddr(ssh));
--			cleanup_exit(255);
--		case SSH_ERR_DISCONNECTED:
--			logit("Disconnected from %.200s",
--			    ssh_remote_ipaddr(ssh));
--			cleanup_exit(255);
--		default:
--			fatal("%s: %s", __func__, ssh_err(r));
--		}
--	}
-+	if ((r = ssh_dispatch_run(ssh, mode, done, ctxt)) != 0)
-+		sshpkt_fatal(ssh, __func__, r);
- }
-diff --git a/packet.c b/packet.c
-index 4922573..a7727ef 100644
---- a/packet.c
-+++ b/packet.c
-@@ -1,4 +1,4 @@
--/* $OpenBSD: packet.c,v 1.208 2015/02/13 18:57:00 markus Exp $ */
-+/* $OpenBSD: packet.c,v 1.212 2015/05/01 07:10:01 djm Exp $ */
- /*
-  * Author: Tatu Ylonen <ylo@cs.hut.fi>
-  * Copyright (c) 1995 Tatu Ylonen <ylo@cs.hut.fi>, Espoo, Finland
-@@ -1920,9 +1920,19 @@ sshpkt_fatal(struct ssh *ssh, const char *tag, int r)
- 		logit("Connection closed by %.200s", ssh_remote_ipaddr(ssh));
- 		cleanup_exit(255);
- 	case SSH_ERR_CONN_TIMEOUT:
--		logit("Connection to %.200s timed out while "
--		    "waiting to write", ssh_remote_ipaddr(ssh));
-+		logit("Connection to %.200s timed out", ssh_remote_ipaddr(ssh));
- 		cleanup_exit(255);
-+	case SSH_ERR_DISCONNECTED:
-+		logit("Disconnected from %.200s",
-+		    ssh_remote_ipaddr(ssh));
-+		cleanup_exit(255);
-+	case SSH_ERR_SYSTEM_ERROR:
-+		if (errno == ECONNRESET) {
-+			logit("Connection reset by %.200s",
-+			    ssh_remote_ipaddr(ssh));
-+			cleanup_exit(255);
-+		}
-+		/* FALLTHROUGH */
- 	default:
- 		fatal("%s%sConnection to %.200s: %s",
- 		    tag != NULL ? tag : "", tag != NULL ? ": " : "",
---
-cgit v0.9.2
diff --git a/abs/core/openssh/error.patch b/abs/core/openssh/error.patch
deleted file mode 100644
index 1616ba3..0000000
--- a/abs/core/openssh/error.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 4d24b3b6a4a6383e05e7da26d183b79fa8663697 Mon Sep 17 00:00:00 2001
-From: Damien Miller <djm@mindrot.org>
-Date: Thu, 19 Mar 2015 22:11:59 +0000
-Subject: remove error() accidentally inserted for debugging
-
-pointed out by Christian Hesse
----
-diff --git a/monitor_wrap.c b/monitor_wrap.c
-index b379f05..d39d491 100644
---- a/monitor_wrap.c
-+++ b/monitor_wrap.c
-@@ -153,10 +153,8 @@ mm_request_receive(int sock, Buffer *m)
- 	debug3("%s entering", __func__);
- 
- 	if (atomicio(read, sock, buf, sizeof(buf)) != sizeof(buf)) {
--		if (errno == EPIPE) {
--			error("%s: socket closed", __func__);
-+		if (errno == EPIPE)
- 			cleanup_exit(255);
--		}
- 		fatal("%s: read: %s", __func__, strerror(errno));
- 	}
- 	msg_len = get_u32(buf);
---
-cgit v0.9.2
diff --git a/abs/core/openssh/install b/abs/core/openssh/install
deleted file mode 100644
index 6f0cd37..0000000
--- a/abs/core/openssh/install
+++ /dev/null
@@ -1,10 +0,0 @@
-post_upgrade() {
-	if [[ $(vercmp $2 6.2p2) = -1 ]]; then
-		cat <<EOF
-
-==> The sshd daemon has been moved to /usr/bin alongside all binaries.
-==> Please update this path in your scripts if applicable.
-
-EOF
-	fi
-}
diff --git a/abs/core/openssh/sshdgenkeys.service b/abs/core/openssh/sshdgenkeys.service
index 1d01b7a..cfb9f6a 100644
--- a/abs/core/openssh/sshdgenkeys.service
+++ b/abs/core/openssh/sshdgenkeys.service
@@ -1,15 +1,13 @@
 [Unit]
 Description=SSH Key Generation
-ConditionPathExists=|!/etc/ssh/ssh_host_key
-ConditionPathExists=|!/etc/ssh/ssh_host_key.pub
-ConditionPathExists=|!/etc/ssh/ssh_host_rsa_key
-ConditionPathExists=|!/etc/ssh/ssh_host_rsa_key.pub
 ConditionPathExists=|!/etc/ssh/ssh_host_dsa_key
 ConditionPathExists=|!/etc/ssh/ssh_host_dsa_key.pub
 ConditionPathExists=|!/etc/ssh/ssh_host_ecdsa_key
 ConditionPathExists=|!/etc/ssh/ssh_host_ecdsa_key.pub
 ConditionPathExists=|!/etc/ssh/ssh_host_ed25519_key
 ConditionPathExists=|!/etc/ssh/ssh_host_ed25519_key.pub
+ConditionPathExists=|!/etc/ssh/ssh_host_rsa_key
+ConditionPathExists=|!/etc/ssh/ssh_host_rsa_key.pub
 
 [Service]
 ExecStart=/usr/bin/ssh-keygen -A
-- 
cgit v0.12