From 8a93fa938cbbb0d3b0b1c50ce5c8d0d6da918389 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 19 Aug 2013 14:46:53 -0500
Subject: graphite: initial inclusion. dep of harfbuzz.

---
 abs/extra/graphite/PKGBUILD                        | 63 ++++++++++++++++++++++
 abs/extra/graphite/graphite2-1.2.0-cmakepath.patch |  9 ++++
 2 files changed, 72 insertions(+)
 create mode 100644 abs/extra/graphite/PKGBUILD
 create mode 100644 abs/extra/graphite/graphite2-1.2.0-cmakepath.patch

diff --git a/abs/extra/graphite/PKGBUILD b/abs/extra/graphite/PKGBUILD
new file mode 100644
index 0000000..67fead2
--- /dev/null
+++ b/abs/extra/graphite/PKGBUILD
@@ -0,0 +1,63 @@
+# $Id$
+# Maintainer: AndyRTR <andyrtr@archlinux.org>
+
+pkgname=graphite
+pkgver=1.2.3
+pkgrel=1
+epoch=1
+arch=('i686' 'x86_64')
+url="http://projects.palaso.org/projects/graphitedev"
+pkgdesc='reimplementation of the SIL Graphite text processing engine'
+license=('LGPL' 'GPL' 'custom')
+depends=('gcc-libs')
+makedepends=('cmake' 'freetype2' 'python2')
+             # - only for docs - target doesn't install properly
+             #  'doxygen' 'texlive-latexextra' 'graphviz' 'asciidoc' 'perl-module-build' 'icu') # builds doc properly? 'texlive-helvetic' seems to be missing
+options=('!libtool' '!emptydirs')
+source=(http://downloads.sourceforge.net/project/silgraphite/graphite2/graphite2-${pkgver}.tgz
+        graphite2-1.2.0-cmakepath.patch)
+md5sums=('7042305e4208af4c2d5249d814ccce58'
+         '00353b67941dbc30b76a43253760769e')
+
+build() {
+  cd "${srcdir}"
+  
+  # python2 fixes
+  sed -i "s:\/usr\/bin\/python:\/usr\/bin\/python2:" graphite2-${pkgver}/tests/{jsoncmp,fuzztest,defuzz,corrupt.py}
+  
+  # fix install path - .cmake files contain architecture dependend content - patch taken from FC/Slackware
+  pushd graphite2-${pkgver}
+  patch -Np1 -i ${srcdir}/graphite2-1.2.0-cmakepath.patch
+  popd
+  
+  mkdir build
+  cd build
+  cmake -G "Unix Makefiles" ../graphite2-${pkgver} \
+	-DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
+	-DCMAKE_INSTALL_PREFIX=/usr \
+	-DCMAKE_BUILD_TYPE:STRING=Release \
+	-DGRAPHITE2_COMPARE_RENDERER=OFF \
+	#-DCMAKE_VERBOSE_MAKEFILE:BOOL=ON # remove when docs install target will be fixed
+
+  # fix unwanted -O3 cflag (taken form Debian)
+  find . -type f ! -name "rules" ! -name "changelog" -exec sed -i -e 's/\-O3//g' {} \;
+
+  make 
+  #make docs
+}
+
+check() {
+  cd "${srcdir}"/build
+  sed -i "s:python:python2:g" tests/CTestTestfile.cmake
+  ctest
+}
+
+package() {
+  cd "${srcdir}"/build
+  # FIXME: all target doesn't install the docs target files
+  make DESTDIR="$pkgdir/" install 
+
+  # licenses
+  mkdir -p "${pkgdir}"/usr/share/licenses/${pkgname}
+  install -m644 "${srcdir}"/graphite2-${pkgver}/COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/
+}
diff --git a/abs/extra/graphite/graphite2-1.2.0-cmakepath.patch b/abs/extra/graphite/graphite2-1.2.0-cmakepath.patch
new file mode 100644
index 0000000..ee71cd6
--- /dev/null
+++ b/abs/extra/graphite/graphite2-1.2.0-cmakepath.patch
@@ -0,0 +1,9 @@
+diff -urN graphite2-1.2.0.orig/src/CMakeLists.txt graphite2-1.2.0/src/CMakeLists.txt
+--- graphite2-1.2.0.orig/src/CMakeLists.txt	2013-01-29 15:47:32.465841769 +0530
++++ graphite2-1.2.0/src/CMakeLists.txt	2013-01-29 15:48:24.056843352 +0530
+@@ -136,4 +136,4 @@
+ 
+ 
+ install(TARGETS graphite2 EXPORT graphite2 LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} PUBLIC_HEADER DESTINATION include/graphite2 RUNTIME DESTINATION bin)
+-install(EXPORT graphite2 DESTINATION share/graphite2 NAMESPACE gr2_)
++install(EXPORT graphite2 DESTINATION lib${LIB_SUFFIX}/graphite2 NAMESPACE gr2_)
-- 
cgit v0.12