From 390cbf1170ddc80564de91673ddf83fc1737210e Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 15 Mar 2017 18:01:01 +0000
Subject: LinHES-system: mythwelcome-config.py: disable timeout if not running
 mythwelcome and check if Master_backend

---
 abs/core/LinHES-system/PKGBUILD              | 4 ++--
 abs/core/LinHES-system/mythwelcome-config.py | 8 ++++++--
 2 files changed, 8 insertions(+), 4 deletions(-)

diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index aed479d..81b72a3 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=8.4
-pkgrel=22
+pkgrel=23
 arch=('i686' 'x86_64')
 install=system.install
 pkgdesc="Everything that makes LinHES an automated system"
@@ -135,7 +135,7 @@ md5sums=('c6e6b83a1f4c35ef4501e277657ab2ac'
          '28f29578e5b3ba84fdf2aa57cf475bcf'
          '4a1fda884dcd7d65fb2690fbdbd92a83'
          '2b7fe3b57592823a4c7e3ec132dcb7f4'
-         '6e95aa86413abdb568ed157cf11dd69f'
+         'de3028ed75b53bd2f85ffbfdf64c44c2'
          '95c092f67036a361ef7a57436f44332e'
          '410795ef9039e4c6c0484e706ecfd567'
          'eb879fee9603a05d5420d4ce8ed9e450'
diff --git a/abs/core/LinHES-system/mythwelcome-config.py b/abs/core/LinHES-system/mythwelcome-config.py
index 01638a2..204a6e9 100755
--- a/abs/core/LinHES-system/mythwelcome-config.py
+++ b/abs/core/LinHES-system/mythwelcome-config.py
@@ -17,8 +17,12 @@ mythdb.settings[localhostname].MythShutdownXTermCmd = u'xterm'
 mythdb.settings[localhostname].MythWelcomeStartFECmd = u'/usr/LH/bin/mythfrontend-start'
 
 # mythtv-setup Shutdown/Wakeup options
-if mythdb.settings.NULL.idleTimeoutSecs == u'0' or mythdb.settings.NULL.idleTimeoutSecs == None:
-    mythdb.settings.NULL.idleTimeoutSecs = u'40'
+if mythdb.settings[localhostname].HostSystemType == u'Master_backend':
+    if mythdb.settings[localhostname].HostUseMythWelcome == u'1':
+        if mythdb.settings.NULL.idleTimeoutSecs == u'0' or mythdb.settings.NULL.idleTimeoutSecs == None:
+            mythdb.settings.NULL.idleTimeoutSecs = u'60'
+    else:
+        mythdb.settings.NULL.idleTimeoutSecs = u'0'
 
 mythdb.settings.NULL.WakeupTimeFormat = u'yyyy-MM-ddThh:mm:ss'
 mythdb.settings.NULL.SetWakeuptimeCommand = u'/usr/bin/mythshutdown --setwakeup $time'
-- 
cgit v0.12