From d11edcfd208c6ee48819b565c9dbd620e9c83781 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 15 May 2012 16:33:57 -0500
Subject: LinHES-system: make fluxbox use the updated startup path and not use
 it's own file. refs #830

---
 abs/core/LinHES-system/LinHES-run     |  1 +
 abs/core/LinHES-system/LinHES-session | 53 +++++++++++++++++------------------
 abs/core/LinHES-system/PKGBUILD       |  6 ++--
 3 files changed, 30 insertions(+), 30 deletions(-)

diff --git a/abs/core/LinHES-system/LinHES-run b/abs/core/LinHES-system/LinHES-run
index 2c53337..0de0feb 100755
--- a/abs/core/LinHES-system/LinHES-run
+++ b/abs/core/LinHES-system/LinHES-run
@@ -1,4 +1,5 @@
 #!/bin/sh
+exit 0
 ################################################################
 #  WARNING THIS FILE IS DEPRECATED 
 #  any changes to this file must also be made to  LinHES-session
diff --git a/abs/core/LinHES-system/LinHES-session b/abs/core/LinHES-system/LinHES-session
index f01e569..918406d 100755
--- a/abs/core/LinHES-system/LinHES-session
+++ b/abs/core/LinHES-system/LinHES-session
@@ -345,35 +345,34 @@ function set_background()
 
 if [ x$WM = "x" ]
 then
-	fluxbox > /var/log/fluxbox.log 2>&1
-
-else
-    #if using mythvantage style, start the WM right away
-    # this is done so that starting mythtv can loop.
-    $WM &
-    pid=$!
-    mouse_move
-    keylaunch
-    set_background
-    unclutter
-    load_nvidia_settings
-    run_tilda
-    start_screensaver
-    show_help_tip
-    notify_scan &
-    update_apple_trailers
-
-    first_configure
-    start_myth
-
-    # wait for the  windowmanger
-    #This will make the session wait on the WM to exit.
-    if [ x$STARTUP_STYLE != xmythvantage ]
-    then
-        wait $pid
-    fi
+#	fluxbox > /var/log/fluxbox.log 2>&1
+    WM=fluxbox
+fi
 
+#if using mythvantage style, start the WM right away
+# this is done so that starting mythtv can loop.
+$WM &
+pid=$!
+mouse_move
+keylaunch
+set_background
+unclutter
+load_nvidia_settings
+run_tilda
+start_screensaver
+show_help_tip
+notify_scan &
+update_apple_trailers
+first_configure
+start_myth
+
+# wait for the  windowmanger
+#This will make the session wait on the WM to exit.
+if [ x$STARTUP_STYLE != xmythvantage ]
+then
+    wait $pid
 fi
 
 
 
+
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index a2f0010..6881e3c 100644
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=2
-pkgrel=51
+pkgrel=52
 arch=('i686')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
@@ -52,13 +52,13 @@ build() {
         mkdir $startdir/pkg/etc/logrotate.d
         cp $startdir/myth_mtc.lr $startdir/pkg/etc/logrotate.d
 }
-md5sums=('e62397288e9b3b41c5ca2a73500db865'
+md5sums=('d1a5963c5a440a608031c6d750232633'
          '5881bdb43d578ec3a79d1f77ea58a3db'
          'a875ee97f86e46f34a741c2bc455f894'
          '76b2637cac0452b3acdbeeb4e8a5474b'
          'd1f27cb422010077c841376526fe46ea'
          '2ef9f945e034119f77d9b6beb17e4fa5'
-         '390af4b95a186c5ea1c2c1de9b1de00a'
+         '4b4585ccba30595cf958d202997c57f7'
          'cbe4cba14fa9d01a62e2196edc1bd98b'
          'dc3eef2a624754e16805d72bbe488b67'
          'dc0be354ce77ba2b89868fc29b942c43'
-- 
cgit v0.12