From 28cc8bad3efc117db88d38e19e7d9a8a75efbe75 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 2 Sep 2015 22:42:27 +0000
Subject: mythinstall: simplify default device to 1 list

there are some cards that we identify wrong as analog or digital so to remove confusion just offer 1 list with all found devices
---
 .../MythVantage-app/mythinstall/installdialog.cpp  |   4 +-
 .../mythinstall/installsettings.cpp                | 261 +++++----------------
 .../MythVantage-app/mythinstall/installsettings.h  |  38 +--
 abs/core/mythinstall/PKGBUILD                      |   2 +-
 4 files changed, 67 insertions(+), 238 deletions(-)

diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installdialog.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/installdialog.cpp
index e18da49..4c7099d 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installdialog.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installdialog.cpp
@@ -1127,8 +1127,8 @@ void WelcomeDialog::install_it(void)
             }
         }
         file.close();
-        bool ok;
-        int mem = currentitem.toInt( &ok, 10 );     // dec == 0, ok == FALSE
+//        bool ok;
+//        int mem = currentitem.toInt( &ok, 10 );     // dec == 0, ok == FALSE
 
 
 //         if ( mem >= 500000 )
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
index adc9430..37dc7c9 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
@@ -1090,26 +1090,6 @@ static HostCheckBox *Hostpluginmythweather()
 };
 
 
-//static HostCheckBox *HostMiro()
-//{
-//    HostCheckBox *gc = new HostCheckBox("HostMiro");
-//    gc->setLabel(QObject::tr("Miro"));
-//    gc->setValue(false);
-//    gc->setHelpText(QObject::tr("Miro is a popular, free, and open internet TV application. It brings video channels from thousands of sources and has more free HD than any other platform."));
-//    return gc;
-//};
-
-
-// static HostCheckBox *HostXine()
-// {
-//     HostCheckBox *gc = new HostCheckBox("HostXine");
-//     gc->setLabel(QObject::tr("Xine"));
-//     gc->setValue(false);
-//     gc->setHelpText(QObject::tr("Xine is a free multimedia player"));
-//     return gc;
-// };
-
-
 static HostCheckBox *Hostwebmin()
 {
     HostCheckBox *gc = new HostCheckBox("Hostwebmin");
@@ -2775,31 +2755,6 @@ SoundSettings::SoundSettings():
     addChild(HostAudiotype);
     setTrigger(HostAudiotype);
 
-//     HostsyncXine = new HostCheckBox("HostsyncXine");
-//     HostsyncXine->setLabel(QObject::tr("Xine"));
-//     HostsyncXine->setValue(true);
-//
-//     HostsyncMplayer = new HostCheckBox("HostsyncMplayer");
-//     HostsyncMplayer->setLabel(QObject::tr("mplayer"));
-//     HostsyncMplayer->setValue(true);
-//
-//     HostsyncMythMusic = new HostCheckBox("HostsyncMythMusic");
-//     HostsyncMythMusic->setLabel(QObject::tr("mythmusic"));
-//     HostsyncMythMusic->setValue(true);
-//
-//     HostsyncMythFrontend = new HostCheckBox("HostsyncMythFrontend");
-//     HostsyncMythFrontend->setLabel(QObject::tr("mythfrontend"));
-//     HostsyncMythFrontend->setValue(true);
-
-
-
-
-//     HorizontalConfigurationGroup *syncboxes =   new HorizontalConfigurationGroup(false, false, true, true);
-//     syncboxes->addChild(HostsyncXine);
-//     syncboxes->addChild(HostsyncMplayer);
-//     syncboxes->addChild(HostsyncMythMusic);
-//     syncboxes->addChild(HostsyncMythFrontend);
-
     HorizontalConfigurationGroup *lp = new HorizontalConfigurationGroup(false, false, true, true);
     HorizontalConfigurationGroup *lpalsa = new HorizontalConfigurationGroup(false, false, true, true);
 
@@ -2810,13 +2765,13 @@ SoundSettings::SoundSettings():
 
     TransButtonSetting *TestAudiobutton = new TransButtonSetting();
     TestAudiobutton->setLabel(tr("Test Device"));
-    TestAudiobutton->setHelpText(QObject::tr("Will play a sound using the selected default device."));
+    TestAudiobutton->setHelpText(QObject::tr("Play a sound using the selected default device."));
     lp->addChild(TestAudiobutton);
     lp->addChild(LoadOSSbutton);
 
     TransButtonSetting *TestALSAAudiobutton = new TransButtonSetting();
     TestALSAAudiobutton->setLabel(tr("Test Device"));
-    TestALSAAudiobutton->setHelpText(QObject::tr("Will play a sound using the selected default device."));
+    TestALSAAudiobutton->setHelpText(QObject::tr("Play a sound using the selected default device."));
     lpalsa->addChild(TestALSAAudiobutton);
     lpalsa->addChild(LoadALSAbutton);
 
@@ -2831,7 +2786,6 @@ SoundSettings::SoundSettings():
     ConfigurationGroup* osssettings = new VerticalConfigurationGroup(false);
     osssettings->addChild(osslabel);
     osssettings->addChild(OSS);
-   // osssettings->addChild(syncboxes);
     osssettings->addChild(lp);
     connect(this, SIGNAL(oss_sig()),
             OSS,   SLOT(soundossgathersettings()));
@@ -2845,7 +2799,6 @@ SoundSettings::SoundSettings():
     ConfigurationGroup* alsasettings = new VerticalConfigurationGroup(false);
     alsasettings->addChild(AlsaLabel);
     alsasettings->addChild(ALSA);
-//    alsasettings->addChild(syncboxes);
     alsasettings->addChild(lpalsa);
 
     connect(this, SIGNAL(alsa_sig()),
@@ -2863,54 +2816,26 @@ SoundOSSsettings::SoundOSSsettings():
     TriggeredConfigurationGroup(true,false,true,true,true,true,true,true)
 {
     SetVertical(true);
-    HostSoundTypeout = new HostComboBox("HostSoundTypeout");
-    HostSoundTypeout->setLabel(QObject::tr("Audio Type"));
-    HostSoundTypeout->addSelection("Analog");
-    HostSoundTypeout->addSelection("Digital");
-    HostSoundTypeout->setHelpText(QObject::tr("Select the connection type, Analog or Digital."));
-
-    HostSoundOssAnalog = new HostComboBox("HostSoundOssAnalog");
-    HostSoundOssAnalog->setLabel(QObject::tr("Default Device"));
-    HostSoundOssAnalog->setHelpText(QObject::tr("Select the default audio output device for the system."));
-    HostSoundOssDigital = new HostComboBox("HostSoundOssDigital");
-    HostSoundOssDigital->setLabel(QObject::tr("Default Device"));
-    HostSoundOssDigital->setHelpText(QObject::tr("Select the default audio output device for the system."));
+    HostSoundOssAll = new HostComboBox("HostSoundOssAll");
+    HostSoundOssAll->setLabel(QObject::tr("Default Device"));
+    HostSoundOssAll->setHelpText(QObject::tr("Select the default audio output device for the system."));
     fillossselection();
-    int findossanalog=HostSoundOssAnalog->findSelection(hostparm.OLDHostSoundOSSAnalog );
-    int findossdigital=HostSoundOssDigital->findSelection(hostparm.OLDHostSoundOSSDigital );
-    HostSoundOssAnalog->setValue(findossanalog);
-    HostSoundOssDigital->setValue(findossdigital);
-    addChild(HostSoundTypeout);
-    setTrigger(HostSoundTypeout);
-    addTarget("Analog", HostSoundOssAnalog);
-    addTarget("Digital", HostSoundOssDigital);
+    int findossall=HostSoundOssAll->findSelection(hostparm.OLDHostSoundOSSAll );
+    HostSoundOssAll->setValue(findossall);
+    addTarget("All", HostSoundOssAll);
 };
 
 SoundALSAsettings::SoundALSAsettings():
     TriggeredConfigurationGroup(true,false,true,true,true,true,true,true)
 {
     SetVertical(true);
-    HostSoundALSATypeout = new HostComboBox("HostSoundALSATypeout");
-    HostSoundALSATypeout->setLabel(QObject::tr("Audio Type"));
-    HostSoundALSATypeout->addSelection("Analog");
-    HostSoundALSATypeout->addSelection("Digital");
-    HostSoundALSATypeout->setHelpText(QObject::tr("Select the connection type, Analog or Digital."));
-
-    HostSoundALSAAnalog = new HostComboBox("HostSoundALSAAnalog");
-    HostSoundALSAAnalog->setLabel(QObject::tr("Default Device"));
-    HostSoundALSAAnalog->setHelpText(QObject::tr("Select the default audio output device for the system. Chrome, aplay and other programs that use the default system device for audio will use this device. Mplayer will be set to use this device."));
-    HostSoundALSADigital = new HostComboBox("HostSoundALSADigital");
-    HostSoundALSADigital->setLabel(QObject::tr("Default Device"));
-    HostSoundALSADigital->setHelpText(QObject::tr("Select the default audio output device for the system. Chrome, aplay and other programs that use the default system device for audio will use this device. Mplayer will be set to use this device."));
+    HostSoundALSAAll = new HostComboBox("HostSoundALSAAll");
+    HostSoundALSAAll->setLabel(QObject::tr("Default Device"));
+    HostSoundALSAAll->setHelpText(QObject::tr("Select the default audio output device for the system. Chrome, aplay and other programs that use the default system device for audio will use this device. Mplayer will be set to use this device."));
     fillALSAselection();
-    int findalsaanalog=HostSoundALSAAnalog->findSelection(hostparm.OLDHostSoundALSAAnalog );
-    int findalsadigital=HostSoundALSADigital->findSelection(hostparm.OLDHostSoundALSADigital );
-    HostSoundALSAAnalog->setValue(findalsaanalog);
-    HostSoundALSADigital->setValue(findalsadigital);
-    addChild(HostSoundALSATypeout);
-    setTrigger(HostSoundALSATypeout);
-    addTarget("Analog", HostSoundALSAAnalog);
-    addTarget("Digital", HostSoundALSADigital);
+    int findalsaall=HostSoundALSAAll->findSelection(hostparm.OLDHostSoundALSAAll );
+    HostSoundALSAAll->setValue(findalsaall);
+    addTarget("All", HostSoundALSAAll);
 };
 
 void  SoundOSSsettings::loadossdriver()
@@ -2929,6 +2854,7 @@ void  SoundOSSsettings::loadossdriver()
     MythUIBusyDialog *busyPopup = new MythUIBusyDialog(msgtext, popupStack,
                                                        "ossbusy");
 
+
     int progressbar=1;
     MythProgressDialog *popupProgress = NULL;
     popupProgress = new MythProgressDialog(msgtext, 50);
@@ -2966,7 +2892,6 @@ void  SoundOSSsettings::loadossdriver()
         busyPopup = NULL;
     }
 
-
     if (popupProgress)
     {
         popupProgress->Close();
@@ -2974,7 +2899,6 @@ void  SoundOSSsettings::loadossdriver()
     }
 
     fillossselection();
-
 }
 void  SoundALSAsettings::loadalsadriver()
 {
@@ -2984,7 +2908,9 @@ void  SoundALSAsettings::loadalsadriver()
     cmdtxt.append("bin/soundconfig.sh -t LOAD  -i ALSA &");
     system(cmdtxt);
     int return_code = 0;
+
     QString msgtext = "Loading ALSA driver" ;
+
     MythScreenStack *popupStack = GetMythMainWindow()->GetStack("popup stack");
     MythUIBusyDialog *busyPopup = new MythUIBusyDialog(msgtext, popupStack,"installbusy");
     if (busyPopup->Create())
@@ -3031,11 +2957,7 @@ void  SoundALSAsettings::loadalsadriver()
         popupProgress->deleteLater();
     }
 
-     HostSoundALSAAnalog-> clearSelections();
-     HostSoundALSADigital-> clearSelections();
-
     fillALSAselection();
-
 }
 void  SoundOSSsettings::fillossselection()
 {
@@ -3049,9 +2971,7 @@ void  SoundOSSsettings::fillossselection()
     QRegExp sep( "\t"   );
     QFile file(currentfile);
     QString ossfound="false";
-    HostSoundOssAnalog->clearSelections();
-    HostSoundOssDigital-> clearSelections();
-
+    HostSoundOssAll->clearSelections();
 
     if ( file.open(QIODevice::ReadOnly | QIODevice::Text) )
     {
@@ -3070,18 +2990,14 @@ void  SoundOSSsettings::fillossselection()
                 simpleitem.append(" (");
                 simpleitem.append(legacy_device);
                 simpleitem.append(")");
-                if (line.contains("spdout") || line.contains("digital") )
-                    HostSoundOssDigital->addSelection(simpleitem);
-                else
-                    HostSoundOssAnalog->addSelection(simpleitem);
+                HostSoundOssAll->addSelection(simpleitem);
                 ossfound="true";
             }
         }
         if (ossfound=="false")
         {
-            simpleitem="No cards found, try loading the OSS drivers";
-            HostSoundOssAnalog->addSelection(simpleitem);
-            HostSoundOssDigital->addSelection(simpleitem);
+            simpleitem="No devices found, try loading the OSS driver";
+            HostSoundOssAll->addSelection(simpleitem);
         }
     }
     return ;
@@ -3090,9 +3006,8 @@ void  SoundOSSsettings::fillossselection()
 
 void  SoundALSAsettings::fillALSAselection()
 {
-    HostSoundALSAAnalog-> clearSelections();
-    HostSoundALSADigital-> clearSelections();
-    myth_system("aplay -l > /tmp/alsadevices");
+    HostSoundALSAAll-> clearSelections();
+    myth_system("aplay -l > /tmp/alsadevices 2>&1");
     QString currentfile = "/tmp/alsadevices";
     QString line;
     QString hwdevice;
@@ -3101,21 +3016,21 @@ void  SoundALSAsettings::fillALSAselection()
     QString temphwdevice;
     QString simpleitem;
     QFile file(currentfile);
+
     if ( file.open(QIODevice::ReadOnly | QIODevice::Text) )
     {
         Q3TextStream t( &file );        // use a text stream
         while ( !t.eof() )
         {
             line = t.readLine();
+            if (line.contains("no soundcards found..."))
+            {
+                simpleitem="No devices found, try loading the ALSA driver";
+                HostSoundALSAAll->addSelection(simpleitem);
+                break;
+            }
             if (line.startsWith("card") )
             {
-                if (line.contains("snd_ctl_card_info"))
-                {
-                    simpleitem="Try loading the alsa drivers";
-                    HostSoundALSAAnalog->addSelection(simpleitem);
-                    HostSoundALSADigital->addSelection(simpleitem);
-                    break;
-                }
                 //card 0: I82801DBICH4:q [Intel 82801DB-ICH4], device 0: Intel ICH [Intel 82801DB-ICH4]
                 alsadescription=line.section( ", " , 0 ,0 );
                 alsadescription=alsadescription.section(": ",1,1);
@@ -3133,10 +3048,7 @@ void  SoundALSAsettings::fillALSAselection()
                 hwdevice.append(",");
                 hwdevice.append(temphwdevice);
                 simpleitem=alsadescription + " " + alsadescription2 + "(plughw:" + alsadescription + "," + temphwdevice + ")";
-                if (line.contains("IEC958") || line.contains("Digital") || line.contains("PCM") || line.contains("HDMI"))
-                    HostSoundALSADigital->addSelection(simpleitem);
-                else
-                    HostSoundALSAAnalog->addSelection(simpleitem);
+                HostSoundALSAAll->addSelection(simpleitem);
             }
         }
     }
@@ -3153,7 +3065,7 @@ void  SoundALSAsettings::fillALSAselection()
             {
                 alsadescription=line;
                 simpleitem=alsadescription + "(plug:iec958)";
-                HostSoundALSADigital->addSelection(simpleitem);
+                HostSoundALSAAll->addSelection(simpleitem);
                 break;
             }
         }
@@ -3164,20 +3076,12 @@ void  SoundALSAsettings::fillALSAselection()
 void SoundSettings::soundossgathersettings_1 (void)
 {
     hostparm.ThisHostAudiotype = HostAudiotype->getValue();
-//     hostparm.ThisHostsyncXine = HostsyncXine->getValue();
-//     hostparm.ThisHostsyncMplayer = HostsyncMplayer->getValue();
-//     hostparm.ThisHostsyncMythMusic = HostsyncMythMusic->getValue();
-//     hostparm.ThisHostsyncMythFrontend = HostsyncMythFrontend->getValue();
     // emit the signal to call soundossgathersetting.
     emit oss_sig();
 };
 void SoundSettings::soundalsagathersettings_1 (void)
 {
     hostparm.ThisHostAudiotype = HostAudiotype->getValue();
-//     hostparm.ThisHostsyncXine = HostsyncXine->getValue();
-//     hostparm.ThisHostsyncMplayer = HostsyncMplayer->getValue();
-//     hostparm.ThisHostsyncMythMusic = HostsyncMythMusic->getValue();
-//     hostparm.ThisHostsyncMythFrontend = HostsyncMythFrontend->getValue();
     // emit the signal to call soundALSAgathersetting.
     emit alsa_sig();
 };
@@ -3185,18 +3089,9 @@ void SoundSettings::soundalsagathersettings_1 (void)
 
 void SoundOSSsettings::soundossgathersettings(void)
 {
-    hostparm.ThisHostSoundTypeout =  HostSoundTypeout->getValue() ;
-    hostparm.ThisHostSoundOSSAnalog = HostSoundOssAnalog->getValue();
-    hostparm.ThisHostSoundOSSDigital = HostSoundOssDigital->getValue();
+    hostparm.ThisHostSoundOSSAll = HostSoundOssAll->getValue();
     QString tempdevice;
-    if  ( hostparm.ThisHostSoundTypeout == "Analog" )
-    {
-        tempdevice  =  hostparm.ThisHostSoundOSSAnalog ;
-    }
-    else
-    {
-        tempdevice = hostparm.ThisHostSoundOSSDigital ;
-    };
+    tempdevice = hostparm.ThisHostSoundOSSAll ;
     tempdevice = tempdevice.section( "(", 1,1 );
     tempdevice = tempdevice.section( ")", 0,0 );
     hostparm.ThisHostSoundDevice = "/dev/";
@@ -3204,7 +3099,7 @@ void SoundOSSsettings::soundossgathersettings(void)
     // Add info popup right here
     QString cmdtxt;
     cmdtxt=MV_ROOT  ;
-    cmdtxt.append("bin/soundconfig.sh -t test  -i OSS -d " +  hostparm.ThisHostSoundDevice + "&");
+    cmdtxt.append("bin/soundconfig.sh -t test -i OSS -d " + hostparm.ThisHostSoundDevice + "&");
     system(cmdtxt);
     int return_code = 0;
     QString msgtext = "Playing Test Audio" ;
@@ -3220,10 +3115,6 @@ void SoundOSSsettings::soundossgathersettings(void)
         popupProgress->setProgress(progressbar);
     }
 
-
-
-
-
     if (busyPopup->Create())
     {
         popupStack->AddScreen(busyPopup, false);
@@ -3234,9 +3125,6 @@ void SoundOSSsettings::soundossgathersettings(void)
         busyPopup = NULL;
     }
 
-
-
-
     while (  return_code == 0 )
     {
         progressbar++;
@@ -3266,19 +3154,10 @@ void SoundOSSsettings::soundossgathersettings(void)
 void SoundALSAsettings::soundalsagathersettings(void)
 {
 
-    hostparm.ThisHostSoundALSATypeout =  HostSoundALSATypeout->getValue() ;
-    hostparm.ThisHostSoundALSAAnalog = HostSoundALSAAnalog->getValue();
-    hostparm.ThisHostSoundALSADigital = HostSoundALSADigital->getValue();
+    hostparm.ThisHostSoundALSAAll = HostSoundALSAAll->getValue();
 
     QString tempdevice;
-    if  ( hostparm.ThisHostSoundALSATypeout == "Analog" )
-    {
-        tempdevice  =  hostparm.ThisHostSoundALSAAnalog ;
-    }
-    else
-    {
-        tempdevice = hostparm.ThisHostSoundALSADigital ;
-    };
+    tempdevice  =  hostparm.ThisHostSoundALSAAll ;
     tempdevice = tempdevice.section( "(", 1,1 );
     tempdevice = tempdevice.section( ")", 0,0 );
     hostparm.ThisHostSoundDevice = tempdevice;
@@ -3310,7 +3189,6 @@ void SoundALSAsettings::soundalsagathersettings(void)
     }
 
 
-
     while (  return_code == 0 )
     {
         progressbar++;
@@ -3336,9 +3214,6 @@ void SoundALSAsettings::soundalsagathersettings(void)
             popupProgress->deleteLater();
         }
 
-
-
-
 };
 
 
@@ -3928,27 +3803,15 @@ void writesettings ()
 // AUDIO SETTINGS
 //******************************************************************************************
     hostparm.ThisHostAudiotype =  gCoreContext->GetSetting("HostAudiotype");
-//     hostparm.ThisHostsyncXine = gCoreContext->GetSetting("HostsyncXine");
-//     hostparm.ThisHostsyncMplayer = gCoreContext->GetSetting("HostsyncMplayer");
-//     hostparm.ThisHostsyncMythMusic = gCoreContext->GetSetting("HostsyncMythMusic");
-//     hostparm.ThisHostsyncMythFrontend = gCoreContext->GetSetting("HostsyncMythFrontend");
-    hostparm.ThisHostSoundTypeout =  gCoreContext->GetSetting("HostSoundTypeout") ;
-    hostparm.ThisHostSoundOSSAnalog = gCoreContext->GetSetting("HostSoundOssAnalog");
-    hostparm.ThisHostSoundOSSDigital = gCoreContext->GetSetting("HostSoundOssDigital");
-    hostparm.ThisHostSoundALSATypeout =  gCoreContext->GetSetting("HostSoundALSATypeout") ;
-    hostparm.ThisHostSoundALSAAnalog = gCoreContext->GetSetting("HostSoundALSAAnalog");
-    hostparm.ThisHostSoundALSADigital = gCoreContext->GetSetting("HostSoundALSADigital");
+    hostparm.ThisHostSoundOSSAll = gCoreContext->GetSetting("HostSoundOssAll");
+    hostparm.ThisHostSoundALSAAll = gCoreContext->GetSetting("HostSoundALSAAll");
 
     if ( hostparm.ThisHostAudiotype  == "OSS"   )
     {
         QString tempdevice;
         QChar tempchar  ;
         hostparm.ThisHostSoundDevice = "/dev/dsp";
-        if  ( hostparm.ThisHostSoundTypeout == "Analog" )
-            tempdevice  =  hostparm.ThisHostSoundOSSAnalog ;
-
-        if  ( hostparm.ThisHostSoundTypeout == "Digital" )
-            tempdevice = hostparm.ThisHostSoundOSSDigital ;
+        tempdevice = hostparm.ThisHostSoundOSSAll ;
 
         int tlength=(tempdevice.length()  -2 );
         if  ( tlength > 0  )
@@ -3962,19 +3825,12 @@ void writesettings ()
     if ( hostparm.ThisHostAudiotype  == "ALSA"   )
     {
         QString tempdevice;
-        hostparm.ThisHostSoundTypeout = hostparm.ThisHostSoundALSATypeout;
-        if (  hostparm.ThisHostSoundTypeout == "Digital" )
-            tempdevice=hostparm.ThisHostSoundALSADigital;
-        if (  hostparm.ThisHostSoundTypeout == "Analog" )
-            tempdevice=hostparm.ThisHostSoundALSAAnalog;
+        tempdevice=hostparm.ThisHostSoundALSAAll;
 
         tempdevice = tempdevice.section( "(", 1,1 );
         tempdevice = tempdevice.section( ")", 0,0 );
         hostparm.ThisHostSoundDevice = tempdevice;
     }
-// Turn off internal audio controls is digital audio is seleced
-    if  ( hostparm.ThisHostSoundTypeout == "Digital" )
-        gCoreContext->SaveSetting("MythControlsVolume","0");
 
 //  LCD TYPE
     hostparm.ThisHostLCDType = gCoreContext->GetSetting("HostLCDType");
@@ -4004,11 +3860,9 @@ void writesettings ()
 
     hostparm.ThisHostpluginmythvideo_dvdcss = gCoreContext->GetSetting("Hostpluginmythvideo_dvdcss");
     hostparm.ThisHostpluginmythappletrailers= gCoreContext->GetSetting("Hostpluginmythappletrailers");
-//    hostparm.ThisHostMiro= gCoreContext->GetSetting("HostMiro");
     hostparm.ThisHostpluginmythgameMednafen= gCoreContext->GetSetting("HostpluginmythgameMednafen");
     hostparm.ThisHostpluginmythgameROMDB= gCoreContext->GetSetting("HostpluginmythgameROMDB");
     hostparm.ThisHostpluginmythgameMupen64= gCoreContext->GetSetting("HostpluginmythgameMupen64");
-//    hostparm.ThisHostXine = gCoreContext->GetSetting("HostXine");
     hostparm.ThisHostwebmin = gCoreContext->GetSetting("Hostwebmin");
     hostparm.ThisHostHuluDesktop = gCoreContext->GetSetting("HostHuluDesktop");
     hostparm.ThisHostwebonlinhes = gCoreContext->GetSetting("HostWebonlinhes");
@@ -4309,12 +4163,7 @@ void writesettings ()
     myfile << systemheader ;
     myfile << divider ;
     myfile << "Audiotype=\""            + hostparm.ThisHostAudiotype + "\"\n";
-    myfile << "Audiotypeout=\""            + hostparm.ThisHostSoundTypeout + "\"\n";
     myfile << "SoundDevice=\""    + hostparm.ThisHostSoundDevice+  "\"\n";
-//     myfile << "syncXine=\""   + hostparm.ThisHostsyncXine + "\"\n";
-//     myfile << "syncMplayer=\""   + hostparm.ThisHostsyncMplayer + "\"\n";
-//     myfile << "syncMythMusic=\""   + hostparm.ThisHostsyncMythMusic + "\"\n";
-//     myfile << "syncMythFrontend=\""   + hostparm.ThisHostsyncMythFrontend + "\"\n";
 
 
     systemheader= "\n#    Software settings\n"  ;
@@ -4344,7 +4193,6 @@ void writesettings ()
     myfile << "dvdcss=\"" + hostparm.ThisHostpluginmythvideo_dvdcss + "\"\n";
     myfile << "mythappletrailers=\"" + hostparm.ThisHostpluginmythappletrailers + "\"\n";
 
-//    myfile << "miro=\"" + hostparm.ThisHostMiro + "\"\n";
     myfile << "webonlinhes=\"" + hostparm.ThisHostwebonlinhes + "\"\n";
     myfile << "huludesktop=\"" + hostparm.ThisHostHuluDesktop + "\"\n";
     myfile << "kodi=\"" + hostparm.ThisHostXBMC + "\"\n";
@@ -4353,7 +4201,6 @@ void writesettings ()
     myfile << "foldingathome=\"" + hostparm.ThisHostfoldingathome  + "\"\n";
     myfile << "foldingusername=\"" + hostparm.ThisHostfoldingusername  + "\"\n";
     myfile << "foldingworksize=\"" + hostparm.ThisHostfoldingworksize  + "\"\n";
-    //  myfile << "xine=\"" + hostparm.ThisHostXine  + "\"\n";
     myfile << "webmin=\"" + hostparm.ThisHostwebmin  + "\"\n";
 
 
@@ -4668,23 +4515,33 @@ MythInstallSettings::MythInstallSettings()
             {
                 //remove old sound card setting from the db.  This is useful for when the saved setting is no longer valid for this machine.
                 // Later search the list and set the value to the old setting if found in the dropdown.
-                hostparm.OLDHostSoundOSSAnalog = gCoreContext->GetSetting("HostSoundOssAnalog");
-                hostparm.OLDHostSoundOSSDigital = gCoreContext->GetSetting("HostSoundOssDigital");
-                hostparm.OLDHostSoundALSAAnalog = gCoreContext->GetSetting("HostSoundALSAAnalog");
-                hostparm.OLDHostSoundALSADigital= gCoreContext->GetSetting("HostSoundALSADigital");
+                hostparm.OLDHostSoundOSSAll = gCoreContext->GetSetting("HostSoundOssAll");
+                hostparm.OLDHostSoundALSAAll = gCoreContext->GetSetting("HostSoundALSAAll");
 
 
                 MSqlQuery query(MSqlQuery::InitCon());
+                query.prepare( "delete from settings where  hostname=:HOSTNAME  and value = 'HOSTSoundOssAll';  "  );
+                query.bindValue( ":HOSTNAME" ,   gCoreContext->GetHostName()  );
+                query.exec();
                 query.prepare( "delete from settings where  hostname=:HOSTNAME  and value = 'HOSTSoundOssAnalog';  "  );
                 query.bindValue( ":HOSTNAME" ,   gCoreContext->GetHostName()  );
                 query.exec();
+                query.prepare( "delete from settings where  hostname=:HOSTNAME  and value = 'HOSTSoundOssDigital';  "  );
+                query.bindValue( ":HOSTNAME" ,   gCoreContext->GetHostName()  );
+                query.exec();
+                query.prepare( "delete from settings where  hostname=:HOSTNAME  and value = 'HOSTSoundALSAAll';  "  );
+                query.bindValue( ":HOSTNAME" ,   gCoreContext->GetHostName()  );
+                query.exec();
                 query.prepare( "delete from settings where  hostname=:HOSTNAME  and value = 'HOSTSoundALSAAnalog';  "  );
                 query.bindValue( ":HOSTNAME" ,   gCoreContext->GetHostName()  );
                 query.exec();
                 query.prepare( "delete from settings where  hostname=:HOSTNAME  and value = 'HOSTSoundALSADigital';  "  );
                 query.bindValue( ":HOSTNAME" ,   gCoreContext->GetHostName()  );
                 query.exec();
-                query.prepare( "delete from settings where  hostname=:HOSTNAME  and value = 'HOSTSoundOssDigital';  "  );
+                query.prepare( "delete from settings where  hostname=:HOSTNAME  and value = 'HOSTSoundALSATypeout';  "  );
+                query.bindValue( ":HOSTNAME" ,   gCoreContext->GetHostName()  );
+                query.exec();
+                query.prepare( "delete from settings where  hostname=:HOSTNAME  and value = 'HOSTSoundTypeout';  "  );
                 query.bindValue( ":HOSTNAME" ,   gCoreContext->GetHostName()  );
                 query.exec();
 
@@ -4770,8 +4627,6 @@ MythInstallSettings::MythInstallSettings()
                 ConfigurationGroup *GridShowPlugin4 = new GridConfigurationGroup(2,false);
                 GridShowPlugin4->setLabel(QObject::tr("Programs (3/4)"));
                 GridShowPlugin4->addChild(Hostpluginmythappletrailers());
-                //GridShowPlugin4->addChild(HostMiro());
-                //GridShowPlugin4->addChild(HostXine());
                 GridShowPlugin4->addChild(HostHuluDesktop());
                 GridShowPlugin4->addChild(HostPLEXHT());
                 GridShowPlugin4->addChild(HostPLEXMS());
@@ -4779,7 +4634,7 @@ MythInstallSettings::MythInstallSettings()
                 GridShowPlugin4->addChild(Hostwebonlinhes());
                 GridShowPlugin4->addChild(HostXBMC());
 
-                ConfigurationGroup *GridShowPlugin5 = new GridConfigurationGroup(2);
+                //ConfigurationGroup *GridShowPlugin5 = new GridConfigurationGroup(2);
 
                 ConfigurationGroup *GridShowPlugin6 = new VerticalConfigurationGroup(false,true);
                 GridShowPlugin6->setLabel(QObject::tr("Programs (4/4)"));
@@ -4872,5 +4727,3 @@ MythInstallSettings::MythInstallSettings()
     }
 
 };
-
-
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
index 62b2500..3a53048 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
@@ -190,10 +190,6 @@ class SoundSettings:    public TriggeredConfigurationGroup {
 public:
     SoundSettings();
     HostComboBox *HostAudiotype;
-    HostCheckBox *HostsyncXine;
-    HostCheckBox *HostsyncMplayer;
-    HostCheckBox *HostsyncMythMusic;
-    HostCheckBox *HostsyncMythFrontend;
 
 
 signals:
@@ -210,9 +206,7 @@ class SoundOSSsettings: public TriggeredConfigurationGroup {
     Q_OBJECT
 public:
     SoundOSSsettings();
-    HostComboBox *HostSoundOssAnalog;
-    HostComboBox *HostSoundOssDigital;
-    HostComboBox *HostSoundTypeout;
+    HostComboBox *HostSoundOssAll;
     void fillossselection();
 public slots:
     void soundossgathersettings();
@@ -223,9 +217,7 @@ class SoundALSAsettings: public TriggeredConfigurationGroup {
     Q_OBJECT
 public:
     SoundALSAsettings();
-    HostComboBox *HostSoundALSAAnalog;
-    HostComboBox *HostSoundALSADigital;
-    HostComboBox *HostSoundALSATypeout;
+    HostComboBox *HostSoundALSAAll;
     void fillALSAselection();
 public slots:
     void soundalsagathersettings();
@@ -483,28 +475,14 @@ struct HostParms
     QString ThisHostXNvidia1080i;
     QString ThisHostXNvidia720p;
     QString ThisHostXNvidia480p;
-    QString ThisHostAudiotype;
-
-    QString ThisHostSoundTypeout;
-    QString ThisHostSoundOSSAnalog;
-    QString OLDHostSoundOSSAnalog;
-    QString ThisHostSoundOSSDigital;
-    QString OLDHostSoundOSSDigital;
 
-    QString ThisHostSoundDigital;
+    QString ThisHostAudiotype;
+    QString ThisHostSoundOSSAll;
+    QString OLDHostSoundOSSAll;
     QString ThisHostSoundDevice;
+    QString ThisHostSoundALSAAll;
+    QString OLDHostSoundALSAAll;
 
-    QString ThisHostSoundALSAAnalog;
-    QString OLDHostSoundALSAAnalog;
-    QString ThisHostSoundALSADigital;
-    QString OLDHostSoundALSADigital;
-    QString ThisHostSoundALSATypeout;
-
-
-    QString ThisHostsyncXine;
-    QString ThisHostsyncMplayer;
-    QString ThisHostsyncMythMusic;
-    QString ThisHostsyncMythFrontend;
     QString ThisHostLCDType;
     QString ThisHostRemoteBackup;
     QString ThisHostRemoteBackupDir;
@@ -521,7 +499,6 @@ struct HostParms
     QString ThisHostpluginmythvideo_dvdcss;
     QString ThisHostpluginmythappletrailers;
 
-//    QString ThisHostMiro;
     QString ThisHostwebonlinhes;
     QString ThisHostXBMC;
     QString ThisHostPLEXHT;
@@ -537,7 +514,6 @@ struct HostParms
     QString ThisHostpluginmythgameDolphin;
     QString ThisHostpluginmythgameXe;
 
-//    QString ThisHostXine;
     QString ThisHostwebmin;
     QString ThisHostfoldingathome;
     QString ThisHostfoldingusername;
diff --git a/abs/core/mythinstall/PKGBUILD b/abs/core/mythinstall/PKGBUILD
index 54e6266..e053c0d 100644
--- a/abs/core/mythinstall/PKGBUILD
+++ b/abs/core/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Jams
 pkgname=mythinstall
 pkgver=8.3
-pkgrel=10
+pkgrel=11
 pkgdesc="LinHES installer/systemconfig GUI."
 arch=('i686' 'x86_64')
 depends=('mythtv>=0.27')
-- 
cgit v0.12