From 283ff72c8f742f807e4788846447531bc9ae1ea9 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 1 Oct 2014 20:24:57 +0000
Subject: python-pillow: initial inclusion. dep of xbmc 13.2

---
 abs/core/python_modules/python-pillow/PKGBUILD    | 75 +++++++++++++++++++++++
 abs/core/python_modules/python-pillow/__changelog |  2 +
 2 files changed, 77 insertions(+)
 create mode 100644 abs/core/python_modules/python-pillow/PKGBUILD
 create mode 100644 abs/core/python_modules/python-pillow/__changelog

diff --git a/abs/core/python_modules/python-pillow/PKGBUILD b/abs/core/python_modules/python-pillow/PKGBUILD
new file mode 100644
index 0000000..fc93f2d
--- /dev/null
+++ b/abs/core/python_modules/python-pillow/PKGBUILD
@@ -0,0 +1,75 @@
+# $Id$
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+# Contributor: minder
+
+pkgbase=python-pillow
+#pkgname=(python-pillow python2-pillow)
+pkgname=(python2-pillow)
+pkgver=2.5.3
+pkgrel=2
+_appname=Pillow
+_py2basever=2.7
+_py3basever=3.4m
+pkgdesc="Python Imaging Library (PIL) fork. Python3 version."
+arch=('i686' 'x86_64')
+url="http://python-pillow.github.io/"
+license=('BSD')
+makedepends=('python2-setuptools' 'lcms' 'libwebp' 'tk')
+source=("http://pypi.python.org/packages/source/P/$_appname/$_appname-$pkgver.zip")
+md5sums=('9879437c28ee0ad6ea04b93d0be2c2d7')
+
+build() {
+  cd "$srcdir"
+  cp -r "$srcdir/$_appname-$pkgver" "$srcdir/${_appname}2-$pkgver"
+}  
+
+#package_python-pillow() {
+#  depends=('python' 'lcms' 'libwebp')
+#  optdepends=('tk: for the ImageTK module'
+#              'sane: for the Sane module'
+#              'python-pyqt4: for the ImageQt module')
+#  cd "$srcdir/$_appname-$pkgver"
+#  python3 setup.py install --root="$pkgdir/" --optimize=0
+#  pushd Sane
+#    python3 setup.py install --root="$pkgdir/" --optimize=0
+#  popd
+#  install -Dm644 docs/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+#  install -dm755 "$pkgdir/usr/include/python$_py3basever/"
+#  install -m644 -t "$pkgdir/usr/include/python$_py3basever/" libImaging/*.h
+
+#  # clean up bins
+#  cd "$pkgdir/usr/bin"
+#  for f in *.py; do
+#    mv "$f" "${f%.py}"
+#  done
+#}
+
+package_python2-pillow() {
+  pkgdesc="Python Imaging Library (PIL) fork. Python2 version."
+  depends=('python2' 'lcms' 'libwebp')
+  optdepends=('tk: for the ImageTK module'
+              'sane: for the Sane module'
+              'python2-pyqt4: for the ImageQt module')
+  provides=('python-imaging' 'python2-imaging')
+  conflicts=('python-imaging' 'python2-imaging')
+  replaces=('python2-imaging')
+  cd "$srcdir/${_appname}2-$pkgver"
+  sed -i 's|/usr/local/bin/python$|/usr/bin/env python2|' PIL/OleFileIO.py
+  python2 setup.py install --root="$pkgdir/" --optimize=0
+#  pushd Sane
+    python2 setup.py install --root="$pkgdir/" --optimize=0
+#  popd
+
+  install -Dm644 docs/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+  install -dm755 "$pkgdir/usr/include/python$_py2basever/"
+  install -m644 -t "$pkgdir/usr/include/python$_py2basever/" libImaging/*.h
+
+  # clean up bins
+  cd "$pkgdir/usr/bin"
+  for f in *.py; do
+    mv "$f" "${f%.py}2"
+  done
+}
+
diff --git a/abs/core/python_modules/python-pillow/__changelog b/abs/core/python_modules/python-pillow/__changelog
new file mode 100644
index 0000000..8e7b951
--- /dev/null
+++ b/abs/core/python_modules/python-pillow/__changelog
@@ -0,0 +1,2 @@
+PKGBUILD - comment out all python 3 stuff and only build for py 2
+PKGBUILD - rm sane dep
-- 
cgit v0.12