From d37a1cd22a4b4ee04d684eee891aae74681b4b06 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 10 Jan 2013 20:36:33 -0600
Subject: enlightenment:  added mythtv-setup to the list of programs to delay
 reveal. Also added /tmp/no_e_delay   and removed ~/.configure  for list of
 files to add/skip delay

---
 abs/core/enlightenment/PKGBUILD      |  4 ++--
 abs/core/enlightenment/startup.patch | 16 ++++++++++------
 2 files changed, 12 insertions(+), 8 deletions(-)

diff --git a/abs/core/enlightenment/PKGBUILD b/abs/core/enlightenment/PKGBUILD
index 7dab1ff..ea2bd1c 100644
--- a/abs/core/enlightenment/PKGBUILD
+++ b/abs/core/enlightenment/PKGBUILD
@@ -4,7 +4,7 @@
 pkgname=enlightenment
 pkgver=1.0.10
 _themever=1.0.1
-pkgrel=6
+pkgrel=7
 pkgdesc="A fast, flexible, and very extensible Window Manager"
 arch=('i686' 'x86_64')
 url="http://www.enlightenment.org"
@@ -36,4 +36,4 @@ package() {
 #  chown -R root:root "${pkgdir}"/usr/share/*
 }
 md5sums=('87441a2e7c4639e5d23198ed7bc834ea'
-         'd25aaec0b9f465d3b0c237a1c8ae7c2d')
+         '3aac55d552d0e77764fd8398796d4096')
diff --git a/abs/core/enlightenment/startup.patch b/abs/core/enlightenment/startup.patch
index 87c2344..68641fc 100644
--- a/abs/core/enlightenment/startup.patch
+++ b/abs/core/enlightenment/startup.patch
@@ -1,7 +1,7 @@
---- src/startup.orig	2012-04-29 21:43:59.424202996 +0000
-+++ src/startup.c	2012-04-29 22:19:28.350782803 +0000
-@@ -173,5 +173,55 @@
-
+--- src/startup.c.orig	2013-01-11 02:14:16.690976774 +0000
++++ src/startup.c	2013-01-11 02:18:38.781047513 +0000
+@@ -173,5 +173,59 @@
+ 
     Mode.place.enable_features--;
     ESync(ESYNC_STARTUP);
 +
@@ -17,8 +17,9 @@
 +   const char *homedir = "HOME";
 +   char *value;
 +   value = getenv(homedir);
-+   char *filename_config;
-+   filename_config = strcat(value , "/.configure");
++   //char *filename_config;
++   //filename_config = strcat(value , "/.configure");
++   const char *filename_config = "/tmp/no_e_delay";
 +   result_config = access (filename_config, F_OK);
 +
 +   if( result == 0 || result_config ==0  )
@@ -38,6 +39,9 @@
 +        ret = system("xwininfo -name \"mythwelcome\" 2>/dev/null >/dev/null " );
 +        if ( ret == 0 )
 +            break;
++        ret = system("xwininfo -name \"MythTV Setup\" 2>/dev/null >/dev/null " );
++        if ( ret == 0 )
++            break;
 +     }
 +     if ( ret != 0 )
 +      printf("ENLIGHTENMENT: Couldn't find mythfrontend/mythwelcome, starting anyhow \n");
-- 
cgit v0.12