From 1df1f16aa547880f622187807d508f847c63ca2e Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 31 May 2018 15:51:54 +0000
Subject: perl-net-sftp-foreign: update to 1.89

---
 .../perl_modules/perl-net-sftp-foreign/Changes     | 69 ++++++++++++++++++++++
 .../perl_modules/perl-net-sftp-foreign/PKGBUILD    | 24 ++++----
 2 files changed, 83 insertions(+), 10 deletions(-)

diff --git a/abs/core/perl_modules/perl-net-sftp-foreign/Changes b/abs/core/perl_modules/perl-net-sftp-foreign/Changes
index eff2bb0..8012661 100644
--- a/abs/core/perl_modules/perl-net-sftp-foreign/Changes
+++ b/abs/core/perl_modules/perl-net-sftp-foreign/Changes
@@ -1,5 +1,73 @@
 Revision history for Net::SFTP::Foreign
 
+1.77  Nov 5, 2013
+        - release as stable
+        - fix misspellings in error message
+
+1.76_04  Oct 2, 2013
+        - fix 'Use of "goto" to jump into a construct is deprecated'
+          warning (bug report by Brent Bates)
+        - don't force permissions from rput when copy_perm is unset
+
+1.76_03  Aug 26, 2013
+        - fix several spelling errors
+        - add spell checking test
+        - remove pod test from MANIFEST
+        - ensure that pty is not destroyed before main object (bug
+          report by Stephen Wylie) during global destruction
+
+1.76_02  Apr 29, 2013
+        - remove warning happening when best_effort was set, specially
+          visible from Compat module (bug report by emerlyn at
+          PerlMonks)
+
+1.76_01  Apr 26, 2013
+        - protect against callbacks setting $\ (bug report by Thomas
+          Wadley)
+
+1.75  Apr 2, 2013
+        - release as stable
+
+1.74_07  Mar 21, 2013
+        - seek method was returning offset instead of success value
+          (bug report by Paul Kolano).
+
+1.74_06  Mar 12, 2013
+        - disconnect may kill some unrelated process when called
+          repeatly (bug report by Douglas Wilson)
+        - debug was clobbering $!
+
+1.74_05  Feb 5, 2013
+        - error was not being set on timeouts (bug report by Kqfh
+          Jjgrn)
+
+1.74_04  Oct 25, 2012
+        - overwriting rename of a file over itself was broken (bug
+          report by Mike Wilder)
+        - stat and lstat path arguments is now optional and defaults
+          to '.' (bug report by Paul Kolano)
+        - fstat was broken
+        - add git repository and bugtracker into meta files
+
+1.74_03  Sep 21, 2012
+        - put_content was broken (bug report by Caleb Cushing)
+        - document put_content method
+        - add more tests
+
+1.74_02  Jul 11, 2012
+        - rget was dieing when trying to copy remote symbolic links
+        - add support for get method slow-start feature: when file
+          size is unknown don't start asking for $queue_size packets
+          as it slows down the transfer of small files, instead,
+          starting from a queue size of one go gradually increasing it
+          until the stated maximum is reached (bug report by David
+          R. Wagner)
+        - parse supported2 extension
+
+1.74_01
+        - add support for password_prompt (feature request by Douglas
+          Wilson)
+
 1.73  May 11, 2012
         - password authentication was broken on Solaris (maybe also on
           others) due to an incorrect waitpid call (bug report and
@@ -134,6 +202,7 @@ Revision history for Net::SFTP::Foreign
           get_symlink options using hashes
         - remove operation inside put_symlink was clobbering error and
           status from previous symlink call
+        - solve several minor bugs related to autodie handling
         - do not die from inside DESTROY methods when autodie is set
         - resume feature in get method was broken
         - refactor numbered logic inside _inc_numbered sub
diff --git a/abs/core/perl_modules/perl-net-sftp-foreign/PKGBUILD b/abs/core/perl_modules/perl-net-sftp-foreign/PKGBUILD
index 61fb3b8..7fa9937 100644
--- a/abs/core/perl_modules/perl-net-sftp-foreign/PKGBUILD
+++ b/abs/core/perl_modules/perl-net-sftp-foreign/PKGBUILD
@@ -1,20 +1,22 @@
+# Maintainer: "Jameson Pugh <imntreal@gmail.com>"
 # Contributor: Alessandro Sagratini <ale_sagra at hotmail dot com>
+
 pkgname=perl-net-sftp-foreign
-pkgver=1.73
+pkgver=1.89
 pkgrel=1
 pkgdesc="Perl SFTP client using the native SSH client application"
-arch=(any)
-url=http://search.cpan.org/~salva/Net-SFTP-Foreign
+arch=('any')
+url='http://search.cpan.org/~salva/Net-SFTP-Foreign'
 license=('GPL' 'PerlArtistic')
 depends=('perl>=5.10.0') 
 optdepends=('perl-file-which' 'perl-sort-key')
-options=(!emptydirs)
+options=('!emptydirs')
 changelog=Changes
-source=(http://search.cpan.org/CPAN/authors/id/S/SA/SALVA/Net-SFTP-Foreign-$pkgver.tar.gz)
-md5sums=('3de69b9281027e484a30e3efa581981f')
+source=("http://search.cpan.org/CPAN/authors/id/S/SA/SALVA/Net-SFTP-Foreign-${pkgver}.tar.gz")
+sha256sums=('9bd33e130581c1fc3eb6108eaf9056c1507428cace04a572f7afe816d83b08a7')
 
 build() {
-	cd "$srcdir/Net-SFTP-Foreign-$pkgver"
+	cd "${srcdir}/Net-SFTP-Foreign-${pkgver}"
 
 	# install module in vendor directories.
 	PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
@@ -22,9 +24,11 @@ build() {
 }
 
 package() {
-	cd "$srcdir/Net-SFTP-Foreign-$pkgver"
+	cd "${srcdir}/Net-SFTP-Foreign-${pkgver}"
 	make install DESTDIR=${pkgdir} || return 1
 	# remove perllocal.pod and .packlist
-	find "$pkgdir" -name perllocal.pod -delete
-	find "$pkgdir" -name .packlist -delete
+	find "${pkgdir}" -name perllocal.pod -delete
+	find "${pkgdir}" -name .packlist -delete
 }
+
+# vim:set ts=2 sw=2 et:
-- 
cgit v0.12