From 08ddf5889e4e0898ef0a17a8fe669800fe2616e1 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 21 Jan 2012 19:32:12 -0600
Subject: runit-scripts: mythbackend.  Add add_storage --report to startup.
 This will print out a list of any new disks found

refs #796
---
 abs/core/runit-scripts/PKGBUILD                    |  2 +-
 .../runitscripts/services/mythbackend/log/run      |  8 --------
 .../runitscripts/services/mythbackend/run          | 22 +++++++++++++++++-----
 3 files changed, 18 insertions(+), 14 deletions(-)
 delete mode 100755 abs/core/runit-scripts/runitscripts/services/mythbackend/log/run

diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 6ef0e51..9fa7cdb 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=runit-scripts
 pkgver=2.1.1
-pkgrel=44
+pkgrel=48
 pkgdesc="collection of startup scripts for runit"
 url="http://smarden.org/runit/"
 license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/services/mythbackend/log/run b/abs/core/runit-scripts/runitscripts/services/mythbackend/log/run
deleted file mode 100755
index 17692a7..0000000
--- a/abs/core/runit-scripts/runitscripts/services/mythbackend/log/run
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-exec 2>&1
-#export TERM=linux
-#. /etc/rc.conf
-#. /etc/rc.d/functions
-#stat_runit "Starting MythBackend logger"
-/usr/bin/logger -p local7.info -t mythbackend  
-
diff --git a/abs/core/runit-scripts/runitscripts/services/mythbackend/run b/abs/core/runit-scripts/runitscripts/services/mythbackend/run
index 4bf54fb..e3ef721 100755
--- a/abs/core/runit-scripts/runitscripts/services/mythbackend/run
+++ b/abs/core/runit-scripts/runitscripts/services/mythbackend/run
@@ -1,21 +1,33 @@
 #!/bin/sh
 exec 2>&1
-. /etc/profile
+#. /etc/profile
 . /etc/systemconfig
 export TERM=linux
 . /etc/rc.conf
 . /etc/rc.d/functions
 
+
+
+stat_runit "Scanning for new storage"
+MYTHCONFDIR=/usr/share/mythtv /usr/LH/bin/add_storage.py --report > /dev/null
+if [ -e /tmp/scan_report ]
+then
+        echo "#####################################################"
+        echo "                New storage found                    "
+        echo ""
+        cat /tmp/scan_report
+        echo ""
+        echo "  run /usr/LH/bin/add_storage.py to make it available "
+        echo "#######################################################"
+
+fi
+
 stat_runit "Starting MythBackend"
 export HOME=/root
 if [ ! x$SystemType = xSlave_backend ]
 then
 	sv start mysql > /dev/null 2>/dev/null
-        #run mythfilldatabase
-	    #printhl "    Running mythfilldatabase"
-        #/usr/MythVantage/bin/initial_db_run &
 fi
-mkfifo /tmp/mbefifo >/dev/null 2>/dev/null
 #echo "Starting mythbackend"
 # 	if [ -f /tmp/debug ]
 # 		then
-- 
cgit v0.12