From 15d157d906b5250025565d8f590de6e6ba8aa2a7 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 17 Jan 2016 00:09:09 +0000
Subject: libfbclient: initial inclusion. dep of qt5

---
 abs/extra/libfbclient/ChangeLog | 26 +++++++++++++++++++++++
 abs/extra/libfbclient/LICENSE   | 44 ++++++++++++++++++++++++++++++++++++++
 abs/extra/libfbclient/PKGBUILD  | 47 +++++++++++++++++++++++++++++++++++++++++
 3 files changed, 117 insertions(+)
 create mode 100644 abs/extra/libfbclient/ChangeLog
 create mode 100644 abs/extra/libfbclient/LICENSE
 create mode 100644 abs/extra/libfbclient/PKGBUILD

diff --git a/abs/extra/libfbclient/ChangeLog b/abs/extra/libfbclient/ChangeLog
new file mode 100644
index 0000000..f02bd5f
--- /dev/null
+++ b/abs/extra/libfbclient/ChangeLog
@@ -0,0 +1,26 @@
+
+2009-06-08  Douglas Soares de Andrade  <douglas@archlinux.org>
+
+	* Rebuilt for the new icu
+
+2009-04-09  Douglas Soares de Andrade  <douglas@archlinux.org>
+
+	* Updated for i686: 2.1.2
+
+2008-08-10  Douglas Soares de Andrade  <douglas@archlinux.org>
+
+	* Updated for i686: 2.1.1
+
+2008-05-10  Mateusz Herych <heniekk@gmail.com>
+
+	* Updated for x86_64 - 2.1.0
+
+2008-04-28  Douglas Soares de Andrade  <dsa@aur.archlinux.org>
+
+	* Updated for i686 - 2.1.0
+	* Sure, firebird is the hell to build. Waiting contributions ;-)
+
+2007-07-06  tardo  <tardo@nagi-fanboi.net>
+	
+	* Built for x86_64
+	* This is the most fucked up pkg evar.
diff --git a/abs/extra/libfbclient/LICENSE b/abs/extra/libfbclient/LICENSE
new file mode 100644
index 0000000..e735b0c
--- /dev/null
+++ b/abs/extra/libfbclient/LICENSE
@@ -0,0 +1,44 @@
+
+LICENSES
+--------
+
+The applicable and approved licenses for the source files
+of the Firebird RDBMS project are:
+
+  1) InterBase Public License (IPL), version 1.0
+     http://bdn.borland.com/article/0,1410,30198,00.html
+
+  2) Initial Developer's Public License (IDPL), version 1.0
+     http://www.ibphoenix.com/main.nfs?a=ibphoenix&page=ibp_idpl
+
+The IPL is copyright of Borland Corp., the other licenses are copyright
+by the source code authors and contributors.
+
+
+USAGE RULES
+-----------
+
+1) The source code which was released under the IPL must keep this license.
+   All modifications / adaptations of this code are still subjects of the IPL.
+
+2) The files that are derived from the IPL covered code, must also keep
+   this license. It means that if any new file contains some code covered by
+   the IPL, then this file should be released under the IPL too.
+
+3) The new files developed by the members of the Firebird project should
+   be released under the IDPL.
+
+4) The new files contributed by people who are not members of the Firebird
+   project should follow the rule #3. If an author (initial developer) doesn't
+   specify the license to be used, the person who applies the contributed code
+   to the CVS tree (a committer) becomes responsible for the license assigned
+   to the contributed code.
+
+5) Every non-binary file that exists in the CVS tree, should have a header
+   section which describes the license this code is released under. If a file
+   contains no header, it means that this code is freeware and nobody owns the
+   appropriate copyrights.
+
+
+You may find the exhibits for the approved licenses in /doc/license directory
+of the CVS tree.
diff --git a/abs/extra/libfbclient/PKGBUILD b/abs/extra/libfbclient/PKGBUILD
new file mode 100644
index 0000000..56c80b2
--- /dev/null
+++ b/abs/extra/libfbclient/PKGBUILD
@@ -0,0 +1,47 @@
+# $Id$
+# Maintainer: Carlier Laurent <lordheavym@gmail.com>
+# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
+
+pkgname=libfbclient
+pkgver=2.5.4.26856
+pkgrel=3
+pkgdesc="Client library for Firebird."
+arch=('i686' 'x86_64')
+url="http://www.firebirdsql.org/"
+license=('custom')
+depends=('gcc-libs' 'icu')
+options=('!makeflags')
+source=(http://downloads.sourceforge.net/firebird/Firebird-$pkgver-0.tar.bz2
+        LICENSE)
+md5sums=('7a17ec9889424b98baa29e001a054434'
+         '0d61798861e159c85dbdf0f30fe2f2ce')
+
+build() {
+  cd $srcdir/Firebird-$pkgver-0
+
+  ./configure --prefix=/usr --with-system-icu --without-fbudf \
+    --without-fbsbin --without-fbconf --without-fbdoc --without-fbsample \
+    --without-fbsample-db --without-fbintl --without-fbmisc --without-fbhelp \
+    --without-fbsecure-db --with-fbmsg=/usr/share/firebird --without-fblog \
+    --without-fbglock --without-fbplugins
+
+  make
+}
+
+package() {
+  cd $srcdir/Firebird-$pkgver-0
+
+  mkdir -p $pkgdir/usr/{bin,share/{firebird,licenses/$pkgname}}
+
+  cp -R gen/firebird/{lib,include} $pkgdir/usr
+  rm -f $pkgdir/usr/lib/libedit.a
+
+  install -m644 gen/firebird/*.msg $pkgdir/usr/share/firebird
+  install -m755 gen/firebird/bin/fb_config $pkgdir/usr/bin
+  install -m644 ${srcdir}/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+  # Add libgds support FS#30062 FS#30282
+  cd $pkgdir/usr/lib
+  ln -s libfbclient.so libgds.so.0
+  ln -s libfbclient.so libgds.so
+}
-- 
cgit v0.12