From 1503b7e35c4b1b511010c8ebcba1110a37e28528 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 22 Nov 2013 15:12:26 -0600
Subject: linhes-theme: add progdetails files with LH colors. ref #940

Add install-ui.xml to theme mythinstall. Patch schedule-ui.xml Schedule Filter Editor to match wider popup.
---
 abs/core/linhes-theme/PKGBUILD               |  25 ++++--
 abs/core/linhes-theme/install-ui.xml         |  76 +++++++++++++++++
 abs/core/linhes-theme/progdetails_page1.html |  30 +++++++
 abs/core/linhes-theme/progdetails_page2.html |  49 +++++++++++
 abs/core/linhes-theme/schedule-ui.xml.patch  | 121 +++++++++++++++++++++++++++
 5 files changed, 293 insertions(+), 8 deletions(-)
 create mode 100755 abs/core/linhes-theme/install-ui.xml
 create mode 100644 abs/core/linhes-theme/progdetails_page1.html
 create mode 100644 abs/core/linhes-theme/progdetails_page2.html
 create mode 100644 abs/core/linhes-theme/schedule-ui.xml.patch

diff --git a/abs/core/linhes-theme/PKGBUILD b/abs/core/linhes-theme/PKGBUILD
index 7f58de5..f261ac0 100644
--- a/abs/core/linhes-theme/PKGBUILD
+++ b/abs/core/linhes-theme/PKGBUILD
@@ -1,18 +1,19 @@
 pkgname=linhes-theme
 pkgver=8.1
-pkgrel=2
+pkgrel=3
 pkgdesc="Default LinHES MythTV theme"
 arch=('i686' 'x86_64')
 license=('GPL2')
 url="http://linhes.org/"
 
 patches=('readme.txt.patch' 'osd.xml.patch' 'base.xml.patch'
-         'menu-ui.xml.patch')
+         'menu-ui.xml.patch' 'schedule-ui.xml.patch')
 
 #The LinHES theme is based on TintedGlass by Harley Peters
 source=("git://github.com/MythTV-Themes/TintedGlass.git"
-        `echo ${patches[@]:0}` 'themeinfo.xml'
-        'background.png' 'qt-background.png' 'tux_thoughts.png')
+        `echo ${patches[@]:0}` 'themeinfo.xml' 'install-ui.xml'
+        'background.png' 'qt-background.png' 'tux_thoughts.png'
+        'progdetails_page1.html' 'progdetails_page2.html')
 
 package() {
     THEMEROOT=usr/share/mythtv/themes
@@ -32,13 +33,18 @@ package() {
     cd $startdir
     msg "--------------------------done applying patches-------------------------"
 
-    msg "Copy themeinfo.xml and adding backgrounds and images for LinHES"
-    rsync -pL $srcdir/themeinfo.xml $pkgdir/$THEMEROOT/LinHES/
+    msg "Copy *.xml and adding backgrounds and images for LinHES"
+    rsync -pL $srcdir/*.xml $pkgdir/$THEMEROOT/LinHES/
     rm -r $pkgdir/$THEMEROOT/LinHES/images/backgrounds/*
     rsync -pL $srcdir/*background.png $pkgdir/$THEMEROOT/LinHES/images/backgrounds/
+
     #tux_thoughts.png is the thought bubble for the menu descriptions
     rsync -pL $srcdir/tux_thoughts.png $pkgdir/$THEMEROOT/LinHES/images/
 
+    #copy in progdetails
+    mkdir -p $pkgdir/$THEMEROOT/LinHES/htmls
+    rsync -pL $srcdir/progdetails_page*.html $pkgdir/$THEMEROOT/LinHES/htmls/
+
     msg "Modifying yellows and blue to LinHES yellow and blue"
     #yellow
     grep -lr '#d9d900' $pkgdir/$THEMEROOT/LinHES/ | xargs sed -i "s/\#d9d900/\#ebb81c/g"
@@ -47,13 +53,16 @@ package() {
     #blue
     grep -lr '#3a9ade' $pkgdir/$THEMEROOT/LinHES/ | xargs sed -i "s/\#3a9ade/\#0072bc/g"
 }
-
 md5sums=('SKIP'
          '9c2fc68864cbedb6e449056972b457aa'
          '15b4462932b7be0e56b2e69e0214823a'
          '2fb0990e8fef2c70e9bd8cfb36689b2b'
          '83b03852c6f46bc791bfa6e8c894ca01'
+         '45d2f265218ab951eefe76adff38c54b'
          '7d7bc458a8f4af408700609f3e1f412e'
+         'eb94abdc196051db708e4a9eb938923a'
          'cbe5f663ebb5d51abe811f81dafec303'
          '12d26a786fde397348653128a6d7676a'
-         '2bd09b8049aaf5ba21db5baf3a0ce077')
+         '2bd09b8049aaf5ba21db5baf3a0ce077'
+         'cc2b5da9ad34704d773f3235bf686835'
+         'be7853c2c9598481368c10f0eb5ad43f')
diff --git a/abs/core/linhes-theme/install-ui.xml b/abs/core/linhes-theme/install-ui.xml
new file mode 100755
index 0000000..4d10d0f
--- /dev/null
+++ b/abs/core/linhes-theme/install-ui.xml
@@ -0,0 +1,76 @@
+<mythuitheme>
+
+    <window name="welcome_screen">
+        <textarea name="title" from="base_heading">
+            <value>Welcome to LinHES!</value>
+        </textarea>
+
+        <!--not used by mythinstall-->
+        <textarea name="time_text" from="basetextarea"/>
+
+        <!--version info-->
+        <textarea name="date_text" from="basetextarea">
+            <multiline>yes</multiline>
+            <font>basemedium</font>
+            <area>20,22,1240,100</area>
+            <value></value>
+            <align>allcenter</align>
+        </textarea>
+
+        <!--not used by mythinstall-->
+        <textarea name="status_text" from="basetextarea">
+            <multiline>yes</multiline>
+            <font>basemediumyellow</font>
+            <area>20,140,1240,60</area>
+            <value></value>
+        </textarea>
+
+        <!--not used by mythinstall-->
+        <textarea name="recording_label" from="basetextarea">
+            <font>baselarge</font>
+            <area>20,140,1240,30</area>
+            <value></value>
+        </textarea>
+
+        <textarea name="recording_text" from="basetextarea">
+            <multiline>yes</multiline>
+            <font>basemediumyellow</font>
+            <area>20,140,1240,60</area>
+            <value>Press MENU for options</value>
+            <align>allcenter</align>
+        </textarea>
+
+        <!--not used by mythinstall-->
+        <textarea name="scheduled_label" from="basetextarea">
+            <font>baselarge</font>
+            <area>20,320,1240,30</area>
+            <value></value>
+        </textarea>
+
+        <textarea name="scheduled_text">
+            <font>basemediumyellow</font>
+            <area>20,210,1240,120</area>
+            <value></value>
+            <align>allcenter</align>
+        </textarea>
+
+        <textarea name="mythvantage_text">
+            <multiline>no</multiline>
+            <font>basesmallyellow</font>
+            <area>20,660,1240,30</area>
+            <value></value>
+            <align>right</align>
+            <cutdown>yes</cutdown>
+        </textarea>
+
+        <imagetype name="logo">
+            <position>565,490</position>
+            <preserveaspect>true</preserveaspect>
+            <!--<crop>x,y,w,h</crop>-->
+            <filepattern low="0" high="30">/usr/MythVantage/logos/logo-%1.png</filepattern>
+            <delay>5000</delay>
+        </imagetype>
+
+    </window>
+
+</mythuitheme>
diff --git a/abs/core/linhes-theme/progdetails_page1.html b/abs/core/linhes-theme/progdetails_page1.html
new file mode 100644
index 0000000..57b5a52
--- /dev/null
+++ b/abs/core/linhes-theme/progdetails_page1.html
@@ -0,0 +1,30 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
+<html xmlns="http://www.w3.org/1999/xhtml">
+<head>
+    <meta http-equiv="content-type" content="text/html; charset=iso-8859-1" />
+    <style type="text/css">
+        body {background-color:#1a1a1a;}
+        h1 {font-family:DejaVu Sans;font-size:1.6em;font-style: normal;color:#ebb81c;margin-top: -5pt}
+        p  {font-family:DejaVu Sans;font-size:1.6em;font-style: normal;color:#ffffff;margin-top: -10pt}
+    </style>
+</head>
+
+<body>
+    <h1>%TITLE_LABEL% & %DESCRIPTION_LABEL%</h1> <p>%TITLE%:  %DESCRIPTION%</p>
+    <h1>%TITLE_PRONOUNCE_LABEL%</h1> <p>%TITLE_PRONOUNCE%</p>
+    <h1>%ORIGINAL_AIRDATE_LABEL%</h1> <p>%ORIGINAL_AIRDATE%</p>
+    <h1>%EPISODE_LABEL%</h1> <p>%EPISODE%</p>
+    <h1>%ADAPTER_LABEL%</h1> <p>%ADAPTER%</p>
+    <h1>%GUEST_LABEL%</h1> <p>%GUEST%</p>
+    <h1>%CATEGORY_LABEL%</h1> <p>%CATEGORY%</p>
+    <h1>%PROGRAMID_LABEL%</h1> <p>%PROGRAMID%</p>
+    <h1>%RECORDING_RULE_LABEL%</h1> <p>%RECORDING_RULE%</p>
+    <h1>%SEARCH_PHRASE_LABEL%</h1> <p>%SEARCH_PHRASE%</p>
+    <h1>%RECORDED_FILE_NAME_LABEL%</h1> <p>%RECORDED_FILE_NAME%</p>
+    <h1>%RECORDED_FILE_SIZE_LABEL%</h1> <p>%RECORDED_FILE_SIZE%</p>
+    <h1>%RECORDING_PROFILE_LABEL%</h1> <p>%RECORDING_PROFILE%</p>
+    <h1>%RECORDING_GROUP_LABEL%</h1> <p>%RECORDING_GROUP%</p>
+    <h1>%PLAYBACK_GROUP_LABEL%</h1> <p>%PLAYBACK_GROUP%</p>
+</body>
+
+</html>
diff --git a/abs/core/linhes-theme/progdetails_page2.html b/abs/core/linhes-theme/progdetails_page2.html
new file mode 100644
index 0000000..c499557
--- /dev/null
+++ b/abs/core/linhes-theme/progdetails_page2.html
@@ -0,0 +1,49 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
+<html xmlns="http://www.w3.org/1999/xhtml">
+<head>
+    <meta http-equiv="content-type" content="text/html; charset=iso-8859-1" />
+    <style type="text/css">
+        body {background-color:#1a1a1a;}
+        h1 {font-family:DejaVu Sans;font-size:1.6em;font-style: normal;color:#ebb81c;margin-top: -5pt}
+        p  {font-family:DejaVu Sans;font-size:1.6em;font-style: normal;color:#ffffff;margin-top: -10pt}
+    </style>
+</head>
+
+body>
+    <h1>%TITLE_LABEL% & %DESCRIPTION_LABEL%</h1> <p>%TITLE%:  %DESCRIPTION%</p>
+    <h1>%TITLE_PRONOUNCE_LABEL%</h1> <p>%TITLE_PRONOUNCE%</p>
+    <h1>%ORIGINAL_AIRDATE_LABEL%</h1> <p>%ORIGINAL_AIRDATE%</p>
+    <h1>%EPISODE_LABEL%</h1> <p>%EPISODE%</p>
+    <h1>%ACTORS_LABEL%</h1> <p>%ACTORS%</p>
+    <h1>%GUEST_STAR_LABEL%</h1> <p>%GUEST_STAR%</p>
+    <h1>%DIRECTOR_LABEL%</h1> <p>%DIRECTOR%</p>
+    <h1>%PRODUCER_LABEL%</h1> <p>%PRODUCER%</p>
+    <h1>%EXECUTIVE_PRODUCER_LABEL%</h1> <p>%EXECUTIVE_PRODUCER%</p>
+    <h1>%WRITER_LABEL%</h1> <p>%WRITER%</p>
+    <h1>%HOST_LABEL%</h1> <p>%HOST%</p>
+    <h1>%ADAPTER_LABEL%</h1> <p>%ADAPTER%</p>
+    <h1>%PRESENTER_LABEL%</h1> <p>%PRESENTER%</p>
+    <h1>%COMMENTATOR_LABEL%</h1> <p>%COMMENTATOR%</p>
+    <h1>%GUEST_LABEL%</h1> <p>%GUEST%</p>
+    <h1>%CATEGORY_LABEL%</h1> <p>%CATEGORY%</p>
+    <h1>%CATEGORY_TYPE_LABEL%</h1> <p>%CATEGORY_TYPE%</p>
+    <h1>%PROGRAMID_LABEL%</h1> <p>%PROGRAMID%</p>
+    <h1>%MYTHTV_STATUS_LABEL%</h1> <p>%MYTHTV_STATUS%</p>
+    <h1>%RECORDING_RULE_LABEL%</h1> <p>%RECORDING_RULE%</p>
+    <h1>%LAST_RECORDED_LABEL%</h1> <p>%LAST_RECORDED%</p>
+    <h1>%NEXT_RECORDING_LABEL%</h1> <p>%NEXT_RECORDING%</p>
+    <h1>%AVERAGE_TIME_SHIFT_LABEL%</h1> <p>%AVERAGE_TIME_SHIFT%</p>
+    <h1>%WATCH_LIST_SCORE_LABEL%</h1> <p>%WATCH_LIST_SCORE%</p>
+    <h1>%WATCH_LIST_STATUS_LABEL%</h1> <p>%WATCH_LIST_STATUS%</p>
+    <h1>%SEARCH_PHRASE_LABEL%</h1> <p>%SEARCH_PHRASE%</p>
+    <h1>%FINDID_LABEL%</h1> <p>%FINDID%</p>
+    <h1>%RECORDING_HOST_LABEL%</h1> <p>%RECORDING_HOST%</p>
+    <h1>%RECORDED_FILE_NAME_LABEL%</h1> <p>%RECORDED_FILE_NAME%</p>
+    <h1>%RECORDED_FILE_SIZE_LABEL%</h1> <p>%RECORDED_FILE_SIZE%</p>
+    <h1>%RECORDING_PROFILE_LABEL%</h1> <p>%RECORDING_PROFILE%</p>
+    <h1>%RECORDING_GROUP_LABEL%</h1> <p>%RECORDING_GROUP%</p>
+    <h1>%STORAGE_GROUP_LABEL%</h1> <p>%STORAGE_GROUP%</p>
+    <h1>%PLAYBACK_GROUP_LABEL%</h1> <p>%PLAYBACK_GROUP%</p>
+</body>
+
+</html>
diff --git a/abs/core/linhes-theme/schedule-ui.xml.patch b/abs/core/linhes-theme/schedule-ui.xml.patch
new file mode 100644
index 0000000..88e643b
--- /dev/null
+++ b/abs/core/linhes-theme/schedule-ui.xml.patch
@@ -0,0 +1,121 @@
+--- schedule-ui.xml.orig	2013-11-22 19:35:05.125862862 +0000
++++ schedule-ui.xml	2013-11-22 19:34:04.307006412 +0000
+@@ -3225,7 +3225,7 @@
+     </window>
+ 
+     <window name="schedulefiltereditor">
+-        <area>-1,-1,500,500</area>
++        <area>-1,-1,602,488</area>
+ 
+         <animation trigger="AboutToShow">
+             <section>
+@@ -3242,85 +3242,85 @@
+         </animation>
+ 
+         <shape name="schedule-filter-editor-backdrop" from="base_popup_backdrop">
+-            <area>0,0,500,500</area>
++            <area>0,0,602,488</area>
+         </shape>
+ 
+         <shape name="schedule-filter-editor-backdrop-line" from="base_backdrop_line">
+-            <area>1,1,498,498</area>
++            <area>1,1,600,486</area>
+         </shape>
+ 
+         <shape name="schedule-filter-editor-top-line" from="base_highlight_line">
+-            <area>2,2,496,2</area>
++            <area>2,2,596,2</area>
+         </shape>
+ 
+         <shape name="schedule-filter-editor-bottom-line" from="base_highlight_line">
+-            <area>2,496,496,2</area>
++            <area>2,484,596,2</area>
+         </shape>
+ 
+         <shape name="schedule-filter-editor-left-line" from="base_highlight_vertical_line">
+-            <area>2,4,2,492</area>
++            <area>2,4,2,480</area>
+         </shape>
+ 
+         <shape name="schedule-filter-editor-right-line" from="base_highlight_vertical_line">
+-            <area>496,4,2,492</area>
++            <area>598,4,2,480</area>
+         </shape>
+ 
+         <shape name="schedule-filter-editor-seperator-first-line" from="base_line">
+-            <area>23,50,454,2</area>
++            <area>23,50,552,2</area>
+         </shape>
+ 
+         <shape name="schedule-filter-editor-seperator-second-line" from="base_line">
+-            <area>23,435,454,2</area>
++            <area>23,435,552,2</area>
+         </shape>
+ 
+         <textarea name="title_text" from="basetextarea">
+-            <area>10,4,480,46</area>
+-            <font>basemediumlargerdarkyellow</font>
++            <area>10,4,582,46</area>
++            <font>basemediumlarger</font>
+             <align>allcenter</align>
+             <value>Schedule Filter Editor</value>
+         </textarea>
+ 
+         <buttonlist name="filters" from="base_button_list">
+-            <area>20,75,460,360</area>
++            <area>15,60,570,360</area>
+             <statetype name="buttonitem">
+                 <state name="active">
+-                    <area>0,0,460,40</area>
++                    <area>0,0,100%,34</area>
+                     <textarea name="buttontext">
+-                        <area>40,0,380,40</area>                     
++                        <area>40,0,490,34</area>                     
+                     </textarea>
+                     <statetype name="buttoncheck">
+-                        <position>15,10</position>
++                        <position>15,7</position>
+                     </statetype>
+                 </state>
+                 <state name="selectedactive">
+-                    <area>0,0,460,40</area>
++                    <area>0,0,100%,34</area>
+                     <textarea name="buttontext">
+-                        <area>40,0,380,40</area>
++                        <area>40,0,490,34</area>
+                     </textarea>
+                     <statetype name="buttoncheck">
+-                        <position>15,10</position>
++                        <position>15,7</position>
+                     </statetype>
+                 </state>
+                 <state name="selectedinactive">
+-                    <area>0,0,460,40</area>
++                    <area>0,0,100%,34</area>
+                     <textarea name="buttontext">
+-                        <area>40,0,380,40</area>
++                        <area>40,0,490,34</area>
+                     </textarea>
+                     <statetype name="buttoncheck">
+-                        <position>15,10</position>
++                        <position>15,7</position>
+                     </statetype>
+                 </state>
+             </statetype>
+             <statetype name="upscrollarrow">
+-                <position>0,343</position>
++                <position>0,359</position>
+             </statetype>
+             <statetype name="downscrollarrow">
+-                <position>20,343</position>
++                <position>20,359</position>
+             </statetype>
+         </buttonlist>
+ 
+-        <button name="back" from="base_medium_button">
+-            <position>75,447</position>
++        <button name="back" from="base_wide_button">
++            <position>60,440</position>
+             <value>Back</value>
+         </button>
+ 
-- 
cgit v0.12