From 492f9c705027a36f69c06f5ee2849753aaa70a44 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 16 Feb 2014 18:02:24 -0600
Subject: v86d: update binary path to /usr/bin refs #961

---
 abs/core/v86d/PKGBUILD     | 31 ++++++++++++++++++-------------
 abs/core/v86d/v86d         | 14 --------------
 abs/core/v86d/v86d_install | 14 ++++++++++++++
 3 files changed, 32 insertions(+), 27 deletions(-)
 delete mode 100644 abs/core/v86d/v86d
 create mode 100644 abs/core/v86d/v86d_install

diff --git a/abs/core/v86d/PKGBUILD b/abs/core/v86d/PKGBUILD
index 13cc2eb..3ff4385 100644
--- a/abs/core/v86d/PKGBUILD
+++ b/abs/core/v86d/PKGBUILD
@@ -1,36 +1,41 @@
-# $Id: PKGBUILD 159626 2012-05-25 23:57:39Z dreisner $
-# Maintainer: Thomas Baechler <thomas@archlinux.org>
+# $Id: PKGBUILD 187075 2013-06-03 11:17:01Z allan $
+# Maintainer:
 
 pkgname=v86d
 pkgver=0.1.10
-pkgrel=4
+pkgrel=5
 pkgdesc="userspace helper for uvesafb that runs x86 code in an emulated environment"
 arch=('i686' 'x86_64')
-url="http://dev.gentoo.org/~spock/projects/uvesafb/"
+url="https://github.com/mjanusz/v86d"
 license=('GPL2')
 depends=('glibc')
+makedepends=('git')
 options=('!makeflags')
-source=(http://dev.gentoo.org/~spock/projects/uvesafb/archive/v86d-$pkgver.tar.bz2
-        v86d
+source=("git://github.com/mjanusz/v86d.git#tag=$pkgname-$pkgver"
+        v86d_install
         v86d_hook
         modprobe.uvesafb)
-md5sums=('51c792ba7b874ad8c43f0d3da4cfabe0'
-         '66ab32602ab29cc5635eaac7f3e42283'
-         '5f75b8bc4a7ddf595014591e5db263cb'
-         '2d7cc8dc6a41916a13869212d0191147')
 
 build() {
-  cd "$srcdir/v86d-$pkgver"
+  cd "$pkgname"
   ./configure --with-x86emu
   # we only need /usr/include/video/uvesafb.h
   make KDIR=/usr
 }
 
 package() {
-  cd "$srcdir/v86d-$pkgver"
+  cd "$pkgname"
   make DESTDIR="$pkgdir" install
 
-  install -D -m644 "$srcdir/v86d" "$pkgdir/usr/lib/initcpio/install/v86d"
+  install -D -m644 "$srcdir/v86d_install" "$pkgdir/usr/lib/initcpio/install/v86d"
   install -D -m644 "$srcdir/v86d_hook" "$pkgdir/usr/lib/initcpio/hooks/v86d"
   install -D -m644 "$srcdir/modprobe.uvesafb" "$pkgdir/usr/lib/modprobe.d/uvesafb.conf"
+
+  # usrmove
+  cd "$pkgdir"
+  mv sbin usr/bin
 }
+md5sums=('SKIP'
+         '66ab32602ab29cc5635eaac7f3e42283'
+         '5f75b8bc4a7ddf595014591e5db263cb'
+         '2d7cc8dc6a41916a13869212d0191147')
diff --git a/abs/core/v86d/v86d b/abs/core/v86d/v86d
deleted file mode 100644
index 840b34e..0000000
--- a/abs/core/v86d/v86d
+++ /dev/null
@@ -1,14 +0,0 @@
-build() {
-    add_module 'uvesafb'
-
-    add_binary "v86d"
-    add_file "/usr/lib/modprobe.d/uvesafb.conf"
-
-    add_runscript
-}
-
-help() {
-    echo "This hook sets up v86d, the userspace helper for uvesafb."
-}
-
-# vim: set ft=sh ts=4 sw=4 expandtab:
diff --git a/abs/core/v86d/v86d_install b/abs/core/v86d/v86d_install
new file mode 100644
index 0000000..840b34e
--- /dev/null
+++ b/abs/core/v86d/v86d_install
@@ -0,0 +1,14 @@
+build() {
+    add_module 'uvesafb'
+
+    add_binary "v86d"
+    add_file "/usr/lib/modprobe.d/uvesafb.conf"
+
+    add_runscript
+}
+
+help() {
+    echo "This hook sets up v86d, the userspace helper for uvesafb."
+}
+
+# vim: set ft=sh ts=4 sw=4 expandtab:
-- 
cgit v0.12