From a52a3c1ea63adcb1821c7c544f21518578157397 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 20 Jan 2016 21:40:32 +0000
Subject: gobject-introspection: update to 1.46.0

---
 abs/core/gobject-introspection/PKGBUILD | 33 +++++++++++++++++++++------------
 1 file changed, 21 insertions(+), 12 deletions(-)

diff --git a/abs/core/gobject-introspection/PKGBUILD b/abs/core/gobject-introspection/PKGBUILD
index 9757c17..9f5edfa 100644
--- a/abs/core/gobject-introspection/PKGBUILD
+++ b/abs/core/gobject-introspection/PKGBUILD
@@ -1,32 +1,41 @@
 # $Id$
 # Maintainer: Jan de Groot <jgc@archlinux.org>
 
-pkgname=gobject-introspection
-pkgver=1.42.0
+pkgbase=gobject-introspection
+pkgname=('gobject-introspection' 'gobject-introspection-runtime')
+pkgver=1.46.0
 pkgrel=1
-pkgdesc="Introspection system for GObject-based libraries"
 url="https://live.gnome.org/GObjectIntrospection"
 arch=('x86_64' 'i686')
 license=('LGPL' 'GPL')
-depends=('glib2')
 makedepends=('cairo' 'python2' 'python2-mako')
-optdepends=('python2: gir development tools'
-            'python2-mako: g-ir-doc-tool')
-source=(http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz)
-sha256sums=('3ba2edfad4f71d4f0de16960b5d5f2511335fa646b2c49bbb93ce5942b3f95f7')
+source=(https://download.gnome.org/sources/$pkgbase/${pkgver:0:4}/$pkgbase-$pkgver.tar.xz)
+sha256sums=('6658bd3c2b8813eb3e2511ee153238d09ace9d309e4574af27443d87423e4233')
 
 prepare() {
-  cd $pkgname-$pkgver
+  cd $pkgbase-$pkgver
   sed -i '1s|#!/usr/bin/env python$|&2|' giscanner/*.py
 }
 
 build() {
-  cd $pkgname-$pkgver
+  cd $pkgbase-$pkgver
   PYTHON=/usr/bin/python2 ./configure --prefix=/usr --disable-static --enable-doctool
   make
 }
 
-package() {
-  cd $pkgname-$pkgver
+package_gobject-introspection-runtime() {
+  pkgdesc="Introspection system for GObject-based libraries - runtime files"
+  depends=('glib2')
+  cd $pkgbase-$pkgver
+  make DESTDIR="$pkgdir" install-libLTLIBRARIES install-typelibsDATA
+}
+
+package_gobject-introspection() {
+  pkgdesc="Introspection system for GObject-based libraries"
+  depends=("gobject-introspection-runtime=$pkgver" 'python2-mako' 'python2')
+  options=('!emptydirs')
+
+  cd $pkgbase-$pkgver
   make DESTDIR="$pkgdir" install
+  make DESTDIR="$pkgdir" uninstall-libLTLIBRARIES uninstall-typelibsDATA
 }
-- 
cgit v0.12