From 2fc15d3074871bd939534a6b681779e4cb42aaec Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Thu, 22 Jan 2009 16:55:28 -0800
Subject: Initial inclusion of apcupsd.

---
 abs/extra-testing/apcupsd/PKGBUILD | 31 +++++++++++++++++++++++++++
 abs/extra-testing/apcupsd/apcupsd  | 44 ++++++++++++++++++++++++++++++++++++++
 2 files changed, 75 insertions(+)
 create mode 100644 abs/extra-testing/apcupsd/PKGBUILD
 create mode 100755 abs/extra-testing/apcupsd/apcupsd

diff --git a/abs/extra-testing/apcupsd/PKGBUILD b/abs/extra-testing/apcupsd/PKGBUILD
new file mode 100644
index 0000000..7f20cab
--- /dev/null
+++ b/abs/extra-testing/apcupsd/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD,v 1.17 2009/01/19 10:34:32 sergej Exp $
+# Maintainer: Sergej Pupykin <sergej@aur.archlinux.org>
+# Maintainer: Todd Musall <tmusall@comcast.net>
+
+pkgname=apcupsd
+pkgver=3.14.5
+pkgrel=1
+pkgdesc="Apcupsd can be used for power mangement and controlling most of APC's UPS models on Unix and Windows machines."
+arch=(i686 x86_64)
+url="http://www.apcupsd.org"
+license=('GPL')
+depends=('gcc-libs' 'gd' 'gconf')
+makedepends=('pkgconfig')
+backup=(etc/apcupsd/apcupsd.conf etc/apcupsd/hosts.conf \
+        etc/apcupsd/multimon.conf)
+source=(http://switch.dl.sf.net/sourceforge/apcupsd/$pkgname-$pkgver.tar.gz \
+	apcupsd)
+md5sums=('4ac73ec91d8ab56f3fac894e172567c4'
+         '5eae3c4d921eeb81798a0250fe3dd111')
+
+build() {
+  cd $startdir/src/$pkgname-$pkgver
+  ./configure --prefix=/usr --enable-cgi --enable-usb --enable-net \
+              --with-upstype=usb --with-upscable=usb \
+              --with-serial-dev=/dev/usb/hid/hiddev[0-9] \
+              --enable-pthreads --enable-gapcmon
+  make || return 1
+  make DESTDIR=$startdir/pkg install || return 1
+  install -D -m755 ../apcupsd $startdir/pkg/etc/rc.d/apcupsd && \
+  chmod 755 $startdir/pkg/sbin/*
+}
diff --git a/abs/extra-testing/apcupsd/apcupsd b/abs/extra-testing/apcupsd/apcupsd
new file mode 100755
index 0000000..3cd5c9d
--- /dev/null
+++ b/abs/extra-testing/apcupsd/apcupsd
@@ -0,0 +1,44 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /sbin/apcupsd`
+case "$1" in
+  start)
+    stat_busy "Starting APCUPSD Daemon"
+    rm -f /etc/apcupsd/powerfail
+    rm -f /etc/nologin
+    [ -z "$PID" ] && /sbin/apcupsd -f /etc/apcupsd/apcupsd.conf
+    if [ $? -gt 0 ]; then
+      stat_fail
+    else
+      PID=`pidof -o %PPID /sbin/apcupsd`
+      echo $PID > /var/run/apcupsd.pid
+      add_daemon apcupsd
+      stat_done
+    fi
+    ;;
+  stop)
+    stat_busy "Stopping APCUPSD Daemon"
+    [ ! -z "$PID" ]  && kill $PID &> /dev/null
+    if [ $? -gt 0 ]; then
+      stat_fail
+    else
+      rm /var/run/apcupsd.pid
+      rm_daemon apcupsd
+      stat_done
+    fi
+    ;;
+  restart)
+    $0 stop
+    sleep 2
+    $0 start
+    ;;
+  status)
+    /sbin/apcaccess status
+    ;;
+  *)
+    echo "usage: $0 {start|stop|restart|status}"  
+esac
+exit 0
-- 
cgit v0.12