From 4c71823825d08c1cc2219d22a6d3fe190e158a09 Mon Sep 17 00:00:00 2001
From: Bob Igo <bob@stormlogic.com>
Date: Mon, 13 Jul 2009 17:50:14 -0400
Subject: fixed twk_audio.pl bug

---
 abs/core-testing/tweaker/PKGBUILD         |  2 +-
 abs/core-testing/tweaker/bin/twk_audio.pl | 10 +++++++++-
 2 files changed, 10 insertions(+), 2 deletions(-)

diff --git a/abs/core-testing/tweaker/PKGBUILD b/abs/core-testing/tweaker/PKGBUILD
index 377edda..b3b4983 100644
--- a/abs/core-testing/tweaker/PKGBUILD
+++ b/abs/core-testing/tweaker/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=tweaker
 pkgver=1
-pkgrel=40
+pkgrel=41
 pkgdesc="applies tweaks to the baseline configuration and attempts to optimize settings for the hardware it finds"
 arch=('i686' 'x86_64')
 
diff --git a/abs/core-testing/tweaker/bin/twk_audio.pl b/abs/core-testing/tweaker/bin/twk_audio.pl
index 09676ed..47a2415 100755
--- a/abs/core-testing/tweaker/bin/twk_audio.pl
+++ b/abs/core-testing/tweaker/bin/twk_audio.pl
@@ -133,7 +133,7 @@ sub implement_option {
 		# Not supported yet.
 	    }
 	    case "digital" {
-		$command2 = "echo -e 'ac=hwac3,hwdts, #TWEAKER\nao=alsa:device=plughw=$card.$device #TWEAKER\naf=scaletempo=stride=30:overlap=.50:search=10 #TWEAKER\nspeed=1.0 #TWEAKER' >> $mplayer_conf";
+		$command2 = "echo -e 'ac=hwac3,hwdts, #TWEAKER\nao=alsa:device=plughw=$card.$device #TWEAKER' >> $mplayer_conf";
 		if (my $error = execute_shell_command($command2)) {
 		    $logger->error("ERROR: $error");
 		    $logger->error("ERROR: Unable to implement option $option.");
@@ -160,6 +160,14 @@ sub implement_option {
 		}
 	    }
 	}
+	# for all options
+	$command2 = "echo -e 'af=scaletempo=stride=30:overlap=.50:search=10 #TWEAKER\nspeed=1.0 #TWEAKER' >> $mplayer_conf";
+	if (my $error = execute_shell_command($command2)) {
+	    $logger->error("ERROR: $error");
+	    $logger->error("ERROR: Unable to implement option $option.");
+	    exit(-1);
+	}
+	
 	$logger->info("Edited $mplayer_conf for $option audio.");
     }
 
-- 
cgit v0.12