From eb21cdae644a7758d77f5a9bfe6b42ef4291266e Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 21 Mar 2010 14:47:43 -0500
Subject: linhes-scripts:  add .php to mythvideo blacklist This is done via
 remove_php_mythvideo.sh.

This is run whenever linhes-scripts is installed.
This should probably be removed after a few releases.
closes 522
---
 abs/core-testing/linhes-scripts/PKGBUILD           | 56 +++++++++++++++++++++-
 .../linhes-scripts/linhes-scripts.install          |  7 +++
 .../linhes-scripts/remove_php_mythvideo.sh         |  6 +++
 3 files changed, 68 insertions(+), 1 deletion(-)
 create mode 100644 abs/core-testing/linhes-scripts/linhes-scripts.install
 create mode 100644 abs/core-testing/linhes-scripts/remove_php_mythvideo.sh

diff --git a/abs/core-testing/linhes-scripts/PKGBUILD b/abs/core-testing/linhes-scripts/PKGBUILD
index af152c1..f721fee 100644
--- a/abs/core-testing/linhes-scripts/PKGBUILD
+++ b/abs/core-testing/linhes-scripts/PKGBUILD
@@ -3,12 +3,13 @@
 
 pkgname=linhes-scripts
 pkgver=1
-pkgrel=51
+pkgrel=55
 pkgdesc="Various scripts that help to make LinHES, LinHES."
 arch=('i686' 'x86_64')
 license=('GPL2')
 depends=('xosd' 'cpulimit')
 url="http://linhes.org/"
+install="linhes-scripts.install"
 source=(
 myth2xvid
 shootscreens.sh
@@ -35,6 +36,7 @@ linhes_update3.sh
 install_hulu.sh
 update_schema_021_to_022.sh
 upgrade_to_0.22.sh
+remove_php_mythvideo.sh
 )
 
 build() {
@@ -48,3 +50,55 @@ build() {
   mkdir -p $startdir/pkg/etc/logrotate.d/
   cp pause_mythcommflag $startdir/pkg/etc/logrotate.d/
 }
+md5sums=('f56985b2d602e11dc1e10d3e7848b2a5'
+         '623b6e9ba6cc4a19771005e750f337a7'
+         '9ae2cd7a0c42d57ad8b5f515d7d60196'
+         '1274bad3fb7296f00acd2d44804bad14'
+         'b4f858834ea92418208ab496ca39ad32'
+         '6b6e7d34a4bda6d608d150039adefd07'
+         '3fe554dbbf7d09e1f9925032ba888bf5'
+         '18263972b6326e140bbef0bb7dfa2da9'
+         '410795ef9039e4c6c0484e706ecfd567'
+         '0750d7c65109d12aa536f312a38410d1'
+         'ac2a4a6b4100f4d7bfb9ecd9356c8c6e'
+         'd2b475821f902c5e081e7da43a35e6ac'
+         '26a194301b0cfc4ca212d462a0899077'
+         '3b776bbff68906ddc2f62b7e0dde3fe4'
+         '85706c981e8ec2c5bb49a33538782d4c'
+         '3d0adf26280cde55a0c47188fff34826'
+         '93aaa2940e33ec9ebb305b839ac46a3e'
+         '972e42e02a11575da91f5e051d4de1d2'
+         'b527b01d119d3bc33b8fa69bdf1082bb'
+         'c537c44156d8404016cc4b405b092d45'
+         '4e66f302a77f1a857476e7f289d0c157'
+         'be324dba44ae96676973a74421944853'
+         'c9dc0dd07369622879a000247ac55074'
+         '3256a968ea4c06b2f6bfb68d7bb1a8f5'
+         'ea5492d4dab8271db20cb84416c001dc'
+         'fc9c3858a30891f159267123b007c0ea')
+md5sums=('f56985b2d602e11dc1e10d3e7848b2a5'
+         '623b6e9ba6cc4a19771005e750f337a7'
+         '9ae2cd7a0c42d57ad8b5f515d7d60196'
+         '1274bad3fb7296f00acd2d44804bad14'
+         'b4f858834ea92418208ab496ca39ad32'
+         '6b6e7d34a4bda6d608d150039adefd07'
+         '3fe554dbbf7d09e1f9925032ba888bf5'
+         '18263972b6326e140bbef0bb7dfa2da9'
+         '410795ef9039e4c6c0484e706ecfd567'
+         '0750d7c65109d12aa536f312a38410d1'
+         'ac2a4a6b4100f4d7bfb9ecd9356c8c6e'
+         'd2b475821f902c5e081e7da43a35e6ac'
+         '26a194301b0cfc4ca212d462a0899077'
+         '3b776bbff68906ddc2f62b7e0dde3fe4'
+         '85706c981e8ec2c5bb49a33538782d4c'
+         '3d0adf26280cde55a0c47188fff34826'
+         '93aaa2940e33ec9ebb305b839ac46a3e'
+         '972e42e02a11575da91f5e051d4de1d2'
+         'b527b01d119d3bc33b8fa69bdf1082bb'
+         'c537c44156d8404016cc4b405b092d45'
+         '4e66f302a77f1a857476e7f289d0c157'
+         'be324dba44ae96676973a74421944853'
+         'c9dc0dd07369622879a000247ac55074'
+         '3256a968ea4c06b2f6bfb68d7bb1a8f5'
+         'ea5492d4dab8271db20cb84416c001dc'
+         'd7c7914225ec86bf3ea46104a364f977')
diff --git a/abs/core-testing/linhes-scripts/linhes-scripts.install b/abs/core-testing/linhes-scripts/linhes-scripts.install
new file mode 100644
index 0000000..f554bd0
--- /dev/null
+++ b/abs/core-testing/linhes-scripts/linhes-scripts.install
@@ -0,0 +1,7 @@
+
+post_upgrade() {
+    . /etc/profile
+    /usr/LH/bin/remove_php_mythvideo.sh
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core-testing/linhes-scripts/remove_php_mythvideo.sh b/abs/core-testing/linhes-scripts/remove_php_mythvideo.sh
new file mode 100644
index 0000000..5320756
--- /dev/null
+++ b/abs/core-testing/linhes-scripts/remove_php_mythvideo.sh
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+mysql mythconverg <<EOF
+delete from videotypes where extension='php';
+insert into videotypes(extension,f_ignore) values('php','1');
+EOF
-- 
cgit v0.12