From 46e08095675d8e2185bf65fa116742cb5a4cda2e Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 7 Aug 2012 15:52:45 -0500
Subject: xdg-utils 1.1.0

---
 abs/extra/xdg-utils/PKGBUILD            | 41 +++++++++++++++++++--------
 abs/extra/xdg-utils/xfce-detection.diff | 49 +++++++++++++++++++++++++++++++++
 2 files changed, 78 insertions(+), 12 deletions(-)
 create mode 100644 abs/extra/xdg-utils/xfce-detection.diff

diff --git a/abs/extra/xdg-utils/PKGBUILD b/abs/extra/xdg-utils/PKGBUILD
index c707346..94e715e 100644
--- a/abs/extra/xdg-utils/PKGBUILD
+++ b/abs/extra/xdg-utils/PKGBUILD
@@ -1,19 +1,36 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 160047 2012-05-28 14:14:28Z andyrtr $
 # Maintainer: Jan de Groot <jgc@archlinux.org>
 
 pkgname=xdg-utils
-pkgver=1.0.2
-pkgrel=1
-pkgdesc="Command line tools that assist applications with a variety of desktop integration tasks."
-arch=(i686 x86_64)
+pkgver=1.1.0
+_gitdate=20120520
+pkgrel=2.${_gitdate}
+pkgdesc="Command line tools that assist applications with a variety of desktop integration tasks"
+arch=('any')
 url="http://portland.freedesktop.org/"
-license=(MIT)
-source=(http://portland.freedesktop.org/download/$pkgname-$pkgver.tgz)
-md5sums=('348a5b91dc66426505022c74a64b2940')
+license=('MIT')
+depends=('sh' 'xorg-xset') # xset needed inside xdg-screensaver
+makedepends=('docbook-xsl' 'lynx' 'xmlto')
+optdepends=('kdebase-runtime: for KDE support in xdg-open'
+            'libgnome: for GNOME support in xdg-open'
+            'exo: for Xfce support in xdg-open'
+            'xorg-xprop: for Xfce support in xdg-open'
+            'pcmanfm: for LXDE support in xdg-open'
+            'perl-file-mimeinfo: for generic support in xdg-open')
+source=(ftp://ftp.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.${_gitdate}.tar.gz  # last git commit 2012-03-10 13:55:24 (GMT) allow DESKTOP_SESSION='Xfce Session' to match xfce
+)
+md5sums=('4e37d65322dbc4763e85b8ba461f919b')
 
 build() {
-  cd $startdir/src/$pkgname-$pkgver
-  ./configure --prefix=/usr
-  make || return 1
-  make DESTDIR=$startdir/pkg install
+	cd ${srcdir}/${pkgname}-5be359a49d4d8dc3c5f814ab89b8422ad522d837
+	./configure --prefix=/usr --mandir=/usr/share/man
+	make scripts-clean -C scripts # needed if it's a git snapshot
+	make man scripts -C scripts # needed if it's a git snapshot
+#	make # for release builds
+}
+
+package() {
+	cd ${srcdir}/${pkgname}-5be359a49d4d8dc3c5f814ab89b8422ad522d837
+	make DESTDIR="${pkgdir}" install
+	install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
 }
diff --git a/abs/extra/xdg-utils/xfce-detection.diff b/abs/extra/xdg-utils/xfce-detection.diff
new file mode 100644
index 0000000..43ccd62
--- /dev/null
+++ b/abs/extra/xdg-utils/xfce-detection.diff
@@ -0,0 +1,49 @@
+--- scripts/xdg-open	2011-01-01 05:03:14.000000000 -0500
++++ scripts/xdg-open.new	2011-06-19 00:43:13.000000000 -0400
+@@ -303,12 +303,35 @@
+ 
+ detectDE()
+ {
++    # see https://bugs.freedesktop.org/show_bug.cgi?id=34164
++    unset GREP_OPTIONS
++
+     if [ x"$KDE_FULL_SESSION" = x"true" ]; then DE=kde;
+     elif [ x"$GNOME_DESKTOP_SESSION_ID" != x"" ]; then DE=gnome;
+     elif `dbus-send --print-reply --dest=org.freedesktop.DBus /org/freedesktop/DBus org.freedesktop.DBus.GetNameOwner string:org.gnome.SessionManager > /dev/null 2>&1` ; then DE=gnome;
+     elif xprop -root _DT_SAVE_MODE 2> /dev/null | grep ' = \"xfce4\"$' >/dev/null 2>&1; then DE=xfce;
+-    elif [ x"$DESKTOP_SESSION" == x"LXDE" ]; then DE=lxde;
+-    else DE=""
++    elif xprop -root 2> /dev/null | grep -i '^xfce_desktop_window' >/dev/null 2>&1; then DE=xfce
++    fi
++
++    if [ x"$DE" = x"" ]; then
++      # fallback to checking $DESKTOP_SESSION
++      case "$DESKTOP_SESSION" in
++         gnome)
++           DE=gnome;
++           ;;
++         LXDE)
++           DE=lxde; 
++           ;;
++         xfce|xfce4)
++           DE=xfce;
++           ;;
++      esac
++    fi
++
++    if [ x"$DE" = x"gnome" ]; then
++      # gnome-default-applications-properties is only available in GNOME 2.x
++      # but not in GNOME 3.x
++      which gnome-default-applications-properties > /dev/null 2>&1  || DE="gnome3"
+     fi
+ }
+ 
+@@ -535,7 +558,7 @@
+     open_kde "$url"
+     ;;
+ 
+-    gnome)
++    gnome*)
+     open_gnome "$url"
+     ;;
+ 
-- 
cgit v0.12