From e07ae7bd514987a930233fbd4db9c3d990144452 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 4 Apr 2010 14:16:17 -0500
Subject: vdpauninfo-legacy: initial import, replaces vdpinfo. This is a stub
 for when using older drivers

---
 abs/core-testing/vdpauinfo-legacy/PKGBUILD  | 26 ++++++++++++++++++++++++++
 abs/core-testing/vdpauinfo-legacy/vdpauinfo |  2 ++
 2 files changed, 28 insertions(+)
 create mode 100644 abs/core-testing/vdpauinfo-legacy/PKGBUILD
 create mode 100755 abs/core-testing/vdpauinfo-legacy/vdpauinfo

diff --git a/abs/core-testing/vdpauinfo-legacy/PKGBUILD b/abs/core-testing/vdpauinfo-legacy/PKGBUILD
new file mode 100644
index 0000000..7e7fe26
--- /dev/null
+++ b/abs/core-testing/vdpauinfo-legacy/PKGBUILD
@@ -0,0 +1,26 @@
+# It is not expected that vdpau will work with the 71xx nVidia drivers, but we still want
+# 'vdpinfo' to return something when users run it, even if the real 'vdpinfo' won't build
+# for their nVidia driver version.
+
+pkgname=vdpauinfo-legacy
+pkgver=1
+pkgrel=4
+pkgdesc="tells the user they can't handle vdpau"
+license=('GPLv2')
+arch=('i686' 'x86_64')
+depends=('')
+# Just let the dependency on the right nvidia and nvidia-utils versions
+# handle conflicts via those packages conflicts.
+conflicts=(vdpauinfo)
+provides=('vpinfo' 'vdpauinfo')
+source=(vdpauinfo)
+md5sums=()
+
+build() {
+    LH_ROOT=/usr/LH
+    mkdir -p $startdir/pkg/$LH_ROOT/bin/
+
+    cd $startdir
+    install -m0755 -D vdpauinfo $startdir/pkg/$LH_ROOT/bin/
+}
+md5sums=('502f0a21bd1232e5a6bccb17cd63116d')
diff --git a/abs/core-testing/vdpauinfo-legacy/vdpauinfo b/abs/core-testing/vdpauinfo-legacy/vdpauinfo
new file mode 100755
index 0000000..9b237dc
--- /dev/null
+++ b/abs/core-testing/vdpauinfo-legacy/vdpauinfo
@@ -0,0 +1,2 @@
+#!/bin/bash
+echo "vdpau is unsupported"
-- 
cgit v0.12