From 8cde77bead8cdc72f8a8b4f7f70eb5e5eed3a8b3 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 12 Oct 2015 14:41:42 +0000
Subject: LinHES-system: checkXFSfrag.sh: ionice xfs_fsr

---
 abs/core/LinHES-system/PKGBUILD        | 4 ++--
 abs/core/LinHES-system/checkXFSfrag.sh | 7 ++++---
 2 files changed, 6 insertions(+), 5 deletions(-)

diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index e4ca5e2..7469000 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=8.3
-pkgrel=17
+pkgrel=18
 arch=('i686' 'x86_64')
 install=system.install
 pkgdesc="Everything that makes LinHES an automated system"
@@ -120,7 +120,7 @@ md5sums=('76842f8cff548d2c1289e0992a8b84dd'
          'bacc813b48bafcc6fe906e5969930501'
          'dedd3fcb1abec6361f4060d8149c7d6d'
          '8b0298f70f97cc1dc2a58b9a73c64bd3'
-         '716710e0db42147b079c9ec1c7080efa'
+         'b4bb70650893c811c854d446cfa6ca6a'
          'cd28dd67a78f3b7da704e31db0298916'
          'e9f545c3bcf9c85b45496c281fc6a1b8'
          'a94fe6d980f4b810f2e2ae5352084b39'
diff --git a/abs/core/LinHES-system/checkXFSfrag.sh b/abs/core/LinHES-system/checkXFSfrag.sh
index 74b73c4..709cdac 100755
--- a/abs/core/LinHES-system/checkXFSfrag.sh
+++ b/abs/core/LinHES-system/checkXFSfrag.sh
@@ -27,10 +27,11 @@
 # Original Release: 2011 December 15 (Merry Christmas!)
 # DO NOT ALTER HEADER FROM THIS LINE UP.
 #
-e='/bin/echo -e'                                # Use the echo command, not built-in.
+e='/usr/bin/echo -e'                                # Use the echo command, not built-in.
 xfsfsr=/usr/bin/xfs_fsr                            # Set variable with the path to xfs_fsr.
 xfsdb=/usr/bin/xfs_db                              # Set variable with the path to xfs_db.
-pctmax=15                                        # Set maxiumum frag percent needed for defrag.
+ionice=/usr/bin/ionice                             # Set variable with the path to ionice.
+pctmax=12                                        # Set maxiumum frag percent needed for defrag.
                                                 # This is zero here for testing purposes only
                                                 # a higher number should be used in production.
 array=`df -T|grep xfs|cut -f 1 --delim=" "`     # Array of all XFS file systems.
@@ -48,7 +49,7 @@ do
                 $e "${i} is $percentage% fragmented. Running defragment on ${i}."
                 # Only uncomment one of the following two lines.
                 #$xfsfsr -v ${i}        # Uncomment for verbose defrag.
-                $xfsfsr ${i}           # Uncomment for quiet defrag.
+                $ionice -c3 $xfsfsr ${i}           # Uncomment for quiet defrag.
             else
                 $e "${i} is $percent2% fragmented and is below the fragmentation threshold of $pctmax%. Skipping."
             fi
-- 
cgit v0.12