From b05c6f777dde33dc0dde24ac461b5e4b8ed4f466 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Fri, 7 Dec 2012 09:06:59 -0600
Subject: filesystem:  2012.10

---
 abs/core/filesystem/PKGBUILD           | 43 +++++++++++-------
 abs/core/filesystem/__changelog        |  2 +-
 abs/core/filesystem/archlinux.7.txt    | 80 ++++++++++++++++++++++++++++++++++
 abs/core/filesystem/crypttab           | 36 +++++----------
 abs/core/filesystem/filesystem.install |  4 +-
 abs/core/filesystem/group              |  1 +
 abs/core/filesystem/gshadow            |  1 +
 abs/core/filesystem/issue              |  2 +-
 abs/core/filesystem/locale.sh          | 28 ++++++++++++
 abs/core/filesystem/nsswitch.conf      |  2 +-
 abs/core/filesystem/passwd             |  1 +
 abs/core/filesystem/shadow             |  1 +
 12 files changed, 156 insertions(+), 45 deletions(-)
 create mode 100644 abs/core/filesystem/archlinux.7.txt
 create mode 100644 abs/core/filesystem/locale.sh

diff --git a/abs/core/filesystem/PKGBUILD b/abs/core/filesystem/PKGBUILD
index e0e0497..1bce61a 100644
--- a/abs/core/filesystem/PKGBUILD
+++ b/abs/core/filesystem/PKGBUILD
@@ -1,22 +1,29 @@
-# $Id: PKGBUILD 163828 2012-07-20 23:48:47Z tomegun $
+# $Id: PKGBUILD 169662 2012-10-25 10:06:29Z tomegun $
 # Maintainer: Tom Gundersen <teg@jklm.no>
 
 pkgname=filesystem
-pkgver=2012.7
-pkgrel=1
+pkgver=2012.10
+pkgrel=2
 pkgdesc='Base filesystem'
 arch=('any')
 license=('GPL')
 url='http://www.archlinux.org'
 groups=('base')
 install='filesystem.install'
-depends=('iana-etc' 'bash' 'coreutils')
+makedepends=('asciidoc')
+depends=('iana-etc' 'bash' 'coreutils' 'nss-myhostname')
 backup=('etc/fstab' 'etc/crypttab' 'etc/group' 'etc/hosts' 'etc/ld.so.conf' 'etc/passwd'
         'etc/shadow' 'etc/gshadow' 'etc/resolv.conf' 'etc/motd' 'etc/nsswitch.conf'
         'etc/shells' 'etc/host.conf' 'etc/securetty' 'etc/profile' 'etc/issue')
-source=('group' 'issue' 'nsswitch.conf' 'securetty' 'host.conf' 'ld.so.conf'
+source=('group'  'nsswitch.conf' 'securetty' 'host.conf' 'ld.so.conf'
         'passwd' 'shadow' 'fstab' 'crypttab' 'hosts' 'motd' 'os-release' 'resolv.conf'
-        'shells' 'gshadow' 'profile' 'modprobe.d.usb-load-ehci-first')
+        'shells' 'gshadow' 'profile' 'modprobe.d.usb-load-ehci-first' 'archlinux.7.txt'
+	'locale.sh')
+
+build() {
+	cd ${srcdir}
+	a2x -d manpage -f manpage archlinux.7.txt
+}
 
 package() {
 	cd ${pkgdir}
@@ -36,7 +43,7 @@ package() {
 
 	# setup /etc
 	install -d etc/{ld.so.conf.d,skel,profile.d}
-	for f in fstab group host.conf hosts ld.so.conf motd nsswitch.conf os-release passwd resolv.conf securetty shells profile; do
+	for f in fstab group host.conf hosts  ld.so.conf motd nsswitch.conf os-release passwd resolv.conf securetty shells profile; do
 		install -m644 ${srcdir}/${f} etc/
 	done
 	ln -s /proc/self/mounts etc/mtab
@@ -45,6 +52,7 @@ package() {
 	done
 	touch etc/arch-release
 	install -D -m644 ${srcdir}/modprobe.d.usb-load-ehci-first usr/lib/modprobe.d/usb-load-ehci-first.conf
+	install -m755 ${srcdir}/locale.sh etc/profile.d/locale.sh
 
 	# setup /var
 	for d in cache/man local opt log/old lib/misc empty; do
@@ -67,6 +75,10 @@ package() {
 		install -d -m755 usr/share/man/man${d}
 	done
 
+	#
+	# install archlinux(7) manpage
+	#
+	install -D -m644 ${srcdir}/archlinux.7 usr/share/man/man7/archlinux.7
 
 	#
 	# setup /usr/local hierarchy
@@ -76,21 +88,22 @@ package() {
 	done
 	ln -s ../man usr/local/share/man
 }
-md5sums=('45940618da782cc391c59f88ab3333c3'
-         'b153cc716cd73e8ec17bc27fa127d052'
-         '13753e4e0964f3652b0cc60a28528bdf'
+md5sums=('004013ac940ef3d3cdd8c596e7accfe1'
+         '9e4533df61f0c82d6b2e2371f7376282'
          'f833071f3b4c1e1033770c0ef30da0a4'
          'f28150d4c0b22a017be51b9f7f9977ed'
          '6e488ffecc8ba142c0cf7e2d7aeb832e'
-         '8a9042a2cedf6b6b47eb8973f14289cb'
-         'b8355d9d2782f424f4cedcf682651be0'
+         '455b78cada80f40b6f6968f5cbd97a2e'
+         '01249bb0ba4468f95e2cc3a627f5e6e3'
          'ca716f853860199c1286e7939b2f2666'
-         'e5d8323a4dbee7a6d0d2a19cbf4b819f'
+         '1745349eb24ed21b4cfaa6f423bddb76'
          '7bc65f234dfb6abf24e7c3b03e86f4ff'
          'd41d8cd98f00b204e9800998ecf8427e'
          'c1e795aa3bae70bf0fb76b8a720e4825'
          '6f48288b6fcaf0065fcb7b0e525413e0'
          '22518e922891f9359f971f4f5b4e793c'
-         'f95416882cef800edef08382a1176b7d'
+         '677523dbe94b79299aa91b35ed8203b6'
          'f3b6ae7db8adffaaa4bffc6099dcbd50'
-         'a8a962370cd0128465d514e6a1f74130')
+         'a8a962370cd0128465d514e6a1f74130'
+         'f339bbc45ff3ad4dd73039beab2f28e3'
+         '3807d07215d9116331fe1cf8feeaa0f8')
diff --git a/abs/core/filesystem/__changelog b/abs/core/filesystem/__changelog
index 0ecc942..b68b199 100644
--- a/abs/core/filesystem/__changelog
+++ b/abs/core/filesystem/__changelog
@@ -1,3 +1,3 @@
 added tty10 to securetty
-os.system
+os-release
 remove issue
diff --git a/abs/core/filesystem/archlinux.7.txt b/abs/core/filesystem/archlinux.7.txt
new file mode 100644
index 0000000..74eee59
--- /dev/null
+++ b/abs/core/filesystem/archlinux.7.txt
@@ -0,0 +1,80 @@
+/////
+vim:set ts=4 sw=4 syntax=asciidoc noet:
+/////
+archlinux(7)
+============
+
+NAME
+----
+archlinux - basic configuration
+
+SYNOPSIS
+--------
+Overview of the basic configuration of Arch Linux.
+
+DESCRIPTION
+-----------
+Arch Linux exposes the user to the system without hiding any details. This manpage gives a
+brief overview of the configuration files that should be set up on a fresh install.
+
+SYSTEM SERVICES[[S]]
+--------------------
+System services to be started at boot can be enabled using 'systemctl enable <name>.service'. To view
+available services use 'systemctl list-unit-files'.
+
+HOSTNAME[[H]]
+-------------
+The hostname of the machine can be set using 'hostnamectl set-hostname <hostname>'. It will then be
+written to /etc/hostname.
+
+LOCALIZATION[[L]]
+-----------------
+Various locales may be enabled in /etc/locale.gen, and generated by locale-gen. The system-wide locale to be used
+can be configured in /etc/locale.conf. These settings can be overridden on a per-user basis by keeping a
+user-specific locale.conf in $HOME/.config/locale.conf. The user-specific file will take precedence if it exists.
+
+VIRTUAL CONSOLE[[V]]
+--------------------
+The virtual console is configured in /etc/vconsole.conf. It allows you to set a font and a keyboard layout, among
+other things. Note that these settings only apply to the console, and not if you use X.
+
+TIME[[T]]
+---------
+The local timezone is configured by calling 'timedatectl set-timezone <Region/City>'. A *symlink* is then created
+from /etc/localtime to the correct zoneinfo file under /usr/share/zoneinfo/. E.g.,
+
+    /etc/localtime -> ../usr/share/zoneinfo/Europe/Paris
+
+The real-time clock, which keeps track of time when the computer is off, can be configured to either
+be in UTC or in localtime by calling 'timedatectl set-local-rtc <false|true>'. The default is UTC.
+
+FILESYSTEMS[[F]]
+----------------
+Filesystems are configured in /etc/fstab, and encryption mappings are configured in /etc/crypttab.
+
+INITRAMFS[[R]]
+--------------
+The initramfs is generated by mkinitcpio, and can be configured in /etc/mkinitcpio.conf.
+
+PACKAGE MANAGER[[P]]
+--------------------
+The package manager, pacman, is configured in /etc/pacman.conf.
+
+BOOTLOADER[[B]]
+---------------
+GRUB's configuration is generated from /etc/default/grub by grub-mkconfig. Syslinux is configured in /boot/syslinux/syslinux.cfg
+
+MODULES[[M]]
+------------
+Most modules should be loaded on-demand. Modules to be unconditionally loaded at boot can be specified in /etc/modules-load.d/,
+and modules to be blacklisted from auto-loading can be configured in /etc/modprobe.d/.
+
+SEE ALSO
+--------
+
+systemctl(1), hostnamectl(1), hostname(5), locale.conf(5), vconsole.conf(5), timedatectl(1), timezone(3), hwclock(8), fstab(5),
+crypttab(5), mkinitcpio(8), pacman(8), pacman.conf(5), grub-mkconfig(8), syslinux(1), modules-load.d(5), modprobe.d(5)
+
+AUTHORS
+-------
+Written by Tom Gundersen.
diff --git a/abs/core/filesystem/crypttab b/abs/core/filesystem/crypttab
index dd6994b..195945a 100644
--- a/abs/core/filesystem/crypttab
+++ b/abs/core/filesystem/crypttab
@@ -1,33 +1,17 @@
-# crypttab: Mappings for encrypted partitions
+# crypttab: mappings for encrypted partitions
 #
 # Each mapped device will be created in /dev/mapper, so your /etc/fstab
-# should use the /dev/mapper/{NAME} paths for encrypted devices.
+# should use the /dev/mapper/<name> paths for encrypted devices.
 #
-# Each PASSWORD field can be an absolute pathname to a key file (starting
-# with a slash, recommended) or a literal string that will be used as
-# a passphrase. To use special characters in the passphrase, surround it
-# by quotes, the usual bash quoting rules apply.
-# There are two special keywords that cannot be used as passphrases:
-#   - ASK  ask for a passphrase on boot
-#   - SWAP use a random key and create a swapspace afterwards
-# WARNING: use the SWAP keyword carefully, as it overwrites the data
-#          on the specified partition
-# 
-# To create a key file:
-#    hashalot -n 32 ripemd160 >/etc/crytfs.key
-# or
-#    dd if=/dev/urandom of=/etc/cryptfs.key bs=256 count=1
-#
-# To pass additional options to cryptsetup for non-LUKS partitions, use the
-# fourth column.
+# The Arch specific syntax has been deprecated, see crypttab(5) for the
+# new supported syntax.
 #
 # NOTE: Do not list your root (/) partition here, it must be set up
 #       beforehand by the initramfs (/etc/mkinitcpio.conf).
 
-
-# NAME		SOURCE DEVICE		PASSWORD		OPTIONS
-#home		/dev/hda4		mypassword
-#data1		/dev/hda3		"my \"password\""
-#data2		/dev/hda5		/etc/cryptfs.key
-#swap		/dev/hdx4		SWAP			-c aes-cbc-essiv:sha256 -s 256
-#vol		/dev/hdb7		ASK
+# <name>       <device>         <password>              <options>
+# home         /dev/hda4        /etc/mypassword1
+# data1        /dev/hda3        /etc/mypassword2
+# data2        /dev/hda5        /etc/cryptfs.key
+# swap         /dev/hdx4        /dev/urandom            swap,cipher=aes-cbc-essiv:sha256,size=256
+# vol          /dev/hdb7        none
diff --git a/abs/core/filesystem/filesystem.install b/abs/core/filesystem/filesystem.install
index c8717f0..34fcc0d 100644
--- a/abs/core/filesystem/filesystem.install
+++ b/abs/core/filesystem/filesystem.install
@@ -41,8 +41,10 @@ post_upgrade() {
 	_addgroup scanner -g 96
 	_addgroup rfkill  -g 24
 	_addgroup lock    -g 54
+	_addgroup uuidd   -g 68
+	_adduser uuidd   -u 68 -d / -g uuidd -s /sbin/nologin
 
-	# sync gshadow to group (fixes FS#19869
+	# sync gshadow to group (fixes FS#19869)
 	if ! grep -q '^lock:' etc/gshadow; then
 		grpconv >/dev/null
 	fi
diff --git a/abs/core/filesystem/group b/abs/core/filesystem/group
index 6e8e773..cfee1f2 100644
--- a/abs/core/filesystem/group
+++ b/abs/core/filesystem/group
@@ -20,6 +20,7 @@ smmsp:x:25:
 http:x:33:
 games:x:50:
 lock:x:54:
+uuidd:x:68:
 network:x:90:
 video:x:91:
 audio:x:92:
diff --git a/abs/core/filesystem/gshadow b/abs/core/filesystem/gshadow
index c5c7635..c5ac185 100644
--- a/abs/core/filesystem/gshadow
+++ b/abs/core/filesystem/gshadow
@@ -20,6 +20,7 @@ smmsp:::
 http:::
 games:::
 lock:::
+uuidd:!::
 network:x::
 video:x::
 audio:::
diff --git a/abs/core/filesystem/issue b/abs/core/filesystem/issue
index 36067f0..dd702dc 100644
--- a/abs/core/filesystem/issue
+++ b/abs/core/filesystem/issue
@@ -1,2 +1,2 @@
-LinHES\r (\l)
+Arch Linux \r (\l)
 
diff --git a/abs/core/filesystem/locale.sh b/abs/core/filesystem/locale.sh
new file mode 100644
index 0000000..5fd4174
--- /dev/null
+++ b/abs/core/filesystem/locale.sh
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+unset LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES \
+      LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT LC_IDENTIFICATION
+
+if [ -n "$XDG_CONFIG_HOME" ] && [ -r "$XDG_CONFIG_HOME/locale.conf" ]; then
+  . "$XDG_CONFIG_HOME/locale.conf"
+elif [ -n $HOME ] && [ -r $HOME/.config/locale.conf ]; then
+  . "$HOME/.config/locale.conf"
+elif [ -r /etc/locale.conf ]; then
+  . /etc/locale.conf
+elif [ -r /etc/rc.conf ]; then
+  LANG=$(. /etc/rc.conf 2>/dev/null; echo "$LOCALE")
+fi
+
+export LANG="${LANG:-C}"
+[ -n "$LC_CTYPE" ]          && export LC_CTYPE
+[ -n "$LC_NUMERIC" ]        && export LC_NUMERIC
+[ -n "$LC_TIME" ]           && export LC_TIME
+[ -n "$LC_COLLATE" ]        && export LC_COLLATE
+[ -n "$LC_MONETARY" ]       && export LC_MONETARY
+[ -n "$LC_MESSAGES" ]       && export LC_MESSAGES
+[ -n "$LC_PAPER" ]          && export LC_PAPER
+[ -n "$LC_NAME" ]           && export LC_NAME
+[ -n "$LC_ADDRESS" ]        && export LC_ADDRESS
+[ -n "$LC_TELEPHONE" ]      && export LC_TELEPHONE
+[ -n "$LC_MEASUREMENT" ]    && export LC_MEASUREMENT
+[ -n "$LC_IDENTIFICATION" ] && export LC_IDENTIFICATION
diff --git a/abs/core/filesystem/nsswitch.conf b/abs/core/filesystem/nsswitch.conf
index 6e459ad..4a4f577 100644
--- a/abs/core/filesystem/nsswitch.conf
+++ b/abs/core/filesystem/nsswitch.conf
@@ -6,7 +6,7 @@ shadow: files
 
 publickey: files
 
-hosts: files dns
+hosts: files dns myhostname
 networks: files
 
 protocols: files
diff --git a/abs/core/filesystem/passwd b/abs/core/filesystem/passwd
index a4a24e3..cb9fec7 100644
--- a/abs/core/filesystem/passwd
+++ b/abs/core/filesystem/passwd
@@ -4,4 +4,5 @@ daemon:x:2:2:daemon:/sbin:/bin/false
 mail:x:8:12:mail:/var/spool/mail:/bin/false
 ftp:x:14:11:ftp:/srv/ftp:/bin/false
 http:x:33:33:http:/srv/http:/bin/false
+uuidd:x:68:68:uuidd:/:/sbin/nologin
 nobody:x:99:99:nobody:/:/bin/false
diff --git a/abs/core/filesystem/shadow b/abs/core/filesystem/shadow
index ccab68d..5eff493 100644
--- a/abs/core/filesystem/shadow
+++ b/abs/core/filesystem/shadow
@@ -4,4 +4,5 @@ daemon:x:14871::::::
 mail:x:14871::::::
 ftp:x:14871::::::
 http:x:14871::::::
+uuidd:x:14871::::::
 nobody:x:14871::::::
-- 
cgit v0.12