From 26c5910152da4720ff7130108a8a0fb953c8e431 Mon Sep 17 00:00:00 2001
From: Nathan Harris <nharris@eoimaging.com>
Date: Tue, 12 May 2009 14:49:15 -0400
Subject: qt updated to 4.5.1

---
 abs/core-testing/qt/PKGBUILD              | 88 +++++++++++++------------------
 abs/core-testing/qt/assistant.desktop     |  8 +++
 abs/core-testing/qt/designer.desktop      |  9 ++++
 abs/core-testing/qt/linguist.desktop      |  9 ++++
 abs/core-testing/qt/qdoc3.patch           | 22 ++++++++
 abs/core-testing/qt/qt4-assistant.desktop | 10 ----
 abs/core-testing/qt/qt4-designer.desktop  | 11 ----
 abs/core-testing/qt/qt4-linguist.desktop  | 11 ----
 abs/core-testing/qt/qtconfig.desktop      |  8 +++
 9 files changed, 93 insertions(+), 83 deletions(-)
 create mode 100644 abs/core-testing/qt/assistant.desktop
 create mode 100644 abs/core-testing/qt/designer.desktop
 create mode 100644 abs/core-testing/qt/linguist.desktop
 create mode 100644 abs/core-testing/qt/qdoc3.patch
 delete mode 100644 abs/core-testing/qt/qt4-assistant.desktop
 delete mode 100644 abs/core-testing/qt/qt4-designer.desktop
 delete mode 100644 abs/core-testing/qt/qt4-linguist.desktop
 create mode 100644 abs/core-testing/qt/qtconfig.desktop

diff --git a/abs/core-testing/qt/PKGBUILD b/abs/core-testing/qt/PKGBUILD
index a06b7e0..b581564 100644
--- a/abs/core-testing/qt/PKGBUILD
+++ b/abs/core-testing/qt/PKGBUILD
@@ -1,31 +1,34 @@
-# $Id: PKGBUILD 18501 2008-11-06 12:11:46Z pierre $
+# $Id$
 # Maintainer: Pierre Schmitz <pierre@archlinux.de>
 
 pkgname=qt
-pkgver=4.4.3
+pkgver=4.5.1
 pkgrel=2
-_qtcopyver=880178
-pkgdesc="The QT gui toolkit."
+_qtcopyver=958581
+pkgdesc='A cross-platform application and UI framework'
 arch=('i686' 'x86_64')
-url="http://www.trolltech.com/products/qt"
-license=('GPL3')
-options=('!libtool' '!docs')
-depends=('libpng' 'libxi' 'mesa' 'fontconfig' 'libxrandr' 'glib2' 'libtiff' 'libmng' 'sqlite3' 'dbus' 'libxcursor' 'libxinerama')
+url='http://www.qtsoftware.com/'
+license=('GPL3' 'LGPL')
+depends=('libpng' 'mesa' 'fontconfig' 'libtiff' 'libmng' 'sqlite3' 'libxrandr' 'glib2' 'libxi' 'dbus' 'libxcursor' 'libxinerama' 'libxrender')
 optdepends=('postgresql-libs' 'libmysqlclient' 'unixodbc')
 makedepends=('inputproto' 'postgresql-libs' 'mysql' 'unixodbc' 'libxfixes')
 provides=("qt4=${pkgver}")
 replaces=('qt4')
 conflicts=('qt4')
-_pkgfqn=qt-x11-opensource-src-$pkgver
-# svn export -r -${_qtcopyver} svn://anonsvn.kde.org/home/kde/trunk/qt-copy/patches/ qt-copy-patches-${_qtcopyver}
-source=("ftp://ftp.trolltech.com/qt/source/${_pkgfqn}.tar.bz2"
+options=('!libtool')
+_pkgfqn="qt-x11-opensource-src-${pkgver}"
+# svn export -r${_qtcopyver} svn://anonsvn.kde.org/home/kde/trunk/qt-copy/patches/ qt-copy-patches-${_qtcopyver}
+source=("ftp://ftp.qtsoftware.com/qt/source/${_pkgfqn}.tar.bz2"
         "ftp://ftp.archlinux.org/other/qt/qt-copy-patches-${_qtcopyver}.tar.bz2"
-        'qt4-assistant.desktop' 'qt4-designer.desktop' 'qt4-linguist.desktop')
-md5sums=('00e00c6324d342a7b0d8653112b4f08c'
-         'd3a40d783528a86174b62ecfc136b031'
-         'c95e1697bf2b923199c3b8cd7d485a17'
-         '00333dca87e24767383217ba378b5980'
-         '71f7ac8206c19da7ecf71cdb391f0452')
+        'assistant.desktop' 'designer.desktop' 'linguist.desktop' 'qtconfig.desktop'
+        'qdoc3.patch')
+md5sums=('afc43e566341cf3e5ed0bcb974f0c3b2'
+         'b57b08ac7f990f91b85a7b1b1106e36b'
+         'b352b4b70faba2571af3fce5d119580a'
+         '491a96682faa03407f768a53cca71db5'
+         'cda7ed7e132689991dc2968a0043b4b0'
+         '717669b728a0a795217d2f52969e454c'
+         '868056a3edab09fbac0f82ec8b4a4be3')
 
 build() {
 	unset QMAKESPEC
@@ -39,58 +42,41 @@ build() {
 		patch -p0 -i $i || return 1
 	done
 
-	# remove unwanted mkspecs
-	cd mkspecs/
-	find . -maxdepth 1 -regextype posix-egrep -type d ! -regex "./linux.*|./common|./features|./qws" -exec rm -rf "{}" \;
-	cd qws
-	find . -maxdepth 1 -regextype posix-egrep -type d ! -regex "./linux.*" -exec rm -rf "{}" \;
-	cd ../../
+	patch -p1 -i $srcdir/qdoc3.patch
 
-	sed -i 's|-cp -P -f|-cp -L -f|' qmake/Makefile.unix
 	sed -i "s|-O2|$CXXFLAGS|" mkspecs/common/g++.conf
-	# fix postgres build
-	sed -e '/pg_config --libs/d' -i configure
-	# do not compile demos, examples and docs
-	sed -i 's|CFG_NOBUILD_PARTS=""|CFG_NOBUILD_PARTS="demos examples docs"|' configure
 
-	./configure -confirm-license \
+	./configure -confirm-license -opensource \
+		-silent \
 		-prefix /usr \
-		-docdir /usr/share/doc/qt \
+		-sysconfdir /etc \
 		-plugindir /usr/lib/qt/plugins \
-		-datadir /usr/share/qt \
 		-translationdir /usr/share/qt/translations \
-		-sysconfdir /etc \
+		-datadir /usr/share/qt \
+		-docdir /usr/share/doc/qt \
 		-examplesdir /usr/share/doc/qt/examples \
 		-demosdir /usr/share/doc/qt/demos \
-		-no-exceptions \
+		-no-separate-debug-info \
 		-plugin-sql-{psql,mysql,sqlite,odbc} \
 		-system-sqlite \
-		-no-phonon \
-		-dbus-linked \
-		-webkit \
-		-no-separate-debug-info \
+		-openssl-linked \
+		-nomake demos \
 		-nomake examples \
 		-nomake docs \
-		-nomake demos \
-		-assistant-webkit \
-		-system-libpng \
-		-system-libjpeg \
-		-system-zlib \
-		-openssl-linked \
-		-reduce-relocations \
-		-xinerama \
-		-xcursor \
-		-xfixes \
-		-optimized-qmake || return 1
+		-no-phonon \
+		-optimized-qmake \
+		-reduce-relocations
 
-	make || return 1
-	make INSTALL_ROOT=$pkgdir install || return 1
+	make
+	make INSTALL_ROOT=$pkgdir install
 
 	install -D -m644 tools/assistant/tools/assistant/images/assistant.png ${pkgdir}/usr/share/pixmaps/assistant.png
 	install -D -m644 tools/linguist/linguist/images/appicon.png ${pkgdir}/usr/share/pixmaps/linguist.png
 	install -D -m644 tools/designer/src/designer/images/designer.png ${pkgdir}/usr/share/pixmaps/designer.png
+	install -D -m644 src/gui/dialogs/images/qtlogo-64.png ${pkgdir}/usr/share/pixmaps/qtlogo.png
 	install -d ${pkgdir}/usr/share/applications
-	install -m644 ${srcdir}/qt4-{linguist,designer,assistant}.desktop ${pkgdir}/usr/share/applications/
+	install -m644 ${srcdir}/{linguist,designer,assistant,qtconfig}.desktop ${pkgdir}/usr/share/applications/
+	install -D -m644 LGPL_EXCEPTION.txt ${pkgdir}/usr/share/licenses/qt/LGPL_EXCEPTION.txt
 
 	# cleanup and path fixes
 	find $pkgdir/usr/lib -type f -name '*prl' -print -exec sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" {} \;
diff --git a/abs/core-testing/qt/assistant.desktop b/abs/core-testing/qt/assistant.desktop
new file mode 100644
index 0000000..48105b9
--- /dev/null
+++ b/abs/core-testing/qt/assistant.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Exec=/usr/bin/assistant
+Name=Qt Assistant
+GenericName=Qt Document Browser
+Icon=/usr/share/pixmaps/assistant.png
+Terminal=false
+Type=Application
+Categories=Qt;Development;Documentation
diff --git a/abs/core-testing/qt/designer.desktop b/abs/core-testing/qt/designer.desktop
new file mode 100644
index 0000000..fefe095
--- /dev/null
+++ b/abs/core-testing/qt/designer.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Exec=/usr/bin/designer
+Name=Qt Designer
+GenericName=Interface Designer
+MimeType=application/x-designer
+Icon=/usr/share/pixmaps/designer.png
+Terminal=false
+Type=Application
+Categories=Qt;Development;GUIDesigner
diff --git a/abs/core-testing/qt/linguist.desktop b/abs/core-testing/qt/linguist.desktop
new file mode 100644
index 0000000..04519bf
--- /dev/null
+++ b/abs/core-testing/qt/linguist.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Exec=/usr/bin/linguist
+Name=Qt Linguist
+GenericName=Translation Tool
+MimeType=application/x-linguist
+Terminal=false
+Type=Application
+Icon=/usr/share/pixmaps/linguist.png
+Categories=Qt;Development;Translation
diff --git a/abs/core-testing/qt/qdoc3.patch b/abs/core-testing/qt/qdoc3.patch
new file mode 100644
index 0000000..38ae735
--- /dev/null
+++ b/abs/core-testing/qt/qdoc3.patch
@@ -0,0 +1,22 @@
+diff -up qt-x11-opensource-src-4.5.0/tools/qdoc3/qdoc3.pro.qdoc3 qt-x11-opensource-src-4.5.0/tools/qdoc3/qdoc3.pro
+--- qt-x11-opensource-src-4.5.0/tools/qdoc3/qdoc3.pro.qdoc3	2009-02-25 15:09:26.000000000 -0600
++++ qt-x11-opensource-src-4.5.0/tools/qdoc3/qdoc3.pro	2009-03-04 09:30:05.000000000 -0600
+@@ -106,3 +106,7 @@ win32 {
+         QT_WINCONFIG = debug
+     }    
+ }
++
++TARGET= qdoc3
++target.path = $$[QT_INSTALL_BINS]
++INSTALLS += target
+diff -up qt-x11-opensource-src-4.5.0/tools/tools.pro.qdoc3 qt-x11-opensource-src-4.5.0/tools/tools.pro
+--- qt-x11-opensource-src-4.5.0/tools/tools.pro.qdoc3	2009-02-25 15:09:27.000000000 -0600
++++ qt-x11-opensource-src-4.5.0/tools/tools.pro	2009-03-04 09:44:18.000000000 -0600
+@@ -13,6 +13,7 @@ no-png {
+          SUBDIRS += designer
+      }
+      SUBDIRS     += linguist
++     SUBDIRS     += qdoc3
+      wince*: SUBDIRS = qtestlib designer
+      unix:!mac:!embedded:contains(QT_CONFIG, qt3support):SUBDIRS += qtconfig
+      win32:!wince*:!contains(QT_EDITION, OpenSource|Console):SUBDIRS += activeqt
diff --git a/abs/core-testing/qt/qt4-assistant.desktop b/abs/core-testing/qt/qt4-assistant.desktop
deleted file mode 100644
index 5d64aba..0000000
--- a/abs/core-testing/qt/qt4-assistant.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Exec=/usr/bin/assistant
-Name=Qt 4 Assistant
-GenericName=Qt4 Document Browser
-X-KDE-StartupNotify=true
-Icon=/usr/share/pixmaps/assistant.png
-Terminal=false
-Type=Application
-Categories=Qt;Development;Documentation
diff --git a/abs/core-testing/qt/qt4-designer.desktop b/abs/core-testing/qt/qt4-designer.desktop
deleted file mode 100644
index f4f91e8..0000000
--- a/abs/core-testing/qt/qt4-designer.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Exec=/usr/bin/designer
-Name=Qt 4 Designer
-GenericName=Interface Designer
-X-KDE-StartupNotify=true
-MimeType=application/x-designer
-Icon=/usr/share/pixmaps/designer.png
-Terminal=false
-Type=Application
-Categories=Qt;Development;GUIDesigner
diff --git a/abs/core-testing/qt/qt4-linguist.desktop b/abs/core-testing/qt/qt4-linguist.desktop
deleted file mode 100644
index fee679e..0000000
--- a/abs/core-testing/qt/qt4-linguist.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Exec=/usr/bin/linguist
-Name=Qt 4 Linguist
-GenericName=Translation Tool
-X-KDE-StartupNotify=true
-MimeType=application/x-linguist
-Terminal=false
-Type=Application
-Icon=/usr/share/pixmaps/linguist.png
-Categories=Qt;Development;Translation
diff --git a/abs/core-testing/qt/qtconfig.desktop b/abs/core-testing/qt/qtconfig.desktop
new file mode 100644
index 0000000..633d921
--- /dev/null
+++ b/abs/core-testing/qt/qtconfig.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Qt Config 
+Comment=Configure Qt behavior, styles, fonts
+Exec=/usr/bin/qtconfig
+Icon=/usr/share/pixmaps/qtlogo
+Terminal=false
+Type=Application
+Categories=Qt;Settings;
-- 
cgit v0.12