From 4d54378232c5ad60c4778dec8eb20fb035abc530 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sat, 4 Feb 2023 15:51:40 -0500
Subject: linhes-system: remove mythtv deps and install on first run

---
 linhes/linhes-system/PKGBUILD           | 7 +++----
 linhes/linhes-system/lh_system_start.sh | 9 +++++----
 2 files changed, 8 insertions(+), 8 deletions(-)

diff --git a/linhes/linhes-system/PKGBUILD b/linhes/linhes-system/PKGBUILD
index 993ec7d..ace26d0 100755
--- a/linhes/linhes-system/PKGBUILD
+++ b/linhes/linhes-system/PKGBUILD
@@ -1,13 +1,12 @@
 pkgname=linhes-system
 pkgver=9.0.0
-pkgrel=33
+pkgrel=34
 arch=('x86_64')
 #install=$pkgname.install
 pkgdesc="Everything that makes LinHES a system"
 license=('GPL2')
 depends=('cronie' 'dbus-python' 'flatpak' 'firefox' 'glances' 'kdialog' 'libnotify'
-         'logrotate' 'linhes-templates' 'linhes-theme' 'linhes-web'
-         'mythtv' 'mythplugins-mytharchive' 'mythplugins-mythmusic' 'mythplugins-mythweb' 'ncdu'
+         'logrotate' 'linhes-templates' 'linhes-theme' 'ncdu'
          'openssh' 'pacman-contrib' 'rsyslog' 'ttf-overlock' 'x11vnc')
 binfiles="add_storage.py balance_storage_groups.py empty_storage_groups.py remove_storage.py
           checkXFSfrag.sh enableIRWake.sh idle.py lh_system_start.sh lh_notify-send
@@ -31,7 +30,7 @@ sha256sums=('7f91d2afcb76e8e9063c6bbe05f5c3d134a6f67541aead8894d342c32d34ad98'
             'c7a2b2de44645e3a905b39d7411e5b8b27b60bd2944533fd4655c3b175755da1'
             'ae34515e144830f424d3bd3f6b1b446892d62beed20bca6f0fb19b0bbb779f27'
             '5e6d128f879b0fe7c1a190cccd75d4e5d00afc161f3bc9e92ffa2d87242cc9df'
-            '721c698a2478edd8dad2bc52422bc2c225d14fc3a4c30823cb4a2afe52b82fc4'
+            '3525b5b7ed2aab17a6f16d4c1e223b51a4df251f65cbb81a9c8289f73d7e0670'
             '6d4fb0ed1a5ed961b3a3884dce093118e50c2981a9cd5837d20abc5a6d4fd8aa'
             '87875d9e5f5ce18208f419698ce69b6bcbcd08955a57a4a13940e715af58b787'
             '91bdec992bb2c933e15625c181f2195c402060b879168ebf35944cb064c904b9'
diff --git a/linhes/linhes-system/lh_system_start.sh b/linhes/linhes-system/lh_system_start.sh
index 257f800..fb21b92 100755
--- a/linhes/linhes-system/lh_system_start.sh
+++ b/linhes/linhes-system/lh_system_start.sh
@@ -65,10 +65,11 @@ function storage_scan(){
 function install_lh_apps(){
     #install programs that are not needed on the iso
     msg "Installing apps."
-    #sudo pacman -Syyy --noconfirm archlinux-keyring
+    sudo pacman -Syyy --noconfirm archlinux-keyring
     #sudo pacman -Syyy --noconfirm flatpak firefox glances mlocate mythtv mythplugins-mytharchive mythplugins-mythmusic mythplugins-mythweb ncdu x11vnc
-    #status=$?
-    #[ $status -eq 1 ] && msg "Could not install apps. Check internet connection. Cancelling Setup." && exit 1
+    sudo pacman -Syyy --noconfirm mythtv mythplugins-mytharchive mythplugins-mythmusic mythplugins-mythweb
+    status=$?
+    [ $status -eq 1 ] && msg "Could not install apps. Check internet connection. Cancelling Setup." && exit 1
     flatpak install tv.plex.PlexHTPC --noninteractive --assumeyes
     gen_lib_xml.py
 }
@@ -85,7 +86,7 @@ function sql_setup(){
 }
 
 function localweb_setup(){
-    #sudo pacman -Syyy --noconfirm linhes-web
+    sudo pacman -Syyy --noconfirm linhes-web
     sudo cp /etc/lighttpd/lighttpd.conf /etc/lighttpd/lighttpd.conf.orig
     sudo cp /usr/share/linhes/templates/lighttpd.conf.template /etc/lighttpd/lighttpd.conf
     sudo systemctl enable --now lighttpd.service
-- 
cgit v0.12