From cf345a74d050d0aeab8392fee5069546a1b066dc Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 2 Feb 2023 15:17:04 -0500
Subject: linhes-system: idle.py: add number of inuseprograms

---
 linhes/linhes-system/PKGBUILD | 4 ++--
 linhes/linhes-system/idle.py  | 6 +++++-
 2 files changed, 7 insertions(+), 3 deletions(-)

diff --git a/linhes/linhes-system/PKGBUILD b/linhes/linhes-system/PKGBUILD
index e6378b5..993ec7d 100755
--- a/linhes/linhes-system/PKGBUILD
+++ b/linhes/linhes-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=linhes-system
 pkgver=9.0.0
-pkgrel=32
+pkgrel=33
 arch=('x86_64')
 #install=$pkgname.install
 pkgdesc="Everything that makes LinHES a system"
@@ -30,7 +30,7 @@ sha256sums=('7f91d2afcb76e8e9063c6bbe05f5c3d134a6f67541aead8894d342c32d34ad98'
             'ff261f41efec8a9963f9f59100cbe75f015028a2ed3a863ce0cb473f2ebb7b76'
             'c7a2b2de44645e3a905b39d7411e5b8b27b60bd2944533fd4655c3b175755da1'
             'ae34515e144830f424d3bd3f6b1b446892d62beed20bca6f0fb19b0bbb779f27'
-            '23358a7bff4968eccd469613b81b1415c2ae0ebe77f14f74426697333e4d88d7'
+            '5e6d128f879b0fe7c1a190cccd75d4e5d00afc161f3bc9e92ffa2d87242cc9df'
             '721c698a2478edd8dad2bc52422bc2c225d14fc3a4c30823cb4a2afe52b82fc4'
             '6d4fb0ed1a5ed961b3a3884dce093118e50c2981a9cd5837d20abc5a6d4fd8aa'
             '87875d9e5f5ce18208f419698ce69b6bcbcd08955a57a4a13940e715af58b787'
diff --git a/linhes/linhes-system/idle.py b/linhes/linhes-system/idle.py
index 373ae24..778677d 100755
--- a/linhes/linhes-system/idle.py
+++ b/linhes/linhes-system/idle.py
@@ -114,7 +114,11 @@ def in_use(cmdargs,cursor):
         msg(cmdargs,"        Programs are NOT in use.")
         return True
     else:
-        msg(cmdargs,"        Programs are in use.")
+        msg(cmdargs,"        %s programs are in use." %prginuse)
+        cursor.execute("select recusage,chanid,lastupdatetime from inuseprograms")
+        results=cursor.fetchall()
+        for i in results:
+            msg(cmdargs,"            %s - %s - %s" %(i[0],i[1],i[2]))
         return False
 
 def job_check(cmdargs,cursor):
-- 
cgit v0.12