From 9db0dcfbc67598a7dfd1ce9f2fe833d73a3557e3 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 7 Mar 2018 14:16:43 +0000
Subject: boost: update to 1.66.0

---
 abs/extra/boost/PKGBUILD    | 68 ++++++++++++++++++++++++++++++---------------
 abs/extra/boost/__changelog |  1 -
 2 files changed, 46 insertions(+), 23 deletions(-)
 delete mode 100644 abs/extra/boost/__changelog

diff --git a/abs/extra/boost/PKGBUILD b/abs/extra/boost/PKGBUILD
index cb7b3b7..648711b 100644
--- a/abs/extra/boost/PKGBUILD
+++ b/abs/extra/boost/PKGBUILD
@@ -1,5 +1,6 @@
 # $Id$
 # Maintainer:  Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Marius Knaust <marius.knaust@gmail.com>
 # Contributor: Ionut Biru <ibiru@archlinux.org>
 # Contributor: Stéphane Gaudreault <stephane@archlinux.org>
 # Contributor: kevin <kevin@archlinux.org>
@@ -9,23 +10,15 @@
 
 pkgbase=boost
 pkgname=('boost-libs' 'boost')
-pkgver=1.60.0
+pkgver=1.66.0
 _boostver=${pkgver//./_}
-pkgrel=2
+pkgrel=1
 url='http://www.boost.org/'
-arch=('i686' 'x86_64')
+arch=('x86_64')
 license=('custom')
-makedepends=('icu>=55.1' 'python2' 'bzip2' 'zlib' 'openmpi')
-source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2
-        cuda_float128.patch::"https://github.com/boostorg/config/commit/a332112317450457c715675686386ec81214b863.patch")
-sha1sums=('7f56ab507d3258610391b47fef6b11635861175a'
-          'bdc6486e0d90368bbfd872fed8ee3d3c73483933')
-
-prepare() {
-  cd ${pkgbase}_${_boostver}
-  # fix https://svn.boost.org/trac/boost/ticket/11852
-  patch -p2 -i ../cuda_float128.patch
-}
+makedepends=('icu>=55.1' 'python' 'python2' 'python-numpy' 'python2-numpy' 'bzip2' 'zlib' 'openmpi')
+source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2)
+sha256sums=('5721818253e6a0989583192f96782c4a98eb6204965316df9f5ad75819225ca9')
 
 build() {
    export _stagedir="${srcdir}/stagedir"
@@ -39,11 +32,6 @@ build() {
    [[ "${CARCH}" = "x86_64" ]] && _bindir="bin.linuxx86_64"
    install -Dm755 tools/build/src/engine/$_bindir/b2 "${_stagedir}"/bin/b2
 
-   # Add an extra python version. This does not replace anything and python 2.x
-   # need to be the default.
-   #echo "using python : 3.5 : /usr/bin/python3 : /usr/include/python3.5m : /usr/lib ;" \
-   #   >> project-config.jam
-
    # Support for OpenMPI
    echo "using mpi ;" >> project-config.jam
 
@@ -65,10 +53,40 @@ build() {
       link=shared,static \
       toolset=gcc \
       python=2.7 \
-      cflags="${CPPFLAGS} ${CFLAGS} -fPIC -O3" linkflags="${LDFLAGS}" \
+      cflags="${CPPFLAGS} ${CFLAGS} -fPIC -O3" \
+      cxxflags="${CPPFLAGS} ${CXXFLAGS} -std=c++14 -fPIC -O3" \
+      linkflags="${LDFLAGS}" \
       --layout=system \
+      ${JOBS} \
+      \
       --prefix="${_stagedir}" \
+      install
+
+   # because b2 in boost 1.62.0 doesn't seem to respect python parameter, we
+   # need another run for liboost_python3.so
+   sed -e '/using python/ s@;@: /usr/include/python${PYTHON_VERSION/3*/${PYTHON_VERSION}m} ;@' \
+      -i bootstrap.sh
+
+   ./bootstrap.sh --with-toolset=gcc --with-icu --with-python=/usr/bin/python3 \
+      --with-libraries=python
+
+   "${_stagedir}"/bin/b2 clean
+   "${_stagedir}"/bin/b2 \
+      variant=release \
+      debug-symbols=off \
+      threading=multi \
+      runtime-link=shared \
+      link=shared,static \
+      toolset=gcc \
+      python=3.6 \
+      cflags="${CPPFLAGS} ${CFLAGS} -fPIC -O3" \
+      cxxflags="${CPPFLAGS} ${CXXFLAGS} -std=c++14 -fPIC -O3" \
+      linkflags="${LDFLAGS}" \
+      --layout=system \
       ${JOBS} \
+      \
+      --prefix="${_stagedir}/python3" \
+      --with-python \
       install
 }
 
@@ -76,8 +94,7 @@ package_boost() {
    pkgdesc='Free peer-reviewed portable C++ source libraries - development headers'
    depends=("boost-libs=${pkgver}")
    optdepends=('python: for python bindings'
-               'python2: for python2 bindings'
-               'boost-build: to use boost jam for building your project.')
+               'python2: for python2 bindings')
    options=('staticlibs')
 
    install -dm755 "${pkgdir}"/usr
@@ -89,6 +106,9 @@ package_boost() {
    install -Dm644 "${srcdir}/"${pkgbase}_${_boostver}/LICENSE_1_0.txt \
       "${pkgdir}"/usr/share/licenses/boost/LICENSE_1_0.txt
 
+   install -Dm644 "${_stagedir}"/python3/lib/libboost_*.a \
+      "${pkgdir}"/usr/lib/
+
    ln -s /usr/bin/b2 "$pkgdir"/usr/bin/bjam
 }
 
@@ -97,8 +117,12 @@ package_boost-libs() {
    depends=('bzip2' 'zlib' 'icu')
    optdepends=('openmpi: for mpi support')
 
+   # powerdns-recursor keeps being rebuild against outdated boost-libs
+   provides=('libboost_context.so')
+
    install -dm755 "${pkgdir}"/usr
    cp -a "${_stagedir}"/lib "${pkgdir}"/usr
+   cp -a "${_stagedir}"/python3/lib/libboost_* "${pkgdir}"/usr/lib
    rm "${pkgdir}"/usr/lib/*.a
 
    install -Dm644 "${srcdir}/"${pkgbase}_${_boostver}/LICENSE_1_0.txt \
diff --git a/abs/extra/boost/__changelog b/abs/extra/boost/__changelog
deleted file mode 100644
index f11e775..0000000
--- a/abs/extra/boost/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-PKGBUILD: remove python dep and comment out python 3.5 line
-- 
cgit v0.12