From 71ecb29b4f182ad51ab5073ac4fbb6bebf05a421 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 31 Jan 2019 14:19:00 +0000
Subject: yelp-tools: update to 3.28.0

---
 abs/extra/yelp-tools/PKGBUILD | 33 +++++++++++++++++++++------------
 1 file changed, 21 insertions(+), 12 deletions(-)

diff --git a/abs/extra/yelp-tools/PKGBUILD b/abs/extra/yelp-tools/PKGBUILD
index a5fba2f..c8859ed 100644
--- a/abs/extra/yelp-tools/PKGBUILD
+++ b/abs/extra/yelp-tools/PKGBUILD
@@ -1,26 +1,35 @@
-# $Id$
 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
 # Contributor: Jan de Groot <jgc@archlinux.org>
 
 pkgname=yelp-tools
-pkgver=3.18.0
+pkgver=3.28.0
 pkgrel=1
-pkgdesc="Tools for creating Yelp documentation"
-arch=('any')
-depends=('yelp-xsl' 'libxslt' 'libxml2' 'itstool')
-license=('GPL')
-options=('!emptydirs')
-url="http://www.gnome.org"
-source=(https://download.gnome.org/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz)
-sha256sums=('c6c1d65f802397267cdc47aafd5398c4b60766e0a7ad2190426af6c0d0716932')
+pkgdesc="Collection of tools for building and converting documentation"
+url="https://gitlab.gnome.org/GNOME/yelp-tools"
+arch=(any)
+depends=(yelp-xsl libxslt libxml2 itstool docbook-xsl)
+makedepends=(git)
+license=(GPL)
+_commit=54a1bd6142d367b18a36d1ba96705840042747be  # tags/3.28.0^0
+source=("git+https://gitlab.gnome.org/GNOME/yelp-tools.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+  cd $pkgname
+  git describe --tags | sed 's/-/+/g'
+}
+prepare() {
+  cd $pkgname
+  NOCONFIGURE=1 ./autogen.sh
+}
 
 build() {
-  cd $pkgname-$pkgver
+  cd $pkgname
   ./configure --prefix=/usr
   make
 }
 
 package() {
-  cd $pkgname-$pkgver
+  cd $pkgname
   make DESTDIR="$pkgdir" install
 }
-- 
cgit v0.12