From cf739da3ef34e05a4994fe86e93090f1e4772822 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Sat, 13 Nov 2010 02:16:56 +0000
Subject: nfsidmap: up to latest

---
 abs/core/nfsidmap/PKGBUILD | 19 ++++++++++++-------
 1 file changed, 12 insertions(+), 7 deletions(-)

diff --git a/abs/core/nfsidmap/PKGBUILD b/abs/core/nfsidmap/PKGBUILD
index 401c1e7..c275f12 100644
--- a/abs/core/nfsidmap/PKGBUILD
+++ b/abs/core/nfsidmap/PKGBUILD
@@ -1,26 +1,31 @@
-# $Id: PKGBUILD 13097 2008-09-25 22:11:54Z ronald $
+# $Id: PKGBUILD 52311 2009-09-17 07:29:57Z allan $
 # Maintainer: 
 # Contributor: Judd <jvinet@zeroflux.org>
 
 pkgname=nfsidmap
-pkgver=0.21
-pkgrel=2
+pkgver=0.23
+pkgrel=3
 pkgdesc="Library to help mapping IDs, mainly for NFSv4"
 arch=('i686' 'x86_64')
 url="http://www.citi.umich.edu/projects/nfsv4/linux/"
-depends=('glibc' 'libldap')
+depends=('glibc' 'libldap>=2.4.18')
 license=('custom:nfsidmap')
 options=(!libtool)
 source=(http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/libnfsidmap-$pkgver.tar.gz)
-md5sums=('56b05e30645353befbf73bd905270d4b')
+md5sums=('28f3ece648c1dc5d25e8d623d55f8bd6')
 
 build() {
   cd $srcdir/lib$pkgname-$pkgver
   ./configure --prefix=/usr --sysconfdir=/etc
   make || return 1
+}
+package() {
+  cd $srcdir/lib$pkgname-$pkgver
   make DESTDIR=$pkgdir install || return 1
-
+  # remove idmap manpage provided by nfs-utils!
+  rm $pkgdir/usr/share/man/man5/idmapd.conf.5 || return 1
   # install license
   install -Dm644 COPYING \
-	$pkgdir/usr/share/licenses/nfsidmap/LICENSE || return 1
+        $pkgdir/usr/share/licenses/nfsidmap/LICENSE || return 1
 }
+
-- 
cgit v0.12