From 059a0ccd9b32d683de9f1b5f2d594f97f6e483de Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 7 Apr 2016 12:01:12 +0000
Subject: mythtv: add mediamonitor_use_1st_handler.patch to supress dialogs
 when starting mythfrontend

---
 abs/core/mythtv/stable-0.28/mythtv/PKGBUILD        |  6 ++--
 .../mythtv/mediamonitor_use_1st_handler.patch      | 38 ++++++++++++++++++++++
 2 files changed, 42 insertions(+), 2 deletions(-)
 create mode 100644 abs/core/mythtv/stable-0.28/mythtv/mediamonitor_use_1st_handler.patch

diff --git a/abs/core/mythtv/stable-0.28/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.28/mythtv/PKGBUILD
index bdfedf9..8bef8cc 100644
--- a/abs/core/mythtv/stable-0.28/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.28/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythtv
 pkgver=0.28
-pkgrel=5
+pkgrel=6
 commit_hash=`cat ../git_src/git_hash`
 pkgdesc="A Homebrew PVR project $commit_hash"
 arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ license=('GPL')
 depends=('avahi' 'faad2' 'fftw' 'glew' 'exiv2' 'lame' 'libass' 'libavc1394' 'libcdio'
          'libcec' 'libcrystalhd-git' 'libiec61883' 'libva' 'libvdpau' 'libvpx'
          'libxinerama' 'libxrandr' 'libxml2' 'LinHES-config>=8.1-6'
-         'LinHES-system>=8.4-3' 'lirc-utils' 'mysql-clients' 'mysql-python'
+         'LinHES-system>=8.4-4' 'lirc-utils' 'mysql-clients' 'mysql-python'
          'openssl' 'perl-date-manip' 'perl-dbd-mysql'
          'perl-io-socket-inet6' 'perl-libwww' 'perl-math-round'
          'perl-net-upnp' 'perl-soap-lite' 'perl-xml-sax' 'python2-pycurl'
@@ -23,6 +23,7 @@ install='mythtv.install'
 
 patches=('myth_settings.patch'
          'videoAlwaysUseBookmark.patch'
+         'mediamonitor_use_1st_handler.patch'
          )
 
 optdepends=()
@@ -101,4 +102,5 @@ package() {
 
 md5sums=('e30b482dcd5f3e71c6419fd753bab2b1'
          '41098e898361a5a3cde3eaae358482a8'
+         '8d26b14af13b7be242ba999a8521f8dd'
          '928de4b070d9f3b784d55c0db415eaf3')
diff --git a/abs/core/mythtv/stable-0.28/mythtv/mediamonitor_use_1st_handler.patch b/abs/core/mythtv/stable-0.28/mythtv/mediamonitor_use_1st_handler.patch
new file mode 100644
index 0000000..637a8c7
--- /dev/null
+++ b/abs/core/mythtv/stable-0.28/mythtv/mediamonitor_use_1st_handler.patch
@@ -0,0 +1,38 @@
+--- src/mythtv/libs/libmyth/mythmediamonitor.cpp.orig	2016-04-06 21:44:16.206362097 +0000
++++ src/mythtv/libs/libmyth/mythmediamonitor.cpp	2016-04-06 21:47:14.753580798 +0000
+@@ -664,33 +664,9 @@
+         return;
+     }
+ 
++    // TODO - Generate a dialog, add buttons for each description,
++    // if user didn't cancel, selected = handlers.at(choice);
+     int selected = 0;
+-    if (handlers.size() > 1)
+-    {
+-        QStringList buttonmsgs;
+-        for (QList<MHData>::const_iterator it = handlers.begin(); it != handlers.end(); ++it)
+-            buttonmsgs << ((!it->description.isEmpty()) ? it->description : it->destination);
+-        buttonmsgs << tr("Cancel");
+-
+-        const DialogCode cancelbtn = DialogCode(
+-            int(kDialogCodeButton0) + buttonmsgs.size() - 1);
+-
+-        DialogCode ret = MythPopupBox::ShowButtonPopup(GetMythMainWindow(),
+-                                tr("Media Handler Selection"),
+-                                tr("The new media contains mixed content "
+-                                   "that can be rendered in different ways. "
+-                                   "Select your preferred method."),
+-                                buttonmsgs, cancelbtn);
+-        if (kDialogCodeRejected == ret || cancelbtn == ret)
+-        {
+-            LOG(VB_MEDIA, LOG_INFO, "User cancelled media handler selection");
+-            return;
+-        }
+-
+-        selected = MythDialog::CalcItemIndex(ret);
+-        LOG(VB_MEDIA, LOG_NOTICE, QString("User selected '%1'")
+-            .arg(handlers.at(selected).destination) );
+-    }
+ 
+     handlers.at(selected).callback(pMedia);
+ }
-- 
cgit v0.12