From ce712e7bd30f2e578c9a3b5a99aa6f1e35d990de Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 30 Jan 2019 21:49:11 +0000
Subject: libxml2: update to 2.9.9

---
 abs/core/libxml2/PKGBUILD                             | 19 ++++++++++---------
 .../libxml2/libxml2-2.9.4-remove-pyverify_fd.patch    | 12 ------------
 2 files changed, 10 insertions(+), 21 deletions(-)
 delete mode 100644 abs/core/libxml2/libxml2-2.9.4-remove-pyverify_fd.patch

diff --git a/abs/core/libxml2/PKGBUILD b/abs/core/libxml2/PKGBUILD
index 2ab74b4..594b4ef 100644
--- a/abs/core/libxml2/PKGBUILD
+++ b/abs/core/libxml2/PKGBUILD
@@ -1,31 +1,30 @@
-# $Id$
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
 # Maintainer: Jan de Groot <jgc@archlinux.org>
 # Contributor: Tom Gundersen <teg@jklm.no>
 # Contributor: John Proctor <jproctor@prium.net>
 
 pkgname=libxml2
-pkgver=2.9.8
+pkgver=2.9.9
 pkgrel=1
-pkgdesc="XML parsing library, version 2"
-url="http://www.xmlsoft.org/"
+pkgdesc='XML parsing library, version 2'
+url='http://www.xmlsoft.org/'
 arch=(x86_64)
 license=(MIT)
 depends=(zlib readline ncurses xz icu)
 makedepends=(python2 python git)
-_commit=18890f471c420411aa3c989e104d090966ec9dbf  # tags/v2.9.8^0
-source=(git+https://git.gnome.org/browse/libxml2#commit=$_commit
+_commit=f8a8c1f59db355b46962577e7b74f1a1e8149dc6  # tags/v2.9.9^0
+source=("git+https://git.gnome.org/browse/libxml2#commit=$_commit"
         https://www.w3.org/XML/Test/xmlts20130923.tar.gz)
 sha256sums=('SKIP'
             '9b61db9f5dbffa545f4b8d78422167083a8568c59bd1129f94138f936cf6fc1f')
 
 pkgver() {
   cd $pkgname
-  git describe --tags | sed 's/-rc/rc/;s/^v//;s/-/+/g'
+  git describe --always --tags | sed 's/-rc/rc/;s/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
 }
 
 prepare() {
   mkdir build-py{2,3}
-
   cd $pkgname
   NOCONFIGURE=1 ./autogen.sh
 }
@@ -57,5 +56,7 @@ check() {
 package() {
   make -C build-py2 DESTDIR="$pkgdir" install
   make -C build-py3/python DESTDIR="$pkgdir" install
-  install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 build-py2/COPYING
+  install -Dm 644 build-py2/COPYING -t "$pkgdir/usr/share/licenses/$pkgname"
 }
+
+# vim: ts=2 sw=2 et:
diff --git a/abs/core/libxml2/libxml2-2.9.4-remove-pyverify_fd.patch b/abs/core/libxml2/libxml2-2.9.4-remove-pyverify_fd.patch
deleted file mode 100644
index d05d4cb..0000000
--- a/abs/core/libxml2/libxml2-2.9.4-remove-pyverify_fd.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur libxml2-2.9.4.orig/python/types.c libxml2-2.9.4/python/types.c
---- libxml2-2.9.4.orig/python/types.c	2016-02-09 03:17:33.000000000 -0700
-+++ libxml2-2.9.4/python/types.c	2016-12-21 12:34:06.755650986 -0700
-@@ -31,8 +31,6 @@
-     const char *mode;
- 
-     fd = PyObject_AsFileDescriptor(f);
--    if (!_PyVerify_fd(fd))
--        return(NULL);
-     /*
-      * Get the flags on the fd to understand how it was opened
-      */
-- 
cgit v0.12