From f79a2ecd618927f642f36d4d5f827ac208a6528c Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 6 Apr 2014 01:09:51 +0000
Subject: libxcb: initial inclusion. dep of mesa. refs #964

---
 abs/core/libxcb/PKGBUILD                          | 34 +++++++++++++++--------
 abs/core/libxcb/__changelog                       |  1 +
 abs/core/libxcb/libxcb-1.1-no-pthread-stubs.patch |  4 +--
 3 files changed, 25 insertions(+), 14 deletions(-)
 create mode 100644 abs/core/libxcb/__changelog

diff --git a/abs/core/libxcb/PKGBUILD b/abs/core/libxcb/PKGBUILD
index c656433..990dbe8 100644
--- a/abs/core/libxcb/PKGBUILD
+++ b/abs/core/libxcb/PKGBUILD
@@ -1,34 +1,44 @@
-# $Id: PKGBUILD 168376 2012-10-09 16:18:34Z andyrtr $
+# $Id$
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
 # Maintainer: Jan de Groot <jgc@archlinux.org>
 # Contributor: Alexander Baldeck <alexander@archlinux.org>
 
 pkgname=libxcb
-pkgver=1.9
+pkgver=1.10
 pkgrel=1
 pkgdesc="X11 client-side library"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
 url="http://xcb.freedesktop.org/"
-depends=('xcb-proto>=1.7' 'libxdmcp' 'libxau')
+depends=('xcb-proto>=1.10' 'libxdmcp' 'libxau')
 makedepends=('pkgconfig' 'libxslt' 'python2')
-options=('!libtool')
 license=('custom')
 source=($url/dist/$pkgname-$pkgver.tar.bz2
         libxcb-1.1-no-pthread-stubs.patch)
-sha1sums=('ad2fb95eeec41ba3d39502a4f7460c3b64fdf061'
-          'd2df03ddf3e949c10c2c185256b0eb7fa02837ab')
+sha256sums=('98d9ab05b636dd088603b64229dd1ab2d2cc02ab807892e107d674f9c3f2d5b5'
+            '748ed83af60468a0eb6785222e4a5ca589d28f20b9bfc60d5936ec93b8eef356')
+
+prepare() {
+  cd "$pkgname-$pkgver"
+  patch -Np1 -i ../libxcb-1.1-no-pthread-stubs.patch
+  autoreconf -vfi
+}
 
 build() {
-  cd "$srcdir/$pkgname-$pkgver"
-  patch -Np1 -i "$srcdir/libxcb-1.1-no-pthread-stubs.patch"
-  PYTHON=/usr/bin/python2 
-  ./autogen.sh --prefix=/usr \
+  cd "$pkgname-$pkgver"
+  ./configure --prefix=/usr \
     --enable-xinput \
+    --enable-xkb \
     --disable-static
   make
 }
 
+check() {
+  cd $pkgname-$pkgver
+  make -k check
+}
+
 package() {
-  cd "$srcdir/$pkgname-$pkgver"
+  cd "$pkgname-$pkgver"
   make DESTDIR="$pkgdir" install
   install -m755 -d "$pkgdir/usr/share/licenses/$pkgname"
   install -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname"
diff --git a/abs/core/libxcb/__changelog b/abs/core/libxcb/__changelog
new file mode 100644
index 0000000..8bae7de
--- /dev/null
+++ b/abs/core/libxcb/__changelog
@@ -0,0 +1 @@
+- PKGBUILD: change dep python to python2
diff --git a/abs/core/libxcb/libxcb-1.1-no-pthread-stubs.patch b/abs/core/libxcb/libxcb-1.1-no-pthread-stubs.patch
index 8e8162f..52c22ab 100644
--- a/abs/core/libxcb/libxcb-1.1-no-pthread-stubs.patch
+++ b/abs/core/libxcb/libxcb-1.1-no-pthread-stubs.patch
@@ -1,9 +1,9 @@
 --- libxcb-1.8.1/configure.ac	2012-03-09 15:38:38.000000000 +0100
 +++ libxcb-1.8.1/configure.ac.new	2012-03-09 16:50:40.107109896 +0100
-@@ -35,7 +35,7 @@
+@@ -43,7 +43,7 @@
  
  # Checks for pkg-config packages
- PKG_CHECK_MODULES(XCBPROTO, xcb-proto >= 1.7)
+ PKG_CHECK_MODULES(XCBPROTO, xcb-proto >= 1.10)
 -NEEDED="pthread-stubs xau >= 0.99.2"
 +NEEDED="xau >= 0.99.2"
  PKG_CHECK_MODULES(NEEDED, $NEEDED)
-- 
cgit v0.12