From f0c8e6d055143a66be140172b700d6255dd70b37 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 11 Mar 2019 22:18:01 +0000
Subject: LinHES-system: myth_status.py: add tuner name

---
 abs/core/LinHES-system/PKGBUILD       | 6 +++---
 abs/core/LinHES-system/myth_status.py | 7 ++++---
 2 files changed, 7 insertions(+), 6 deletions(-)

diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index c8d01b3..a236769 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
-pkgver=8.5.2
-pkgrel=4
+pkgver=8.6.0
+pkgrel=1
 arch=('x86_64')
 install=system.install
 pkgdesc="Everything that makes LinHES an automated system"
@@ -91,7 +91,7 @@ md5sums=('c6e6b83a1f4c35ef4501e277657ab2ac'
          '542e670e78d117657f93141e9689f54d'
          '8da6a7f1703a002f84e66629e847d8a6'
          'bb72ab230c7a71706285bd0f31a4fb1f'
-         '14352e6d2cd3ed4206b1dff4ff35880d'
+         'c25915a9c5382122f849a3a11b943010'
          '962a3e9eaba2d1466251b7ab0956705d'
          '1758aed160de64abfafb28a3a8f3390e'
          '33fbebbd546672cedd3c5e7350ab414e'
diff --git a/abs/core/LinHES-system/myth_status.py b/abs/core/LinHES-system/myth_status.py
index cd541ca..63328d0 100644
--- a/abs/core/LinHES-system/myth_status.py
+++ b/abs/core/LinHES-system/myth_status.py
@@ -144,11 +144,12 @@ class tuner_recording_status:
         a=self.be.getRecorderList()
         for i in a:
             outline=''
-            cmd="select cardtype,hostname  from capturecard where cardid=%s;" %i
+            cmd="select cardtype,hostname,displayname  from capturecard where cardid=%s;" %i
             self.cursor.execute(cmd)
             results=self.cursor.fetchall()
             type = results[0][0]
             hostname = results[0][1]
+            displayname = results[0][2]
             id = i
             try:
                 c=self.be.getCurrentRecording(i)
@@ -156,10 +157,10 @@ class tuner_recording_status:
                     current_recording = "Idle"
                 else:
                     current_recording = "Recording %s" %c.title
-                outline = "    Tuner %s (%s) on %s : %s " %(id, type, hostname, current_recording)
+                outline = "    Tuner %s - %s (%s) on %s : %s " %(id, displayname, type, hostname, current_recording)
                 self.tuner_status_list.append(outline)
             except:
-                outline = "    Tuner %s (%s) on %s : %s " %(id, type, hostname, "Tuner Error")
+                outline = "    Tuner %s - %s (%s) on %s : %s " %(id, displayname, type, hostname, "Tuner Error")
                 self.tuner_status_list.append(outline)
 
     def get_tuner_status(self):
-- 
cgit v0.12