From 48c7caf0470b8693b849ac13454fdac4a697e812 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 16 Feb 2014 18:08:18 -0600
Subject: filesystem: 2013_05 update binary path to /usr/bin refs #961

---
 abs/core/filesystem/PKGBUILD           | 61 ++++++++++++++++++++++------------
 abs/core/filesystem/__changelog        |  3 --
 abs/core/filesystem/archlinux.7.txt    | 60 +++++++++++++++++++--------------
 abs/core/filesystem/filesystem.install | 17 +++-------
 abs/core/filesystem/fstab              |  1 -
 abs/core/filesystem/group              |  2 ++
 abs/core/filesystem/gshadow            |  4 ++-
 abs/core/filesystem/os-release         | 12 +++----
 abs/core/filesystem/passwd             |  1 +
 abs/core/filesystem/profile            |  2 +-
 abs/core/filesystem/securetty          |  2 +-
 abs/core/filesystem/shadow             |  1 +
 12 files changed, 93 insertions(+), 73 deletions(-)
 delete mode 100644 abs/core/filesystem/__changelog

diff --git a/abs/core/filesystem/PKGBUILD b/abs/core/filesystem/PKGBUILD
index 1bce61a..ad62704 100644
--- a/abs/core/filesystem/PKGBUILD
+++ b/abs/core/filesystem/PKGBUILD
@@ -1,24 +1,24 @@
-# $Id: PKGBUILD 169662 2012-10-25 10:06:29Z tomegun $
+# $Id: PKGBUILD 187026 2013-06-03 11:15:07Z allan $
 # Maintainer: Tom Gundersen <teg@jklm.no>
 
 pkgname=filesystem
-pkgver=2012.10
-pkgrel=2
+pkgver=2013.05
+pkgrel=3
 pkgdesc='Base filesystem'
-arch=('any')
+arch=('i686' 'x86_64')
 license=('GPL')
 url='http://www.archlinux.org'
 groups=('base')
 install='filesystem.install'
 makedepends=('asciidoc')
-depends=('iana-etc' 'bash' 'coreutils' 'nss-myhostname')
+depends=('iana-etc')
 backup=('etc/fstab' 'etc/crypttab' 'etc/group' 'etc/hosts' 'etc/ld.so.conf' 'etc/passwd'
         'etc/shadow' 'etc/gshadow' 'etc/resolv.conf' 'etc/motd' 'etc/nsswitch.conf'
         'etc/shells' 'etc/host.conf' 'etc/securetty' 'etc/profile' 'etc/issue')
-source=('group'  'nsswitch.conf' 'securetty' 'host.conf' 'ld.so.conf'
+source=('group' 'issue' 'nsswitch.conf' 'securetty' 'host.conf' 'ld.so.conf'
         'passwd' 'shadow' 'fstab' 'crypttab' 'hosts' 'motd' 'os-release' 'resolv.conf'
         'shells' 'gshadow' 'profile' 'modprobe.d.usb-load-ehci-first' 'archlinux.7.txt'
-	'locale.sh')
+        'locale.sh')
 
 build() {
 	cd ${srcdir}
@@ -31,7 +31,7 @@ package() {
 	#
 	# setup root filesystem
 	#
-	for d in boot dev etc home media mnt usr var opt srv/http run; do
+	for d in boot dev etc home mnt usr var opt srv/http run; do
 		install -d -m755 ${d}
 	done
 	install -d -m555 proc
@@ -43,7 +43,7 @@ package() {
 
 	# setup /etc
 	install -d etc/{ld.so.conf.d,skel,profile.d}
-	for f in fstab group host.conf hosts  ld.so.conf motd nsswitch.conf os-release passwd resolv.conf securetty shells profile; do
+	for f in fstab group host.conf hosts issue ld.so.conf motd nsswitch.conf os-release passwd resolv.conf securetty shells profile; do
 		install -m644 ${srcdir}/${f} etc/
 	done
 	ln -s /proc/self/mounts etc/mtab
@@ -65,10 +65,10 @@ package() {
 	ln -s ../run var/run
 	ln -s ../run/lock var/lock
 
-	#
-	# setup /usr hierarchy
-	#
-	for d in bin include lib sbin share/misc src; do
+	
+	#setup /usr hierarchy
+	
+	for d in bin include lib share/misc src; do
 		install -d -m755 usr/${d}
 	done
 	for d in $(seq 8); do
@@ -76,6 +76,22 @@ package() {
 	done
 
 	#
+	# add lib symlinks
+	#
+	ln -s usr/lib ${pkgdir}/lib
+	[[ ${CARCH} = "x86_64" ]] && ( 
+		ln -s usr/lib ${pkgdir}/lib64
+		ln -s lib ${pkgdir}/usr/lib64
+	)
+
+# 	#
+# 	# add bin symlinks
+# 	#
+  	ln -s usr/bin ${pkgdir}/bin
+  	ln -s usr/bin ${pkgdir}/sbin
+  	ln -s bin ${pkgdir}/usr/sbin
+
+	#
 	# install archlinux(7) manpage
 	#
 	install -D -m644 ${srcdir}/archlinux.7 usr/share/man/man7/archlinux.7
@@ -88,22 +104,23 @@ package() {
 	done
 	ln -s ../man usr/local/share/man
 }
-md5sums=('004013ac940ef3d3cdd8c596e7accfe1'
+md5sums=('7b8e40f8f793e60f471511641bb1c9f2'
+         '7813c481156f6b280a3ba91fc6236368'
          '9e4533df61f0c82d6b2e2371f7376282'
-         'f833071f3b4c1e1033770c0ef30da0a4'
+         '4c4540eeb748bf1f71d631b8c1dcf0b3'
          'f28150d4c0b22a017be51b9f7f9977ed'
          '6e488ffecc8ba142c0cf7e2d7aeb832e'
-         '455b78cada80f40b6f6968f5cbd97a2e'
-         '01249bb0ba4468f95e2cc3a627f5e6e3'
-         'ca716f853860199c1286e7939b2f2666'
+         '1cfd310dff0804a7d21958487c32a3b1'
+         '2ef2429c2c98d0883906aa6f5363be80'
+         '693c97f2c9a519bb97a17008e92c2b74'
          '1745349eb24ed21b4cfaa6f423bddb76'
          '7bc65f234dfb6abf24e7c3b03e86f4ff'
          'd41d8cd98f00b204e9800998ecf8427e'
-         'c1e795aa3bae70bf0fb76b8a720e4825'
+         'b16a4674ccf3a932ff34c6c8393a4f33'
          '6f48288b6fcaf0065fcb7b0e525413e0'
          '22518e922891f9359f971f4f5b4e793c'
-         '677523dbe94b79299aa91b35ed8203b6'
-         'f3b6ae7db8adffaaa4bffc6099dcbd50'
+         'f45389e116ab0b9e9968287617d27c7d'
+         '0b6f835598c7640184e476057b3c7722'
          'a8a962370cd0128465d514e6a1f74130'
-         'f339bbc45ff3ad4dd73039beab2f28e3'
+         '2e193c4a37245f2323ebe87f1a673563'
          '3807d07215d9116331fe1cf8feeaa0f8')
diff --git a/abs/core/filesystem/__changelog b/abs/core/filesystem/__changelog
deleted file mode 100644
index b68b199..0000000
--- a/abs/core/filesystem/__changelog
+++ /dev/null
@@ -1,3 +0,0 @@
-added tty10 to securetty
-os-release
-remove issue
diff --git a/abs/core/filesystem/archlinux.7.txt b/abs/core/filesystem/archlinux.7.txt
index 74eee59..b46ab05 100644
--- a/abs/core/filesystem/archlinux.7.txt
+++ b/abs/core/filesystem/archlinux.7.txt
@@ -14,66 +14,76 @@ Overview of the basic configuration of Arch Linux.
 
 DESCRIPTION
 -----------
-Arch Linux exposes the user to the system without hiding any details. This manpage gives a
-brief overview of the configuration files that should be set up on a fresh install.
+Arch Linux exposes the user to the system without hiding any details.
+This man page gives a brief overview of the configuration files that should be set up on a fresh install.
 
 SYSTEM SERVICES[[S]]
 --------------------
-System services to be started at boot can be enabled using 'systemctl enable <name>.service'. To view
-available services use 'systemctl list-unit-files'.
+System services to be started at boot can be enabled using 'systemctl enable <name>'.
+To view available services, use 'systemctl list-unit-files'.
 
 HOSTNAME[[H]]
 -------------
-The hostname of the machine can be set using 'hostnamectl set-hostname <hostname>'. It will then be
-written to /etc/hostname.
+The hostname of the machine can be set using 'hostnamectl set-hostname <hostname>'.
+It will then be written to /etc/hostname.
 
 LOCALIZATION[[L]]
 -----------------
-Various locales may be enabled in /etc/locale.gen, and generated by locale-gen. The system-wide locale to be used
-can be configured in /etc/locale.conf. These settings can be overridden on a per-user basis by keeping a
-user-specific locale.conf in $HOME/.config/locale.conf. The user-specific file will take precedence if it exists.
+Various locales may be enabled in /etc/locale.gen and are generated by 'locale-gen'.
+The system-wide locale to be used can be configured in /etc/locale.conf.
+These settings can be overridden on a per-user basis by keeping a user-specific locale.conf in $HOME/.config/locale.conf.
+The user-specific file will take precedence if it exists.
 
 VIRTUAL CONSOLE[[V]]
 --------------------
-The virtual console is configured in /etc/vconsole.conf. It allows you to set a font and a keyboard layout, among
-other things. Note that these settings only apply to the console, and not if you use X.
+The virtual console is configured in /etc/vconsole.conf.
+It allows you to set a font and a keyboard layout, among other things.
+Note that these settings only apply to the console and do not apply if you use X.
 
 TIME[[T]]
 ---------
-The local timezone is configured by calling 'timedatectl set-timezone <Region/City>'. A *symlink* is then created
-from /etc/localtime to the correct zoneinfo file under /usr/share/zoneinfo/. E.g.,
+The local time zone is configured by calling 'timedatectl set-timezone <Region/City>'.
+A relative *symlink* is then created from /etc/localtime to the correct zoneinfo file under /usr/share/zoneinfo/. For example,
 
     /etc/localtime -> ../usr/share/zoneinfo/Europe/Paris
 
 The real-time clock, which keeps track of time when the computer is off, can be configured to either
-be in UTC or in localtime by calling 'timedatectl set-local-rtc <false|true>'. The default is UTC.
+be in UTC or in local time by calling 'timedatectl set-local-rtc <false|true>'.
+The default is UTC.
 
-FILESYSTEMS[[F]]
-----------------
-Filesystems are configured in /etc/fstab, and encryption mappings are configured in /etc/crypttab.
+FILE SYSTEMS[[F]]
+-----------------
+File systems are configured in /etc/fstab, and encryption mappings are configured in /etc/crypttab.
 
 INITRAMFS[[R]]
 --------------
-The initramfs is generated by mkinitcpio, and can be configured in /etc/mkinitcpio.conf.
+The initramfs is generated by 'mkinitcpio -p <preset>'.
+The default preset is "linux".
+The initramfs can be configured in /etc/mkinitcpio.conf and must be regenerated after making configuration changes.
 
 PACKAGE MANAGER[[P]]
 --------------------
 The package manager, pacman, is configured in /etc/pacman.conf.
 
-BOOTLOADER[[B]]
----------------
-GRUB's configuration is generated from /etc/default/grub by grub-mkconfig. Syslinux is configured in /boot/syslinux/syslinux.cfg
+BOOT LOADER[[B]]
+----------------
+GRUB's configuration is generated from /etc/default/grub by 'grub-mkconfig -o /boot/grub/grub.cfg'.
+Syslinux is configured in /boot/syslinux/syslinux.cfg.
 
 MODULES[[M]]
 ------------
-Most modules should be loaded on-demand. Modules to be unconditionally loaded at boot can be specified in /etc/modules-load.d/,
-and modules to be blacklisted from auto-loading can be configured in /etc/modprobe.d/.
+Most modules should be loaded on-demand.
+Modules to be unconditionally loaded at boot can be specified in /etc/modules-load.d/,
+and modules to be blacklisted from automatically loading can be configured in /etc/modprobe.d/.
 
 SEE ALSO
 --------
 
-systemctl(1), hostnamectl(1), hostname(5), locale.conf(5), vconsole.conf(5), timedatectl(1), timezone(3), hwclock(8), fstab(5),
-crypttab(5), mkinitcpio(8), pacman(8), pacman.conf(5), grub-mkconfig(8), syslinux(1), modules-load.d(5), modprobe.d(5)
+*systemctl*(1), *hostnamectl*(1), *hostname*(5), *locale.conf*(5),
+*vconsole.conf*(5), *timedatectl*(1), *timezone*(3), *hwclock*(8),
+*fstab*(5), *crypttab*(5), *mkinitcpio*(8), *pacman*(8), *pacman.conf*(5),
+*grub-mkconfig*(8), *syslinux*(1), *modules-load.d*(5), *modprobe.d*(5),
+*systemd*(1)
 
 AUTHORS
 -------
diff --git a/abs/core/filesystem/filesystem.install b/abs/core/filesystem/filesystem.install
index 34fcc0d..c043744 100644
--- a/abs/core/filesystem/filesystem.install
+++ b/abs/core/filesystem/filesystem.install
@@ -1,13 +1,3 @@
-post_install() {
-	[ -f var/log/lastlog ] ||   : >var/log/lastlog
-	[ -f var/log/wtmp ]    ||   : >var/log/wtmp
-	[ -f var/log/btmp ]    || { : >var/log/btmp && chmod 600 var/log/btmp; }
-	# workaround for bug #7194
-	# readded due to bug #9465
-	# please do not remove!
-	chmod 1777 var/spool/mail tmp var/tmp
-}
-
 # args: <group> [options]
 _addgroup() {
 	if ! getent group "$1" >/dev/null; then
@@ -23,8 +13,6 @@ _adduser() {
 }
 
 post_upgrade() {
-	post_install
-
 	_addgroup optical -g 93
 	_addgroup audio   -g 92
 	_addgroup video   -g 91
@@ -42,7 +30,10 @@ post_upgrade() {
 	_addgroup rfkill  -g 24
 	_addgroup lock    -g 54
 	_addgroup uuidd   -g 68
-	_adduser uuidd   -u 68 -d / -g uuidd -s /sbin/nologin
+	_adduser uuidd    -u 68 -d / -g uuidd -s /sbin/nologin
+	_addgroup dbus    -g 81
+	_adduser dbus     -u 81 -d / -g dbus -s /sbin/nologin
+	_addgroup systemd-journal -g 190
 
 	# sync gshadow to group (fixes FS#19869)
 	if ! grep -q '^lock:' etc/gshadow; then
diff --git a/abs/core/filesystem/fstab b/abs/core/filesystem/fstab
index f7f9298..b6716c1 100644
--- a/abs/core/filesystem/fstab
+++ b/abs/core/filesystem/fstab
@@ -2,4 +2,3 @@
 # /etc/fstab: static file system information
 #
 # <file system>	<dir>	<type>	<options>	<dump>	<pass>
-tmpfs		/tmp	tmpfs	nodev,nosuid	0	0
diff --git a/abs/core/filesystem/group b/abs/core/filesystem/group
index cfee1f2..6c91b29 100644
--- a/abs/core/filesystem/group
+++ b/abs/core/filesystem/group
@@ -21,6 +21,7 @@ http:x:33:
 games:x:50:
 lock:x:54:
 uuidd:x:68:
+dbus:x:81:
 network:x:90:
 video:x:91:
 audio:x:92:
@@ -31,3 +32,4 @@ scanner:x:96:
 power:x:98:
 nobody:x:99:
 users:x:100:
+systemd-journal:x:190:
diff --git a/abs/core/filesystem/gshadow b/abs/core/filesystem/gshadow
index c5ac185..fb475bf 100644
--- a/abs/core/filesystem/gshadow
+++ b/abs/core/filesystem/gshadow
@@ -20,7 +20,8 @@ smmsp:::
 http:::
 games:::
 lock:::
-uuidd:!::
+uuidd:x::
+dbus:x::
 network:x::
 video:x::
 audio:::
@@ -31,3 +32,4 @@ scanner:x::
 power:x::
 nobody:::
 users:::
+systemd-journal:x::
diff --git a/abs/core/filesystem/os-release b/abs/core/filesystem/os-release
index c36b91c..09bc7de 100644
--- a/abs/core/filesystem/os-release
+++ b/abs/core/filesystem/os-release
@@ -1,8 +1,8 @@
-NAME="LinHES"
-ID=linhes
-PRETTY_NAME="LinHES The Home Entertainment System"
+NAME="Arch Linux"
+ID=arch
+PRETTY_NAME="Arch Linux"
 ANSI_COLOR="0;36"
-HOME_URL="http://www.linhes.org/"
-SUPPORT_URL="http://forum.archlinux.org/"
-BUG_REPORT_URL="http://bugs.linhes.org/"
+HOME_URL="https://www.archlinux.org/"
+SUPPORT_URL="https://bbs.archlinux.org/"
+BUG_REPORT_URL="https://bugs.archlinux.org/"
 
diff --git a/abs/core/filesystem/passwd b/abs/core/filesystem/passwd
index cb9fec7..671fc48 100644
--- a/abs/core/filesystem/passwd
+++ b/abs/core/filesystem/passwd
@@ -5,4 +5,5 @@ mail:x:8:12:mail:/var/spool/mail:/bin/false
 ftp:x:14:11:ftp:/srv/ftp:/bin/false
 http:x:33:33:http:/srv/http:/bin/false
 uuidd:x:68:68:uuidd:/:/sbin/nologin
+dbus:x:81:81:dbus:/:/sbin/nologin
 nobody:x:99:99:nobody:/:/bin/false
diff --git a/abs/core/filesystem/profile b/abs/core/filesystem/profile
index 3bc22db..59d0abc 100644
--- a/abs/core/filesystem/profile
+++ b/abs/core/filesystem/profile
@@ -4,7 +4,7 @@
 umask 022
 
 # Set our default path
-PATH="/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin"
+PATH="/usr/local/sbin:/usr/local/bin:/usr/bin"
 export PATH
 
 # Load profiles from /etc/profile.d
diff --git a/abs/core/filesystem/securetty b/abs/core/filesystem/securetty
index 5cc27d8..5a2235c 100644
--- a/abs/core/filesystem/securetty
+++ b/abs/core/filesystem/securetty
@@ -11,5 +11,5 @@ tty5
 tty6
 ttyS0
 hvc0
-tty10
+
 # End of file
diff --git a/abs/core/filesystem/shadow b/abs/core/filesystem/shadow
index 5eff493..39ebb13 100644
--- a/abs/core/filesystem/shadow
+++ b/abs/core/filesystem/shadow
@@ -5,4 +5,5 @@ mail:x:14871::::::
 ftp:x:14871::::::
 http:x:14871::::::
 uuidd:x:14871::::::
+dbus:x:14871::::::
 nobody:x:14871::::::
-- 
cgit v0.12