From ca895f031111dca13b1381ba20049b0b8a84b097 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 5 Sep 2013 16:17:58 -0500
Subject: pacman: revert down to 4.1.0 due to execv error

---
 abs/core/pacman/PKGBUILD     | 41 +++++++++++++++++------------------------
 abs/core/pacman/makepkg.conf | 11 ++++-------
 2 files changed, 21 insertions(+), 31 deletions(-)

diff --git a/abs/core/pacman/PKGBUILD b/abs/core/pacman/PKGBUILD
index bc88ebb..63ee374 100644
--- a/abs/core/pacman/PKGBUILD
+++ b/abs/core/pacman/PKGBUILD
@@ -4,34 +4,34 @@
 # Maintainer: Dave Reisner <dreisner@archlinux.org>
 
 pkgname=pacman
-pkgver=4.1.2
+pkgver=4.1.0
 pkgrel=1
 pkgdesc="A library-based package manager with dependency support"
 arch=('i686' 'x86_64')
 url="http://www.archlinux.org/pacman/"
 license=('GPL')
 groups=('base' 'base-devel')
-depends=('bash>=4.2.042-2' 'glibc>=2.16' 'libarchive>=3.1.2' 'curl>=7.19.4'
+depends=('bash' 'glibc>=2.15' 'libarchive>=3.1.2' 'curl>=7.19.4'
          'gpgme' 'pacman-mirrorlist' 'archlinux-keyring')
-#checkdepends=('python2' 'fakechroot')
+makedepends=('asciidoc')
+checkdepends=('fakechroot')
 optdepends=('fakeroot: for makepkg usage as normal user')
-provides=('pacman-contrib')
-conflicts=('pacman-contrib')
-replaces=('pacman-contrib')
 backup=(etc/pacman.conf etc/makepkg.conf)
 install=pacman.install
 options=(!libtool)
 source=(ftp://ftp.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig}
         pacman.conf.x86_64
         makepkg.conf)
+md5sums=('a0f2b3148bee4784f21cf373cf59a0bc'
+         '4959b8d00056398195f4e549e7bdd346'
+         'de74a13618347f08ae4a9637f74471c4'
+         '2ea6f0a5badef735ec7d30a372f5e9c6')
 
 build() {
   cd $srcdir/$pkgname-$pkgver
 
   ./configure --prefix=/usr --sysconfdir=/etc \
-    --localstatedir=/var --enable-doc \
-    --with-scriptlet-shell=/usr/bin/bash \
-    --with-ldconfig=/usr/bin/ldconfig
+    --localstatedir=/var --enable-doc
   make
   make -C contrib
 }
@@ -43,19 +43,18 @@ check() {
 package() {
   cd $srcdir/$pkgname-$pkgver
   make DESTDIR=$pkgdir install
-  make DESTDIR=$pkgdir -C contrib install
 
   # install Arch specific stuff
-  install -dm755 $pkgdir/etc
-  install -m644 $srcdir/pacman.conf.$CARCH $pkgdir/etc/pacman.conf
-  
+  mkdir -p $pkgdir/etc
   case "$CARCH" in
-    i686)    
+    i686)
+      install -m644 $srcdir/pacman.conf.i686 $pkgdir/etc/pacman.conf
       mycarch="i686"
       mychost="i686-pc-linux-gnu"
       myflags="-march=i686"
       ;;
     x86_64)
+      install -m644 $srcdir/pacman.conf.x86_64 $pkgdir/etc/pacman.conf
       mycarch="x86_64"
       mychost="x86_64-unknown-linux-gnu"
       myflags="-march=x86-64"
@@ -67,18 +66,12 @@ package() {
     -e "s|@CARCH[@]|$mycarch|g" \
     -e "s|@CHOST[@]|$mychost|g" \
     -e "s|@CARCHFLAGS[@]|$myflags|g"
-    
-  # put bash_completion in the right location
-  install -dm755 ${pkgdir}/usr/share/bash-completion/completions
-  mv ${pkgdir}/etc/bash_completion.d/pacman \
-    ${pkgdir}/usr/share/bash-completion/completions
-  rmdir ${pkgdir}/etc/bash_completion.d
 
+  # install completion files
+  install -Dm644 contrib/bash_completion "$pkgdir/usr/share/bash-completion/completions/pacman"
   for f in makepkg pacman-key; do
     ln -s pacman "$pkgdir/usr/share/bash-completion/completions/$f"
   done
+
+  install -Dm644 contrib/zsh_completion $pkgdir/usr/share/zsh/site-functions/_pacman
 }
-md5sums=('063c8b0ff6bdf903dc235445525627cd'
-         '7e46c2654b016fc1de45499a537cb990'
-         'de74a13618347f08ae4a9637f74471c4'
-         '5f360e003e95f1a5cbd6e60d937dfd25')
diff --git a/abs/core/pacman/makepkg.conf b/abs/core/pacman/makepkg.conf
index dc58009..dfec258 100644
--- a/abs/core/pacman/makepkg.conf
+++ b/abs/core/pacman/makepkg.conf
@@ -11,7 +11,7 @@
 DLAGENTS=('ftp::/usr/bin/curl -fC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
           'http::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u'
           'https::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u'
-          'rsync::/usr/bin/rsync --no-motd -z %u %o'
+          'rsync::/usr/bin/rsync -z %u %o'
           'scp::/usr/bin/scp -C %u %o')
 
 # Other common tools:
@@ -36,8 +36,8 @@ LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro"
 #-- Make Flags: change this for DistCC/SMP systems
 #MAKEFLAGS="-j2"
 #-- Debugging flags
-DEBUG_CFLAGS="-g -fvar-tracking-assignments"
-DEBUG_CXXFLAGS="-g -fvar-tracking-assignments"
+#DEBUG_CFLAGS="-g -fvar-tracking-assignments"
+#DEBUG_CXXFLAGS="-g -fvar-tracking-assignments"
 
 #########################################################################
 # BUILD ENVIRONMENT
@@ -109,8 +109,6 @@ PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
 #SRCDEST=/home/sources
 #-- Source packages: specify a fixed directory where all src packages will be placed
 #SRCPKGDEST=/home/srcpackages
-#-- Log files: specify a fixed directory where all log files will be placed
-#LOGDEST=/home/makepkglogs
 #-- Packager: name/email of the person or organization building packages
 #PACKAGER="John Doe <john@doe.com>"
 #-- Specify a key to use for package signing
@@ -123,10 +121,9 @@ PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
 COMPRESSGZ=(gzip -c -f -n)
 COMPRESSBZ2=(bzip2 -c -f)
 COMPRESSXZ=(xz -c -z -)
-COMPRESSLRZ=(lrzip -q)
-COMPRESSLZO=(lzop -q)
 COMPRESSZ=(compress -c -f)
 
+
 #########################################################################
 # EXTENSION DEFAULTS
 #########################################################################
-- 
cgit v0.12