From 8f90ef8c34ed7568a58f6021126f59ed27f60307 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 31 Jan 2019 19:00:46 +0000
Subject: gobject-introspection: update to 1.58.3

---
 abs/core/gobject-introspection/PKGBUILD | 66 ++++++++++++++++++++-------------
 1 file changed, 40 insertions(+), 26 deletions(-)

diff --git a/abs/core/gobject-introspection/PKGBUILD b/abs/core/gobject-introspection/PKGBUILD
index 9f5edfa..2316aa6 100644
--- a/abs/core/gobject-introspection/PKGBUILD
+++ b/abs/core/gobject-introspection/PKGBUILD
@@ -1,41 +1,55 @@
-# $Id$
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
 # Maintainer: Jan de Groot <jgc@archlinux.org>
 
 pkgbase=gobject-introspection
-pkgname=('gobject-introspection' 'gobject-introspection-runtime')
-pkgver=1.46.0
+pkgname=(gobject-introspection gobject-introspection-runtime)
+pkgver=1.58.3
 pkgrel=1
-url="https://live.gnome.org/GObjectIntrospection"
-arch=('x86_64' 'i686')
-license=('LGPL' 'GPL')
-makedepends=('cairo' 'python2' 'python2-mako')
-source=(https://download.gnome.org/sources/$pkgbase/${pkgver:0:4}/$pkgbase-$pkgver.tar.xz)
-sha256sums=('6658bd3c2b8813eb3e2511ee153238d09ace9d309e4574af27443d87423e4233')
+pkgdesc="Introspection system for GObject-based libraries"
+url="https://wiki.gnome.org/Projects/GObjectIntrospection"
+arch=(x86_64)
+license=(LGPL GPL)
+depends=(python python-mako)
+makedepends=(cairo git gtk-doc python-sphinx meson)
+options=(!emptydirs)
+_commit=96e0b3f92624937093f0c683db6968bc53c694eb  # tags/1.58.3^0
+source=("git+https://gitlab.gnome.org/GNOME/gobject-introspection.git#commit=$_commit")
+sha512sums=('SKIP')
 
-prepare() {
-  cd $pkgbase-$pkgver
-  sed -i '1s|#!/usr/bin/env python$|&2|' giscanner/*.py
+pkgver() {
+  cd $pkgbase
+  git describe --tags | sed 's/-/+/g'
 }
 
+prepare() {
+  cd $pkgbase
+}
+  
 build() {
-  cd $pkgbase-$pkgver
-  PYTHON=/usr/bin/python2 ./configure --prefix=/usr --disable-static --enable-doctool
-  make
+  arch-meson $pkgbase build -D cairo=true -D gtk-doc=true
+  ninja -C build
 }
 
-package_gobject-introspection-runtime() {
-  pkgdesc="Introspection system for GObject-based libraries - runtime files"
-  depends=('glib2')
-  cd $pkgbase-$pkgver
-  make DESTDIR="$pkgdir" install-libLTLIBRARIES install-typelibsDATA
+check() {
+  meson test -C build
 }
 
 package_gobject-introspection() {
-  pkgdesc="Introspection system for GObject-based libraries"
-  depends=("gobject-introspection-runtime=$pkgver" 'python2-mako' 'python2')
-  options=('!emptydirs')
+  depends+=("gobject-introspection-runtime=$pkgver-$pkgrel")
+
+  DESTDIR="$pkgdir" meson install -C build
+
+  python -m compileall -d /usr/lib/gobject-introspection "$pkgdir/usr/lib/gobject-introspection"
+  python -O -m compileall -d /usr/lib/gobject-introspection "$pkgdir/usr/lib/gobject-introspection"
+
+### Split runtime
+  mkdir -p "$srcdir/runtime/lib"
+  mv "$pkgdir"/usr/lib/{lib*,girepository-*} "$srcdir/runtime/lib"
+}
+
+package_gobject-introspection-runtime() {
+  pkgdesc+=" (runtime library)"
+  depends=(glib2)
 
-  cd $pkgbase-$pkgver
-  make DESTDIR="$pkgdir" install
-  make DESTDIR="$pkgdir" uninstall-libLTLIBRARIES uninstall-typelibsDATA
+  mv "$srcdir/runtime" "$pkgdir/usr"
 }
-- 
cgit v0.12