From 9c2d818e627d8763a22d860b8f1d8977aa853102 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 30 Apr 2014 18:03:49 +0000
Subject: llvm: update to 3.4

---
 abs/extra/llvm/PKGBUILD                            | 190 ++++++++++++---------
 abs/extra/llvm/bug-9869-operator-h-c++0x.patch     |  57 -------
 abs/extra/llvm/cindexer-clang-path.patch           |  10 --
 .../clang-3.1-fix-libprofile_rt.a-location.patch   |  12 --
 abs/extra/llvm/clang-3.3-use-gold-linker.patch     |  12 ++
 abs/extra/llvm/clang-plugin-loader-registry.patch  |  11 --
 abs/extra/llvm/clang-pure64.patch                  |  13 --
 abs/extra/llvm/clang-toolchains-gcc-versions.patch |  12 --
 abs/extra/llvm/enable-lto.patch                    |  32 ----
 abs/extra/llvm/llvm-3.1-2.src.tar.gz               |   1 -
 10 files changed, 122 insertions(+), 228 deletions(-)
 delete mode 100644 abs/extra/llvm/bug-9869-operator-h-c++0x.patch
 delete mode 100644 abs/extra/llvm/cindexer-clang-path.patch
 delete mode 100644 abs/extra/llvm/clang-3.1-fix-libprofile_rt.a-location.patch
 create mode 100644 abs/extra/llvm/clang-3.3-use-gold-linker.patch
 delete mode 100644 abs/extra/llvm/clang-plugin-loader-registry.patch
 delete mode 100644 abs/extra/llvm/clang-pure64.patch
 delete mode 100644 abs/extra/llvm/clang-toolchains-gcc-versions.patch
 delete mode 100644 abs/extra/llvm/enable-lto.patch
 delete mode 120000 abs/extra/llvm/llvm-3.1-2.src.tar.gz

diff --git a/abs/extra/llvm/PKGBUILD b/abs/extra/llvm/PKGBUILD
index 515dbc7..3a837d2 100644
--- a/abs/extra/llvm/PKGBUILD
+++ b/abs/extra/llvm/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 159472 2012-05-24 20:02:15Z foutrelis $
+# $Id$
 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
 # Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
 # Contributor: Sebastian Nowicki <sebnow@gmail.com>
@@ -9,93 +9,63 @@
 # Contributor: Roberto Alsina <ralsina@kde.org>
 # Contributor: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
 
-pkgname=('llvm' 'llvm-ocaml' 'clang' 'clang-analyzer')
-pkgver=3.1
-pkgrel=2
+pkgname=('llvm' 'llvm-libs' 'llvm-ocaml' 'clang' 'clang-analyzer'
+         'clang-tools-extra')
+pkgver=3.4
+pkgrel=1
 arch=('i686' 'x86_64')
 url="http://llvm.org/"
 license=('custom:University of Illinois/NCSA Open Source License')
-makedepends=('libffi' 'python2' 'ocaml')
-source=(http://llvm.org/releases/$pkgver/$pkgname-$pkgver.src.tar.gz
+makedepends=('libffi' 'python2' 'ocaml' 'python2-sphinx')
+options=('staticlibs')
+source=(http://llvm.org/releases/$pkgver/llvm-$pkgver.src.tar.gz
         http://llvm.org/releases/$pkgver/clang-$pkgver.src.tar.gz
-        http://dev.archlinux.org/~foutrelis/sources/compiler-rt/compiler-rt-$pkgver.src.tar.xz
+        http://llvm.org/releases/$pkgver/clang-tools-extra-$pkgver.src.tar.gz
+        http://llvm.org/releases/$pkgver/compiler-rt-$pkgver.src.tar.gz
+        clang-3.3-use-gold-linker.patch
         llvm-Config-config.h
-        llvm-Config-llvm-config.h
-        cindexer-clang-path.patch
-        clang-pure64.patch
-        enable-lto.patch
-        clang-3.1-fix-libprofile_rt.a-location.patch)
-sha256sums=('1ea05135197b5400c1f88d00ff280d775ce778f8f9ea042e25a1e1e734a4b9ab'
-            'ff63e215dcd3e2838ffdea38502f8d35bab17e487f3c3799579961e452d5a786'
-            '563d8a5ef86123ed8775e115ad7f90c1aa3e80f70b4e587f1bccab2c10753558'
+        llvm-Config-llvm-config.h)
+sha256sums=('25a5612d692c48481b9b397e2b55f4870e447966d66c96d655241702d44a2628'
+            '22a9780db3b85a7f2eb9ea1f7f6e00da0249e3d12851e8dea0f62f1783242b1b'
+            'ba85187551ae97fe1c8ab569903beae5ff0900e21233e5eb5389f6ceab1028b4'
+            'f37c89b1383ce462d47537a0245ac798600887a9be9f63073e16b79ed536ab5c'
+            '8240adda155d7961eeb5d07ed50ead10cb7125f70283dff7f1c9fee9df3cea09'
             '312574e655f9a87784ca416949c505c452b819fad3061f2cde8aced6540a19a3'
-            '597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48'
-            '3074df5322900e087377a8e03a02115463ccc0011c25917c2f06df11facd9b92'
-            '288a82fbff17bc554f5863734246500e637882af33ee8511019d5e0d6cd20524'
-            'f7145e203ffb4ce2c01976027f7840a9520e5341a9945f2459b6b11e5422d5b7'
-            '0d32ad283566357ca1bfbeb4cbe6b0b961943b79d3d718ed0435101c05629137')
+            '597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48')
 
-build() {
-  cd "$srcdir/$pkgname-$pkgver.src"
+prepare() {
+  cd "$srcdir/llvm-$pkgver"
 
   # At the present, clang must reside inside the LLVM source code tree to build
   # See http://llvm.org/bugs/show_bug.cgi?id=4840
-  rm -rf tools/clang
-  cp -r "$srcdir/clang-$pkgver.src" tools/clang
+  mv "$srcdir/clang-$pkgver" tools/clang
 
-  rm -rf projects/compiler-rt
-  cp -r "$srcdir/compiler-rt-$pkgver.src" projects/compiler-rt
+  mv "$srcdir/clang-tools-extra-$pkgver" tools/clang/tools/extra
 
-  # Fix symbolic links from OCaml bindings to LLVM libraries
-  sed -i 's:\$(PROJ_libdir):/usr/lib/llvm:' bindings/ocaml/Makefile.ocaml
+  mv "$srcdir/compiler-rt-$pkgver" projects/compiler-rt
 
-  # Fix installation directories, ./configure doesn't seem to set them right
-  sed -i -e 's:\$(PROJ_prefix)/etc/llvm:/etc/llvm:' \
-         -e 's:\$(PROJ_prefix)/lib:$(PROJ_prefix)/lib/llvm:' \
-         -e 's:\$(PROJ_prefix)/docs/llvm:$(PROJ_prefix)/share/doc/llvm:' \
+  # Fix docs installation directory
+  sed -i 's:\$(PROJ_prefix)/docs/llvm:$(PROJ_prefix)/share/doc/llvm:' \
     Makefile.config.in
-  sed -i '/ActiveLibDir = ActivePrefix/s:lib:lib/llvm:' \
-    tools/llvm-config/llvm-config.cpp
-  sed -i 's:LLVM_LIBDIR="${prefix}/lib":LLVM_LIBDIR="${prefix}/lib/llvm":' \
-    autoconf/configure.ac \
-    configure
-
-  # Fix insecure rpath (http://bugs.archlinux.org/task/14017)
-  sed -i 's:$(RPATH) -Wl,$(\(ToolDir\|LibDir\|ExmplDir\))::g' Makefile.rules
-
-  # Fix clang path in CIndexer.cpp (https://bugs.archlinux.org/task/22799)
-  patch -d tools/clang -Np0 -i "$srcdir/cindexer-clang-path.patch"
-
-  if [[ $CARCH == x86_64 ]]; then
-    # Adjust linker path
-    patch -d tools/clang -Np0 -i "$srcdir/clang-pure64.patch"
-  fi
 
-  # Make -flto work
-  # Use gold instead of default linker, and always use the plugin
-  patch -d tools/clang -Np0 -i "$srcdir/enable-lto.patch"
+  # Make -flto work; use ld.gold instead of the default linker
+  patch -d tools/clang -Np1 -i "$srcdir/clang-3.3-use-gold-linker.patch"
+}
 
-  # Fix FS#29984: [clang] -coverage is broken
-  patch -d tools/clang -Np1 -i \
-    "$srcdir/clang-3.1-fix-libprofile_rt.a-location.patch"
+build() {
+  cd "$srcdir/llvm-$pkgver"
 
   # Apply strip option to configure
   _optimized_switch="enable"
   [[ $(check_option strip) == n ]] && _optimized_switch="disable"
 
   # Include location of libffi headers in CPPFLAGS
-  export CPPFLAGS="$CPPFLAGS $(pkg-config --cflags libffi)"
-
-  # Use Python 2
-  mkdir "$srcdir/python2-path"
-  ln -s /usr/bin/python2 "$srcdir/python2-path/python"
-  export PATH="$srcdir/python2-path:$PATH"
+  CPPFLAGS+=" $(pkg-config --cflags libffi)"
 
   # Force the use of GCC instead of clang
   CC=gcc CXX=g++ \
   ./configure \
     --prefix=/usr \
-    --libdir=/usr/lib/llvm \
     --sysconfdir=/etc \
     --enable-shared \
     --enable-libffi \
@@ -104,16 +74,20 @@ build() {
     --disable-debug-runtime \
     --disable-assertions \
     --with-binutils-include=/usr/include \
+    --with-python=/usr/bin/python2 \
     --$_optimized_switch-optimized
 
   make REQUIRES_RTTI=1
+  make -C docs -f Makefile.sphinx man
+  make -C docs -f Makefile.sphinx html
+  make -C tools/clang/docs -f Makefile.sphinx html
 }
 
 package_llvm() {
   pkgdesc="Low Level Virtual Machine"
-  depends=('perl' 'libffi')
+  depends=("llvm-libs=$pkgver-$pkgrel" 'perl')
 
-  cd "$srcdir/$pkgname-$pkgver.src"
+  cd "$srcdir/llvm-$pkgver"
 
   # We move the clang directory out of the tree so it won't get installed and
   # then we bring it back in for the clang package
@@ -123,27 +97,26 @@ package_llvm() {
   make -j1 DESTDIR="$pkgdir" install
   mv "$srcdir/clang" tools
 
+  # The runtime library goes into llvm-libs
+  mv "$pkgdir/usr/lib/libLLVM-$pkgver.so" "$srcdir"
+
   # OCaml bindings go to a separate package
   rm -rf "$srcdir"/{ocaml,ocamldoc}
   mv "$pkgdir"/usr/{lib/ocaml,share/doc/llvm/ocamldoc} "$srcdir"
 
   # Remove duplicate files installed by the OCaml bindings
-  rm "$pkgdir"/usr/{lib/llvm/libllvm*,share/doc/llvm/ocamldoc.tar.gz}
+  rm "$pkgdir"/usr/{lib/libllvm*,share/doc/llvm/ocamldoc.tar.gz}
 
   # Fix permissions of static libs
-  chmod -x "$pkgdir"/usr/lib/llvm/*.a
+  chmod -x "$pkgdir"/usr/lib/*.a
 
   # Get rid of example Hello transformation
-  rm "$pkgdir"/usr/lib/llvm/*LLVMHello.*
-
-  # Add ld.so.conf.d entry
-  install -d "$pkgdir/etc/ld.so.conf.d"
-  echo /usr/lib/llvm >"$pkgdir/etc/ld.so.conf.d/llvm.conf"
+  rm "$pkgdir"/usr/lib/*LLVMHello.*
 
   # Symlink LLVMgold.so into /usr/lib/bfd-plugins
   # (https://bugs.archlinux.org/task/28479)
   install -d "$pkgdir/usr/lib/bfd-plugins"
-  ln -s ../llvm/LLVMgold.so "$pkgdir/usr/lib/bfd-plugins/LLVMgold.so"
+  ln -s ../LLVMgold.so "$pkgdir/usr/lib/bfd-plugins/LLVMgold.so"
 
   if [[ $CARCH == x86_64 ]]; then
     # Needed for multilib (https://bugs.archlinux.org/task/29951)
@@ -155,14 +128,32 @@ package_llvm() {
     done
   fi
 
+  # Install man pages
+  install -d "$pkgdir/usr/share/man/man1"
+  cp docs/_build/man/*.1 "$pkgdir/usr/share/man/man1/"
+
+  # Install html docs
+  cp -r docs/_build/html/* "$pkgdir/usr/share/doc/$pkgname/html/"
+  rm -r "$pkgdir/usr/share/doc/$pkgname/html/_sources"
+
   install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
 }
 
+package_llvm-libs() {
+  pkgdesc="Low Level Virtual Machine (runtime library)"
+  depends=('gcc-libs' 'zlib' 'libffi' 'ncurses')
+
+  install -D "$srcdir/libLLVM-$pkgver.so" "$pkgdir/usr/lib/libLLVM-$pkgver.so"
+
+  install -Dm644 "$srcdir/llvm-$pkgver/LICENSE.TXT" \
+    "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
 package_llvm-ocaml() {
   pkgdesc="OCaml bindings for LLVM"
   depends=("llvm=$pkgver-$pkgrel" 'ocaml')
 
-  cd "$srcdir/llvm-$pkgver.src"
+  cd "$srcdir/llvm-$pkgver"
 
   install -d "$pkgdir"/{usr/lib,usr/share/doc/llvm}
   cp -r "$srcdir/ocaml" "$pkgdir/usr/lib"
@@ -171,7 +162,7 @@ package_llvm-ocaml() {
   # Remove execute bit from static libraries
   chmod -x "$pkgdir"/usr/lib/ocaml/libllvm*.a
 
-  install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/llvm-ocaml/LICENSE"
+  install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
 }
 
 package_clang() {
@@ -181,19 +172,35 @@ package_clang() {
 
   # Fix installation path for clang docs
   sed -i 's:$(PROJ_prefix)/share/doc/llvm:$(PROJ_prefix)/share/doc/clang:' \
-    "$srcdir/llvm-$pkgver.src/Makefile.config"
+    "$srcdir/llvm-$pkgver/Makefile.config"
+
+  cd "$srcdir/llvm-$pkgver/tools/clang"
+
+  # We move the extra tools directory out of the tree so it won't get
+  # installed and then we bring it back in for the clang-tools-extra package
+  mv tools/extra "$srcdir"
 
-  cd "$srcdir/llvm-$pkgver.src/tools/clang"
   make DESTDIR="$pkgdir" install
+  mv "$srcdir/extra" tools/
 
   # Fix permissions of static libs
-  chmod -x "$pkgdir"/usr/lib/llvm/*.a
+  chmod -x "$pkgdir"/usr/lib/*.a
 
   # Revert the path change in case we want to do a repackage later
   sed -i 's:$(PROJ_prefix)/share/doc/clang:$(PROJ_prefix)/share/doc/llvm:' \
-    "$srcdir/llvm-$pkgver.src/Makefile.config"
+    "$srcdir/llvm-$pkgver/Makefile.config"
+
+  # Install html docs
+  cp -r docs/_build/html/* "$pkgdir/usr/share/doc/$pkgname/html/"
+  rm -r "$pkgdir/usr/share/doc/$pkgname/html/_sources"
 
-  install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/clang/LICENSE"
+  # Install Python bindings
+  install -d "$pkgdir/usr/lib/python2.7/site-packages"
+  cp -r bindings/python/clang "$pkgdir/usr/lib/python2.7/site-packages/"
+  python2 -m compileall "$pkgdir/usr/lib/python2.7/site-packages/clang"
+  python2 -O -m compileall "$pkgdir/usr/lib/python2.7/site-packages/clang"
+
+  install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
 }
 
 package_clang-analyzer() {
@@ -201,7 +208,7 @@ package_clang-analyzer() {
   url="http://clang-analyzer.llvm.org/"
   depends=("clang=$pkgver-$pkgrel" 'python2')
 
-  cd "$srcdir/llvm-$pkgver.src/tools/clang"
+  cd "$srcdir/llvm-$pkgver/tools/clang"
 
   install -d "$pkgdir"/usr/{bin,lib/clang-analyzer}
   for _tool in scan-{build,view}; do
@@ -209,6 +216,14 @@ package_clang-analyzer() {
     ln -s /usr/lib/clang-analyzer/$_tool/$_tool "$pkgdir/usr/bin/"
   done
 
+  # scan-build looks for clang within the same directory
+  ln -s /usr/bin/clang "$pkgdir/usr/lib/clang-analyzer/scan-build/"
+
+  # Relocate man page
+  install -d "$pkgdir/usr/share/man/man1"
+  mv "$pkgdir/usr/lib/clang-analyzer/scan-build/scan-build.1" \
+    "$pkgdir/usr/share/man/man1/"
+
   # Use Python 2
   sed -i \
     -e 's|env python$|&2|' \
@@ -220,7 +235,22 @@ package_clang-analyzer() {
   python2 -m compileall "$pkgdir/usr/lib/clang-analyzer"
   python2 -O -m compileall "$pkgdir/usr/lib/clang-analyzer"
 
-  install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/clang-analyzer/LICENSE"
+  install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_clang-tools-extra() {
+  pkgdesc="Extra tools built using Clang's tooling APIs"
+  url="http://clang.llvm.org/"
+  depends=("clang=$pkgver-$pkgrel")
+
+  cd "$srcdir/llvm-$pkgver/tools/clang/tools/extra"
+
+  make DESTDIR="$pkgdir" install
+
+  # Fix permissions of static libs
+  chmod -x "$pkgdir"/usr/lib/*.a
+
+  install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
 }
 
 # vim:set ts=2 sw=2 et:
diff --git a/abs/extra/llvm/bug-9869-operator-h-c++0x.patch b/abs/extra/llvm/bug-9869-operator-h-c++0x.patch
deleted file mode 100644
index b95d7d7..0000000
--- a/abs/extra/llvm/bug-9869-operator-h-c++0x.patch
+++ /dev/null
@@ -1,57 +0,0 @@
---- llvm/trunk/include/llvm/Operator.h	2011/02/07 16:40:21	125006
-+++ llvm/trunk/include/llvm/Operator.h	2011/05/08 01:59:22	131062
-@@ -186,28 +186,46 @@
- };
- 
- class AddOperator
--  : public ConcreteOperator<OverflowingBinaryOperator, Instruction::Add> {};
-+  : public ConcreteOperator<OverflowingBinaryOperator, Instruction::Add> {
-+  ~AddOperator(); // DO NOT IMPLEMENT
-+};
- class SubOperator
--  : public ConcreteOperator<OverflowingBinaryOperator, Instruction::Sub> {};
-+  : public ConcreteOperator<OverflowingBinaryOperator, Instruction::Sub> {
-+  ~SubOperator(); // DO NOT IMPLEMENT
-+};
- class MulOperator
--  : public ConcreteOperator<OverflowingBinaryOperator, Instruction::Mul> {};
-+  : public ConcreteOperator<OverflowingBinaryOperator, Instruction::Mul> {
-+  ~MulOperator(); // DO NOT IMPLEMENT
-+};
- class ShlOperator
--  : public ConcreteOperator<OverflowingBinaryOperator, Instruction::Shl> {};
-+  : public ConcreteOperator<OverflowingBinaryOperator, Instruction::Shl> {
-+  ~ShlOperator(); // DO NOT IMPLEMENT
-+};
- 
-   
- class SDivOperator
--  : public ConcreteOperator<PossiblyExactOperator, Instruction::SDiv> {};
-+  : public ConcreteOperator<PossiblyExactOperator, Instruction::SDiv> {
-+  ~SDivOperator(); // DO NOT IMPLEMENT
-+};
- class UDivOperator
--  : public ConcreteOperator<PossiblyExactOperator, Instruction::UDiv> {};
-+  : public ConcreteOperator<PossiblyExactOperator, Instruction::UDiv> {
-+  ~UDivOperator(); // DO NOT IMPLEMENT
-+};
- class AShrOperator
--  : public ConcreteOperator<PossiblyExactOperator, Instruction::AShr> {};
-+  : public ConcreteOperator<PossiblyExactOperator, Instruction::AShr> {
-+  ~AShrOperator(); // DO NOT IMPLEMENT
-+};
- class LShrOperator
--  : public ConcreteOperator<PossiblyExactOperator, Instruction::LShr> {};
-+  : public ConcreteOperator<PossiblyExactOperator, Instruction::LShr> {
-+  ~LShrOperator(); // DO NOT IMPLEMENT
-+};
-   
-   
-   
- class GEPOperator
-   : public ConcreteOperator<Operator, Instruction::GetElementPtr> {
-+  ~GEPOperator(); // DO NOT IMPLEMENT
-+
-   enum {
-     IsInBounds = (1 << 0)
-   };
diff --git a/abs/extra/llvm/cindexer-clang-path.patch b/abs/extra/llvm/cindexer-clang-path.patch
deleted file mode 100644
index ddaab69..0000000
--- a/abs/extra/llvm/cindexer-clang-path.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- tools/libclang/CIndexer.cpp.orig	2011-04-07 13:08:24.000000000 +0300
-+++ tools/libclang/CIndexer.cpp	2011-04-07 13:11:52.224884642 +0300
-@@ -80,6 +80,7 @@ std::string CIndexer::getClangResourcesP
-   
-   // We now have the CIndex directory, locate clang relative to it.
-   LibClangPath.eraseComponent();
-+  LibClangPath.eraseComponent();
- #endif
-   
-   LibClangPath.appendComponent("clang");
diff --git a/abs/extra/llvm/clang-3.1-fix-libprofile_rt.a-location.patch b/abs/extra/llvm/clang-3.1-fix-libprofile_rt.a-location.patch
deleted file mode 100644
index 080aa4f..0000000
--- a/abs/extra/llvm/clang-3.1-fix-libprofile_rt.a-location.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -upr clang-3.1.src.orig/lib/Driver/Tools.cpp clang-3.1.src/lib/Driver/Tools.cpp
---- clang-3.1.src.orig/lib/Driver/Tools.cpp	2012-04-19 00:32:25.000000000 +0300
-+++ clang-3.1.src/lib/Driver/Tools.cpp	2012-05-23 21:12:08.000000000 +0300
-@@ -193,7 +193,7 @@ static void addProfileRT(const ToolChain
-   // libprofile_rt.so. We used to use the -l:libprofile_rt.a syntax, but that is
-   // not supported by old linkers.
-   std::string ProfileRT =
--    std::string(TC.getDriver().Dir) + "/../lib/libprofile_rt.a";
-+    std::string(TC.getDriver().Dir) + "/../lib/llvm/libprofile_rt.a";
- 
-   CmdArgs.push_back(Args.MakeArgString(ProfileRT));
- }
diff --git a/abs/extra/llvm/clang-3.3-use-gold-linker.patch b/abs/extra/llvm/clang-3.3-use-gold-linker.patch
new file mode 100644
index 0000000..76905a6
--- /dev/null
+++ b/abs/extra/llvm/clang-3.3-use-gold-linker.patch
@@ -0,0 +1,12 @@
+diff -upr cfe.src.orig/lib/Driver/ToolChains.cpp cfe.src/lib/Driver/ToolChains.cpp
+--- cfe.src.orig/lib/Driver/ToolChains.cpp	2013-06-08 16:17:19.000000000 +0300
++++ cfe.src/lib/Driver/ToolChains.cpp	2013-06-08 16:17:33.000000000 +0300
+@@ -2220,7 +2220,7 @@ Linux::Linux(const Driver &D, const llvm
+   PPaths.push_back(Twine(GCCInstallation.getParentLibPath() + "/../" +
+                          GCCInstallation.getTriple().str() + "/bin").str());
+ 
+-  Linker = GetProgramPath("ld");
++  Linker = GetProgramPath("ld.gold");
+ 
+   Distro Distro = DetectDistro(Arch);
+ 
diff --git a/abs/extra/llvm/clang-plugin-loader-registry.patch b/abs/extra/llvm/clang-plugin-loader-registry.patch
deleted file mode 100644
index f46eb9f..0000000
--- a/abs/extra/llvm/clang-plugin-loader-registry.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -upr llvm-2.7.orig/autoconf/ExportMap.map llvm-2.7/autoconf/ExportMap.map
---- llvm-2.7.orig/autoconf/ExportMap.map	2010-02-25 00:33:41.000000000 +0200
-+++ llvm-2.7/autoconf/ExportMap.map	2010-05-10 14:14:22.000000000 +0300
-@@ -2,6 +2,7 @@
- 	global: main;
- 		__progname;
- 		environ;
-+		_ZN4llvm8RegistryIN5clang14FrontendActionENS_14RegistryTraitsIS2_EEE4HeadE;
- 
- 	local: *;
- };
diff --git a/abs/extra/llvm/clang-pure64.patch b/abs/extra/llvm/clang-pure64.patch
deleted file mode 100644
index 9bbbfaa..0000000
--- a/abs/extra/llvm/clang-pure64.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: lib/Driver/Tools.cpp
-===================================================================
---- lib/Driver/Tools.cpp	(revision 123373)
-+++ lib/Driver/Tools.cpp	(working copy)
-@@ -3306,7 +3306,7 @@
-     else if (ToolChain.getArch() == llvm::Triple::ppc64)
-       CmdArgs.push_back("/lib64/ld64.so.1");
-     else
--      CmdArgs.push_back("/lib64/ld-linux-x86-64.so.2");
-+      CmdArgs.push_back("/lib/ld-linux-x86-64.so.2");
-   }
- 
-   CmdArgs.push_back("-o");
diff --git a/abs/extra/llvm/clang-toolchains-gcc-versions.patch b/abs/extra/llvm/clang-toolchains-gcc-versions.patch
deleted file mode 100644
index 7e00837..0000000
--- a/abs/extra/llvm/clang-toolchains-gcc-versions.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -upr clang-2.9.orig/lib/Driver/ToolChains.cpp clang-2.9/lib/Driver/ToolChains.cpp
---- clang-2.9.orig/lib/Driver/ToolChains.cpp	2011-03-21 23:29:27.000000000 +0200
-+++ clang-2.9/lib/Driver/ToolChains.cpp	2011-04-08 00:03:34.000000000 +0300
-@@ -1449,7 +1449,7 @@ Linux::Linux(const HostInfo &Host, const
-       GccTriple = "i586-suse-linux";
-   }
- 
--  const char* GccVersions[] = {"4.5.2", "4.5.1", "4.5", "4.4.5", "4.4.4",
-+  const char* GccVersions[] = {"4.6.1", "4.5.2", "4.5.1", "4.5", "4.4.5", "4.4.4",
-                                "4.4.3", "4.4", "4.3.4", "4.3.3", "4.3.2",
-                                "4.3", "4.2.4", "4.2.3", "4.2.2", "4.2.1",
-                                "4.2"};
diff --git a/abs/extra/llvm/enable-lto.patch b/abs/extra/llvm/enable-lto.patch
deleted file mode 100644
index 3205fbf..0000000
--- a/abs/extra/llvm/enable-lto.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Index: lib/Driver/ToolChains.cpp
-===================================================================
---- lib/Driver/ToolChains.cpp	(revision 123373)
-+++ lib/Driver/ToolChains.cpp	(working copy)
-@@ -1398,7 +1398,7 @@
-   PPaths.push_back(Twine(GCCInstallation.getParentLibPath() + "/../" +
-                          GCCInstallation.getTriple() + "/bin").str());
- 
--  Linker = GetProgramPath("ld");
-+  Linker = GetProgramPath("ld.gold");
- 
-   LinuxDistro Distro = DetectLinuxDistro(Arch);
- 
-Index: lib/Driver/Tools.cpp
-===================================================================
---- lib/Driver/Tools.cpp	(revision 123373)
-+++ lib/Driver/Tools.cpp	(working copy)
-@@ -3412,11 +3412,11 @@
-   // Tell the linker to load the plugin. This has to come before AddLinkerInputs
-   // as gold requires -plugin to come before any -plugin-opt that -Wl might
-   // forward.
--  if (D.IsUsingLTO(Args) || Args.hasArg(options::OPT_use_gold_plugin)) {
-+  // if (D.IsUsingLTO(Args) || Args.hasArg(options::OPT_use_gold_plugin)) {
-     CmdArgs.push_back("-plugin");
--    std::string Plugin = ToolChain.getDriver().Dir + "/../lib/LLVMgold.so";
-+    std::string Plugin = ToolChain.getDriver().Dir + "/../lib/llvm/LLVMgold.so";
-     CmdArgs.push_back(Args.MakeArgString(Plugin));
--  }
-+  // }
- 
-   AddLinkerInputs(ToolChain, Inputs, Args, CmdArgs);
- }
diff --git a/abs/extra/llvm/llvm-3.1-2.src.tar.gz b/abs/extra/llvm/llvm-3.1-2.src.tar.gz
deleted file mode 120000
index 4ea98f7..0000000
--- a/abs/extra/llvm/llvm-3.1-2.src.tar.gz
+++ /dev/null
@@ -1 +0,0 @@
-/data/pkg_repo/src_packages/llvm-3.1-2.src.tar.gz
\ No newline at end of file
-- 
cgit v0.12