From 39edd22a148e864a14dc4767c2c9d082b73a8007 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Wed, 12 Nov 2008 11:04:26 -0800
Subject: Added DVB firmware package.  This should include most if not all
 firmware needed for various tuners. Modified Fluxbox keys file to reflect
 /etc/rc.d/ instead of /etc/init.d/. Added ivtv-utils.

---
 abs/core-testing/fluxbox/PKGBUILD    | 2 +-
 abs/core-testing/fluxbox/keys        | 6 +++---
 abs/core-testing/ivtv-utils/PKGBUILD | 6 +++---
 3 files changed, 7 insertions(+), 7 deletions(-)

diff --git a/abs/core-testing/fluxbox/PKGBUILD b/abs/core-testing/fluxbox/PKGBUILD
index a3b077d..6735ad0 100644
--- a/abs/core-testing/fluxbox/PKGBUILD
+++ b/abs/core-testing/fluxbox/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=fluxbox
 pkgver=1.0.0
-pkgrel=4
+pkgrel=5
 pkgdesc="A lightweight and highly-configurable window manager"
 arch=('i686' 'x86_64')
 url="http://www.fluxbox.org"
diff --git a/abs/core-testing/fluxbox/keys b/abs/core-testing/fluxbox/keys
index f1a0059..06e5f21 100644
--- a/abs/core-testing/fluxbox/keys
+++ b/abs/core-testing/fluxbox/keys
@@ -20,9 +20,9 @@ Mod1 F12 :Workspace 12
 Mod1 x :ExecCommand xterm -fn *18*
 Mod1 s :ExecCommand mythtv-setup
 Mod1 m :ExecCommand mythfrontend
-Mod1 1 :ExecCommand sudo /etc/init.d/mythtv-backend start
-Mod1 2 :ExecCommand sudo /etc/init.d/mythtv-backend stop
-Mod1 3 :ExecCommand sudo /etc/init.d/mythtv-backend restart
+Mod1 1 :ExecCommand sudo /etc/rc.d/mythtv-backend start
+Mod1 2 :ExecCommand sudo /etc/rc.d/mythtv-backend stop
+Mod1 3 :ExecCommand sudo /etc/rc.d/mythtv-backend restart
 Mod1 h :ExecCommand MythVantage -h
 Mod1 Control u :ExecCommand killall -9 unclutter
 
diff --git a/abs/core-testing/ivtv-utils/PKGBUILD b/abs/core-testing/ivtv-utils/PKGBUILD
index d8e13c6..5b272b1 100644
--- a/abs/core-testing/ivtv-utils/PKGBUILD
+++ b/abs/core-testing/ivtv-utils/PKGBUILD
@@ -4,10 +4,10 @@
 
 pkgname=ivtv-utils
 pkgver=1.0.3
-pkgrel=1
-_kernver=2.6.23-ARCH
+pkgrel=2
+_kernver=2.6.26-ARCH
 pkgdesc="Non-mainline kernel drivers and userspace utilities for Hauppauge PVR cards"
-arch=(i686 x86_64)
+arch=('i586' 'i686' 'x86_64')
 license=('GPL')
 url="http://ivtvdriver.org"
 source=("http://dl.ivtvdriver.org/ivtv/archive/1.0.x/ivtv-$pkgver.tar.gz" \
-- 
cgit v0.12


From f54287894befd1a86d9d3ed97e24f96d4fe34695 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Wed, 12 Nov 2008 11:28:28 -0800
Subject: PKGBUILD for DVB firmware.

---
 abs/core-testing/dvb-firmware/PKGBUILD | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
 create mode 100644 abs/core-testing/dvb-firmware/PKGBUILD

diff --git a/abs/core-testing/dvb-firmware/PKGBUILD b/abs/core-testing/dvb-firmware/PKGBUILD
new file mode 100644
index 0000000..6ad5707
--- /dev/null
+++ b/abs/core-testing/dvb-firmware/PKGBUILD
@@ -0,0 +1,18 @@
+# $Id: PKGBUILD 5936 2008-07-21 20:24:16Z thomas $
+# Maintainer: Cecil Watson<knoppmyth@gmail.com>
+
+pkgname=dvb-firmware
+pkgver=1
+pkgrel=1
+pkgdesc="Firmware for DVB cards"
+arch=('i586' 'i686' 'x86_64')
+license=('GPL2')
+url="http://linuxtv.org/"
+source=(ftp://ftp.knoppmyth.net/R6/sources/dvb-firmware.tar.bz2)
+md5sums=('d58a3f2b556cf32ac5ab68cd86fcf6ec')
+
+build() {
+  cd $startdir/src/
+  mkdir -p $startdir/pkg/lib/firmware
+  cp -a *.fw $startdir/pkg/lib/firmware
+}
-- 
cgit v0.12


From 3d0637fe6b6ea9e03bf02d881cce63a811402a15 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Wed, 12 Nov 2008 20:37:18 -0800
Subject: Bumped mythdb-initial version for testing. Modified LinHES-run to
 launch mythtv-setup from an xterm. Bumped LinHES-System version to reflect
 change.

---
 abs/core-testing/LinHES-system/LinHES-run              | 4 ++--
 abs/core-testing/LinHES-system/PKGBUILD                | 2 +-
 abs/core-testing/mythtv/stable/mythdb-initial/PKGBUILD | 2 +-
 3 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/abs/core-testing/LinHES-system/LinHES-run b/abs/core-testing/LinHES-system/LinHES-run
index 72c3991..0fc10fd 100644
--- a/abs/core-testing/LinHES-system/LinHES-run
+++ b/abs/core-testing/LinHES-system/LinHES-run
@@ -31,9 +31,9 @@ then
         if [ ! $STATUS = 2 ]
         then
                 sudo sv stop mythbackend
-                /usr/bin/mythtv-setup
+                xterm -e /usr/bin/mythtv-setup
                 sudo sv start mythbackend
-                #maybe run mythfilldatabase here
+                nice -n 19 mythfilldatabase --quiet &
         fi
         rm ~/.configure
         fi
diff --git a/abs/core-testing/LinHES-system/PKGBUILD b/abs/core-testing/LinHES-system/PKGBUILD
index bb1b9d2..0660745 100644
--- a/abs/core-testing/LinHES-system/PKGBUILD
+++ b/abs/core-testing/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=1.0
-pkgrel=6
+pkgrel=8
 arch=('i686')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
diff --git a/abs/core-testing/mythtv/stable/mythdb-initial/PKGBUILD b/abs/core-testing/mythtv/stable/mythdb-initial/PKGBUILD
index bf2c94c..8fda243 100755
--- a/abs/core-testing/mythtv/stable/mythdb-initial/PKGBUILD
+++ b/abs/core-testing/mythtv/stable/mythdb-initial/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythdb-initial
 pkgver=1
-pkgrel=5
+pkgrel=6
 pkgdesc="setup the initial mythtv database for linhes"
 url=""
 license=""
-- 
cgit v0.12


From 960af583bf9a21d62a7dc745ddd8c93acb50381f Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Wed, 12 Nov 2008 20:40:16 -0800
Subject: Bumped mythdb-initial version for testing. Modified LinHES-run to
 launch mythtv-setup from an xterm. Launch mythfilldatabase in the background.
 Bumped LinHES-System version to reflect change.

---
 abs/core-testing/LinHES-system/LinHES-run              | 4 ++--
 abs/core-testing/LinHES-system/PKGBUILD                | 2 +-
 abs/core-testing/mythtv/stable/mythdb-initial/PKGBUILD | 2 +-
 3 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/abs/core-testing/LinHES-system/LinHES-run b/abs/core-testing/LinHES-system/LinHES-run
index 72c3991..0fc10fd 100644
--- a/abs/core-testing/LinHES-system/LinHES-run
+++ b/abs/core-testing/LinHES-system/LinHES-run
@@ -31,9 +31,9 @@ then
         if [ ! $STATUS = 2 ]
         then
                 sudo sv stop mythbackend
-                /usr/bin/mythtv-setup
+                xterm -e /usr/bin/mythtv-setup
                 sudo sv start mythbackend
-                #maybe run mythfilldatabase here
+                nice -n 19 mythfilldatabase --quiet &
         fi
         rm ~/.configure
         fi
diff --git a/abs/core-testing/LinHES-system/PKGBUILD b/abs/core-testing/LinHES-system/PKGBUILD
index bb1b9d2..0660745 100644
--- a/abs/core-testing/LinHES-system/PKGBUILD
+++ b/abs/core-testing/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=1.0
-pkgrel=6
+pkgrel=8
 arch=('i686')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
diff --git a/abs/core-testing/mythtv/stable/mythdb-initial/PKGBUILD b/abs/core-testing/mythtv/stable/mythdb-initial/PKGBUILD
index bf2c94c..8fda243 100755
--- a/abs/core-testing/mythtv/stable/mythdb-initial/PKGBUILD
+++ b/abs/core-testing/mythtv/stable/mythdb-initial/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythdb-initial
 pkgver=1
-pkgrel=5
+pkgrel=6
 pkgdesc="setup the initial mythtv database for linhes"
 url=""
 license=""
-- 
cgit v0.12