From 1381cb92cc0e3bcf1adf11c0aa9d94abcab91d5b Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Tue, 3 Feb 2009 22:59:16 -0800
Subject: Initial inclusion of XE multi-system emulator.

---
 abs/extra-testing/xe/PKGBUILD   | 19 +++++++++++++++++++
 abs/extra-testing/xe/xe.install | 17 +++++++++++++++++
 2 files changed, 36 insertions(+)
 create mode 100644 abs/extra-testing/xe/PKGBUILD
 create mode 100644 abs/extra-testing/xe/xe.install

diff --git a/abs/extra-testing/xe/PKGBUILD b/abs/extra-testing/xe/PKGBUILD
new file mode 100644
index 0000000..e87d7a3
--- /dev/null
+++ b/abs/extra-testing/xe/PKGBUILD
@@ -0,0 +1,19 @@
+# $Id: PKGBUILD 5936 2008-07-21 20:24:16Z thomas $
+# Maintainer: Cecil Watson<knoppmyth@gmail.com>
+
+pkgname=xe
+pkgver=2.16.1
+pkgrel=1
+pkgdesc="A multi system emulator, that emulates many console and handheld video game systems."
+arch=('i686' 'x86_64')
+url="http://www.xe-emulator.com"
+source=(http://www.xe-emulator.com/files/xe-x86-32-bin.2.16.1.tar.bz2)
+install=xe.install
+build() {
+  cd $startdir/src/xe-x86
+  make
+  mkdir -p $startdir/pkg/usr/bin
+  mkdir -p $startdir/pkg/usr/lib/xe
+  mkdir -p $startdir/pkg/usr/lib/xe/bios
+  cp -rf xe modules rc manual.html $startdir/pkg/usr/lib/xe
+}
diff --git a/abs/extra-testing/xe/xe.install b/abs/extra-testing/xe/xe.install
new file mode 100644
index 0000000..0c70f17
--- /dev/null
+++ b/abs/extra-testing/xe/xe.install
@@ -0,0 +1,17 @@
+# arg 1:  the new package version
+post_install() {
+	ln -s /usr/lib/xe/xe /usr/bin/xe
+}
+# arg 1:  the new package version
+# arg 2:  the old package version
+#post_upgrade() {
+#}
+
+# arg 1:  the old package version
+post_remove() {
+	rm -fr /usr/bin/xe
+#}
+
+op=$1
+shift
+$op $*
-- 
cgit v0.12