From 0baf997ee6184fe49968687d93205b34323af16f Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 10 Nov 2012 19:47:45 -0600
Subject: runit-scripts: add exec to mythexpress and remyth.  Without the exec 
 sv stop doesn't work

---
 abs/core/runit-scripts/PKGBUILD                              | 2 +-
 abs/core/runit-scripts/runitscripts/services/mythexpress/run | 2 +-
 abs/core/runit-scripts/runitscripts/services/remyth/run      | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 68921e0..b9ec500 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=runit-scripts
 pkgver=2.1.1
-pkgrel=87
+pkgrel=88
 pkgdesc="collection of startup scripts for runit"
 url="http://smarden.org/runit/"
 license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/services/mythexpress/run b/abs/core/runit-scripts/runitscripts/services/mythexpress/run
index d902721..db3eba1 100755
--- a/abs/core/runit-scripts/runitscripts/services/mythexpress/run
+++ b/abs/core/runit-scripts/runitscripts/services/mythexpress/run
@@ -5,5 +5,5 @@ export TERM=linux
 . /etc/rc.d/functions
 /sbin/svwaitup -s 10 /service/avahi
 stat_runit "Starting MythExpress"
-su  http -s/bin/bash -c "node /usr/mythexpress/app.js"
+exec su  http -s/bin/bash -c "node /usr/mythexpress/app.js"
 
diff --git a/abs/core/runit-scripts/runitscripts/services/remyth/run b/abs/core/runit-scripts/runitscripts/services/remyth/run
index 599a8aa..768ec13 100755
--- a/abs/core/runit-scripts/runitscripts/services/remyth/run
+++ b/abs/core/runit-scripts/runitscripts/services/remyth/run
@@ -6,5 +6,5 @@ export TERM=linux
 /sbin/svwaitup -s 10 /service/avahi
 
 stat_runit "Starting ReMyth"
-su  http -s/bin/bash -c "node /usr/remyth/server.js"
+exec su  http -s/bin/bash -c "node /usr/remyth/server.js"
 
-- 
cgit v0.12